It is currently Thu Aug 21, 2014 7:55 pm

Validation failure, user id doesn't match executable: CLOSED

View active topics

All times are UTC - 6 hours


Post new topic Reply to topic  [ 12 posts ]  Go to page 1, 2  Next
Author Message
 PostPosted: Tue Jan 31, 2012 3:02 pm   

Joined: Fri Jan 20, 2012 12:38 pm
Posts: 14
We are attempting to build a native iOS app, using Mobione on Windows. We have generated and used the .csr, downloaded the AppleWWDRCA.cer, distribution_identity.cer, private.key, and mobileprovision files. Now, when we use the "iOS Build Application" dialog, it fails with the following error:

Validation failure: user identity 'iPhone Distribution: MyCompany' doesn't match executable identity 'iPhone Distribution: MyCompany, Inc.'

Can anyone tell us where this user identity is defined? How might we have differing identities?

Thanks.


Top
 Profile  
 PostPosted: Tue Jan 31, 2012 5:28 pm   

Joined: Mon Oct 25, 2010 6:25 am
Posts: 3058
@leifinseattle

Giving this a look now. Will follow up shortly.

_________________
Wayne - MobiOne Mobile Team


Top
 Profile  
 PostPosted: Tue Jan 31, 2012 5:34 pm   

Joined: Fri Jan 20, 2012 12:38 pm
Posts: 14
We have been able to work around this by recreating our certificates through the Provisioning Portal and Keychain Access on the Mac. We then exported a p12 file and used this on Windows to create our build. That all worked fine, but now we're encountering an error when we attempt to upload the IPA using the Application Loader. It says the certificate is not valid, or not a distribution certificate. Can you tell us anything about this? The build number is 131103.

Thanks.


Top
 Profile  
 PostPosted: Tue Jan 31, 2012 5:53 pm   

Joined: Mon Nov 21, 2011 8:14 am
Posts: 13
@leifinseattle,

I have looked over Build #131103 and it appears that the certificate in your p12 file does not match the certificate in your mobile provision file. If you re-generate a certificate on the Provisioning Portal you must also re-generate all the provisioning profiles tied to that certificate.

Hope this helps,
Lonnie
Genuitec Mobile Team


Top
 Profile  
 PostPosted: Tue Jan 31, 2012 6:11 pm   

Joined: Fri Jan 20, 2012 12:38 pm
Posts: 14
That worked! We forgot to regenerate the mobile provision file to keep in sync with the new distribution certificate. Thanks very much.


Top
 Profile  
 PostPosted: Tue Jan 31, 2012 6:16 pm   

Joined: Mon Oct 25, 2010 6:25 am
Posts: 3058
@leifinseattle

Congrats!

_________________
Wayne - MobiOne Mobile Team


Top
 Profile  
 PostPosted: Wed Mar 07, 2012 3:12 pm   

Joined: Sat Feb 04, 2012 7:18 pm
Posts: 12
Hi,

We have also run into this same issue. Apple required us to redo our Developer program information to straighten out a mistake with our company name. In doing so, we had to create an entirely new Apple Developer program ID. After doing this, we redid all of our certificates and provisioning profiles by first deleting all of the old ones, and regenerating our Certificate Signing Request and Private Key using your web page. We then generated a new Certificate in our IOS Provisioning Portal and downloaded that. We also created new App Ids, reentered our devices, and created a brand new Provisioning Profile. We are getting this error:
Error Log: Wed Mar 07 14:55:51 CST 2012
Validation failure: user identity 'iPhone Distribution: Company Name' doesn't match executable identity 'iPhone Distribution: Company Name, Inc.'
(I have replaced our actual company name with the text "Company Name" above)

The build number is 374031

Is the company name or some other file cached somewhere that might be holding our old company name? I have looked at the certificate file, and it is issued to Company Name, Inc.

Could you help?


Top
 Profile  
 PostPosted: Wed Mar 07, 2012 4:11 pm   

Joined: Mon Oct 25, 2010 6:25 am
Posts: 3058
@DCoudron

I will have our build specialist help dig in on this problem.

Q: is your apple developer membership an individual developer membership or an enterprise developer membership?

_________________
Wayne - MobiOne Mobile Team


Top
 Profile  
 PostPosted: Wed Mar 07, 2012 5:00 pm   

Joined: Sat Feb 04, 2012 7:18 pm
Posts: 12
Hi Wayne,

We have a company membership, but it is not the Enterprise Membership. It is the same level we were previously signed up as. Here is what is says for Account Type: Company/Organization. Does that give you the information that you are looking for?

Regards,


Top
 Profile  
 PostPosted: Thu Mar 08, 2012 9:40 am   

Joined: Mon Oct 25, 2010 6:25 am
Posts: 3058
@DCoudron

Thanks for the info. I have escalated this case with the dev team. Hope to know something shortly.

_________________
Wayne - MobiOne Mobile Team


Top
 Profile  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ]  Go to page 1, 2  Next

All times are UTC - 6 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Style originally created by Volize © 2003 • Redesigned SkyLine by MartectX © 2008 - 2009