MyEclipse Enterprise workbench 2017- offline maven

  1. MyEclipse IDE
  2.  > 
  3. Maven for MyEclipse (Maven4MyEclipse)

Tagged: ,

Viewing 16 post (of 16 total)
  • Author
  • #672482 Reply

    Brian Fernandes


    If you look at your log file now, it is now complaining about version 3.1, not 2.6. Please check the log file for errors.
    Caused by: org.eclipse.aether.resolution.ArtifactResolutionException: Failure to transfer org.apache.maven.plugins:maven-resources-plugin:pom:3.1 from https://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced. Original error: Could not transfer artifact org.apache.maven.plugins:maven-resources-plugin:pom:3.1 from/to central (https://repo.maven.apache.org/maven2): PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

    The crux of the issue is that you’re not able to connect to Maven central – this is more of an issue with your proxy or firewall, so not something we can fix, unfortunately. You could try changing your settings.xml to use the http://insecure.repo1.maven.org/ repository instead – this is a version of Maven central repo available over HTTP. If your connection problems are due to HTTPS, this repo change might help resolve the issue.

    Something Swapna had suggested earlier about using Maven in offline mode with your local repository. Did you try these steps to correctly set it up?

    Alternatively, you could configure Maven to work offline. Go to Window > Preferences > Maven and enable Offline. If you have set the local repo right in the settings.xml, then please go to Window > Preferences > Maven > User Settings and recheck if the local repository path is picked up correctly. If it is listed correctly, then reindex and check if it works.

Viewing 16 post (of 16 total)
Reply To: MyEclipse Enterprise workbench 2017- offline maven

You must be logged in to post in the forum log in