Genuitec » All Posts https://www.genuitec.com/forums/topics/devstyle/getting-help/feed/ Thu, 22 Feb 2018 00:35:04 +0000 http://bbpress.org/?v=2.5.14-6684 en-US https://www.genuitec.com/forums/topic/dev-style-is-launching-when-running-eclipse-plugin-junits/#post-550208 <![CDATA[Reply To: Dev style is launching when running eclipse plugin junits]]> https://www.genuitec.com/forums/topic/dev-style-is-launching-when-running-eclipse-plugin-junits/#post-550208 Thu, 01 Feb 2018 16:19:12 +0000 villaa19 Cool, thanks Aaron!

]]>
https://www.genuitec.com/forums/topic/dev-style-is-launching-when-running-eclipse-plugin-junits/#post-550204 <![CDATA[Reply To: Dev style is launching when running eclipse plugin junits]]> https://www.genuitec.com/forums/topic/dev-style-is-launching-when-running-eclipse-plugin-junits/#post-550204 Thu, 01 Feb 2018 15:56:39 +0000 aaronlonin Looks like using JUnit’s run configuration is the best way in this case (see screenshot). Looks like JUnit won’t read the arguments from eclipse.ini file, apologies.

Have a good day!
Aaron Lara

Attachments:
You must be logged in to view attached files.
]]>
https://www.genuitec.com/forums/topic/dev-style-is-launching-when-running-eclipse-plugin-junits/#post-550197 <![CDATA[Reply To: Dev style is launching when running eclipse plugin junits]]> https://www.genuitec.com/forums/topic/dev-style-is-launching-when-running-eclipse-plugin-junits/#post-550197 Thu, 01 Feb 2018 15:07:31 +0000 villaa19 I tried both way and the only way it works is in the vm arguments once the junit has been run. I tried using it in the eclipse.ini and that doesn’t inhibit it like you said it would

]]>
https://www.genuitec.com/forums/topic/dev-style-is-launching-when-running-eclipse-plugin-junits/#post-549478 <![CDATA[Reply To: Dev style is launching when running eclipse plugin junits]]> https://www.genuitec.com/forums/topic/dev-style-is-launching-when-running-eclipse-plugin-junits/#post-549478 Sat, 27 Jan 2018 19:55:43 +0000 aaronlonin In either of them should work.

Cheers!

]]>
https://www.genuitec.com/forums/topic/dev-style-is-launching-when-running-eclipse-plugin-junits/#post-549389 <![CDATA[Reply To: Dev style is launching when running eclipse plugin junits]]> https://www.genuitec.com/forums/topic/dev-style-is-launching-when-running-eclipse-plugin-junits/#post-549389 Fri, 26 Jan 2018 23:42:35 +0000 villaa19 Oh ok thanks for the quick response. So are you saying I add this to the eclipse.ini or the vm arguments under the run/debug configuration?

]]>
https://www.genuitec.com/forums/topic/dev-style-is-launching-when-running-eclipse-plugin-junits/#post-549368 <![CDATA[Reply To: Dev style is launching when running eclipse plugin junits]]> https://www.genuitec.com/forums/topic/dev-style-is-launching-when-running-eclipse-plugin-junits/#post-549368 Fri, 26 Jan 2018 22:08:33 +0000 aaronlonin Hello @villaa19. There’s a System property you can use to disable the DevStyle Startup. You can try adding -Dgenuitec.disable.devstyle.startup=true to your VM Arguments.
Let us know any concern.

Cheers,
Aaron Lara

]]>
https://www.genuitec.com/forums/topic/dev-style-is-launching-when-running-eclipse-plugin-junits/#post-549360 <![CDATA[Dev style is launching when running eclipse plugin junits]]> https://www.genuitec.com/forums/topic/dev-style-is-launching-when-running-eclipse-plugin-junits/#post-549360 Fri, 26 Jan 2018 20:24:23 +0000 villaa19 I’m trying to debug as junit plugin and and dev style is popping up like if I just started eclipse.
Is there a way that I can disable this for junits? I would even disable devStyle plugin but I can’t do that without getting rid of darkest dark theme. Please help

Attachments:
You must be logged in to view attached files.
]]>
https://www.genuitec.com/forums/topic/cant-install-darkestdark-theme-under-neon-2-nxp-mcuxpress/#post-549226 <![CDATA[Reply To: Cant install DarkestDark theme under Neon 2 (NXP MCUXpress)]]> https://www.genuitec.com/forums/topic/cant-install-darkestdark-theme-under-neon-2-nxp-mcuxpress/#post-549226 Thu, 25 Jan 2018 08:19:42 +0000 support-swapna Thomas,

Glad that it works. Thank you for getting back to us.
Please let us know if you see any issues with Darkest Dark.

–Swapna
MyEclipse Support

]]>
https://www.genuitec.com/forums/topic/cant-install-darkestdark-theme-under-neon-2-nxp-mcuxpress/#post-549221 <![CDATA[Reply To: Cant install DarkestDark theme under Neon 2 (NXP MCUXpress)]]> https://www.genuitec.com/forums/topic/cant-install-darkestdark-theme-under-neon-2-nxp-mcuxpress/#post-549221 Thu, 25 Jan 2018 06:57:15 +0000 thomas-boehmer Hi Swapna,

many thanks for your solution. Now it works.

]]>
https://www.genuitec.com/forums/topic/cant-install-darkestdark-theme-under-neon-2-nxp-mcuxpress/#post-548920 <![CDATA[Reply To: Cant install DarkestDark theme under Neon 2 (NXP MCUXpress)]]> https://www.genuitec.com/forums/topic/cant-install-darkestdark-theme-under-neon-2-nxp-mcuxpress/#post-548920 Tue, 23 Jan 2018 09:25:38 +0000 support-swapna Thomas,

Sorry that you are seeing issues installing Darkest Dark. The MCUXpress IDE is missing one of the required dependencies.

Here are the steps to install Darkest Dark successfully to MCUXpress :

1. Open the IDE and go to Window > Preferences > Install/Update > Available Software Sites. Click ‘Add’ and enter the update site url for Neon in the Location field : http://download.eclipse.org/releases/neon/

2. Once done, go to the Eclipse Marketplace and retry installing the Darkest Dark plugin.

Please let us know how it works for you.

–Swapna
MyEclipse Support

]]>
https://www.genuitec.com/forums/topic/cant-install-darkestdark-theme-under-neon-2-nxp-mcuxpress/#post-548914 <![CDATA[Cant install DarkestDark theme under Neon 2 (NXP MCUXpress)]]> https://www.genuitec.com/forums/topic/cant-install-darkestdark-theme-under-neon-2-nxp-mcuxpress/#post-548914 Tue, 23 Jan 2018 06:50:48 +0000 thomas-boehmer When i try install the plugin under Marktplace or update site following error occured:

Cannot complete the install because one or more required items could not be found.
Software being installed: DevStyle (includes Darkest Dark Theme) 1.10.0.201712201137 (com.genuitec.eclipse.theming.feature.feature.group 1.10.0.201712201137)
Missing requirement: Webclipse Common Core Platform Utilities 13.0.2.201710312111 (com.genuitec.eclipse.core.common.platform 13.0.2.201710312111) requires ‘package org.apache.commons.httpclient 3.1.0’ but it could not be found
Cannot satisfy dependency:
From: MyEclipse Core 15.0.0.201712201137 (com.genuitec.eclipse.core 15.0.0.201712201137)
To: bundle com.genuitec.eclipse.core.common.platform 13.0.2
Cannot satisfy dependency:
From: EditorMinimap 1.9.0.201712150904 (com.genuitec.eclipse.inlinesearch 1.9.0.201712150904)
To: bundle com.genuitec.eclipse.monitor 0.0.0
Cannot satisfy dependency:
From: Webclipse UDM 13.0.0.201711231100 (com.genuitec.eclipse.monitor 13.0.0.201711231100)
To: bundle com.genuitec.eclipse.core 13.0.0
Cannot satisfy dependency:
From: DevStyle (includes Darkest Dark Theme) 1.10.0.201712201137 (com.genuitec.eclipse.theming.feature.feature.group 1.10.0.201712201137)
To: com.genuitec.eclipse.inlinesearch [1.9.0.201712150904]

]]>
https://www.genuitec.com/forums/topic/why-did-this-install-itself-without-asking-me/#post-544872 <![CDATA[Reply To: Why did this install itself without asking me]]> https://www.genuitec.com/forums/topic/why-did-this-install-itself-without-asking-me/#post-544872 Mon, 11 Dec 2017 15:41:24 +0000 Brian Fernandes Ajay,

Sorry to see you go. The updates are intentionally automatic (auto updates can be disabled on the Window > Preferences > Webclipse) page, and you have been probably receiving updates ever since you installed the Slack plugin.

On restarting, you should have been taken through a customization step that allows you to choose theme, though someone already pointed out earlier that the ability to keep our default theme was not obvious – we will be fixing this.

Now, using Eclipse Color Themes with DevStyle enabled causes a large number of issues, which is why it has been intentionally disabled. However, I do see your point about not being able to use these settings if you’re not interested in using our themes, and we’ll look at what we can do internally to address this.

]]>
https://www.genuitec.com/forums/topic/why-did-this-install-itself-without-asking-me/#post-544823 <![CDATA[Reply To: Why did this install itself without asking me]]> https://www.genuitec.com/forums/topic/why-did-this-install-itself-without-asking-me/#post-544823 Sun, 10 Dec 2017 11:38:12 +0000 ajaymaske I wasn’t prompted for this update either, I started Eclipse one day as I usually do and got an update then restarted. When Eclipse restarted everything was changed out – not good. I do use the slack plugin but that was it. I used Jeeeyul’s theme with the Eclipse Color Themes for the editor (specifically the monokai theme). The one thing that I specifically do not like and is really annoying is this whole Dark Theme/Light Theme and only being able to select the listed editor themes under each – kind of like “you’ll do things our way only”. I prefer a normal looking ide with the editor theme being monokai. With this DevStyle this makes it impossible.

Also, there is no longer “General->Appearance->Color Themes” under preferences. So even switching back to Jeeeyul’s Theme I can no longer select an editor theme.

So now, I’m having to figure out how to get this uninstalled so I can get Eclipse back what was useful for me.

Got it all back… had to uninstall the slack genuitec plugin, which also uninstalled the DevStyle (which wasn’t listed). oh and the “General->Appearance->Color Themes” also came back … so I’m good now …

]]>
https://www.genuitec.com/forums/topic/console-buttons-doesnt-exist-anymore/#post-544660 <![CDATA[Reply To: Console buttons doesn't exist anymore]]> https://www.genuitec.com/forums/topic/console-buttons-doesnt-exist-anymore/#post-544660 Thu, 07 Dec 2017 15:19:41 +0000 aaronlonin @romuloaps, Thanks for contacting us! Those buttons are contextual to the console itself, DevStyle does not add or remove buttons. It would be useful if you prived more details about your installation:

– Eclipse version and type of package, or if you are using Angular IDE.
– Other relevant plugins installed
– OS and Arch

Cheers!
Aaron Lara

]]>
https://www.genuitec.com/forums/topic/console-buttons-doesnt-exist-anymore/#post-544630 <![CDATA[Console buttons doesn't exist anymore]]> https://www.genuitec.com/forums/topic/console-buttons-doesnt-exist-anymore/#post-544630 Wed, 06 Dec 2017 23:43:43 +0000 romuloaps Hi guys!

After started using the DevStyle, I realized that two buttons of Console view are not there:
“Show console on error” and “Show console on any output”.

If I change the console, choosing the “m2 console”, they are still there. But they aren’t in the “normal” console, the one that logs the server output for example.

How can I fix this?
Thank you!

Attachments:
You must be logged in to view attached files.
]]>