Genuitec » All Posts https://www.genuitec.com/forums/topics/devstyle/theme-problems/feed/ Sat, 26 May 2018 18:08:02 +0000 http://bbpress.org/?v=2.5.14-6684 en-US https://www.genuitec.com/forums/topic/lots-of-error-entries-in-eclipse-error-log-on-eclipse-photon-m7/#post-588611 <![CDATA[Reply To: lots of error entries in eclipse error log on eclipse photon M7]]> https://www.genuitec.com/forums/topic/lots-of-error-entries-in-eclipse-error-log-on-eclipse-photon-m7/#post-588611 Fri, 25 May 2018 18:40:56 +0000 timwebb Alef,

Thanks for sharing this with us. We’ve put in a fix for Eclipse Photon M7 and later that will avoid these being spammed to your log. In addition, we’ve fixed a compatibility issue with DevStyle for Photon on Windows.

I’m attaching a zip, which if you extract into your Eclipse/plugins area, you can then get up and going and hopefully no longer see all those circular error messages!

Important notes:

1. The version #s must match exactly. If you aren’t on the latest version of DevStyle, there may b a mismatch and the fix won’t work.
2. You need to run the first time after replacing the plugins with -clean added to your eclipse.ini file. Make sure to add the clean argument before -vmargs.
3. After replacing the plugins, and adding the -clean, you should be good to go to run Eclipse without issue.

Please do let us know how this works for you — we’ll be having a hotfix update for DevStyle mid-next week with this fix for other users who may be using Photon. Have a great weekend!

Attachments:
You must be logged in to view attached files.
]]>
https://www.genuitec.com/forums/topic/lots-of-error-entries-in-eclipse-error-log-on-eclipse-photon-m7/#post-588327 <![CDATA[lots of error entries in eclipse error log on eclipse photon M7]]> https://www.genuitec.com/forums/topic/lots-of-error-entries-in-eclipse-error-log-on-eclipse-photon-m7/#post-588327 Thu, 24 May 2018 10:19:28 +0000 alef75 each time I’m starting eclipse photon M7 with devstyle darkest dark, eclipse logs lots of error related to
MESSAGE Circular reference detected trying to get service {org.osgi.framework.hooks.weaving.WeavingHook}={service.id=36, service.bundleid=12, service.scope=bundle, component.name=Genuitec Patches Weaver, component.id=0}

see attachment for full log

Attachments:
You must be logged in to view attached files.
]]>
https://www.genuitec.com/forums/topic/eclipse-leaking-swt-gdi-handles-with-darkest-dark-enabled/#post-587659 <![CDATA[Reply To: Eclipse leaking SWT GDI handles with darkest dark enabled]]> https://www.genuitec.com/forums/topic/eclipse-leaking-swt-gdi-handles-with-darkest-dark-enabled/#post-587659 Tue, 22 May 2018 15:37:35 +0000 support-swapna mbisanz,

Glad that the issue is resolved. Thank you for getting back to us.
Please let us know if you see any other issues.

–Swapna
Genuitec Support

]]>
https://www.genuitec.com/forums/topic/eclipse-leaking-swt-gdi-handles-with-darkest-dark-enabled/#post-587598 <![CDATA[Reply To: Eclipse leaking SWT GDI handles with darkest dark enabled]]> https://www.genuitec.com/forums/topic/eclipse-leaking-swt-gdi-handles-with-darkest-dark-enabled/#post-587598 Tue, 22 May 2018 07:34:43 +0000 mbisanz Can confirm. Had the same issue (Eclipse Oxygen.3a with DevStyle), but with the latest version (1.11.0.201804271459) the issues seems to be resolved. No more ui freezes / crashes, and the number of GDI handles does not grow.

Thanks!

]]>
https://www.genuitec.com/forums/topic/outline-view-for-new-classes-is-not-black/#post-586775 <![CDATA[Reply To: Outline View for new classes is not black]]> https://www.genuitec.com/forums/topic/outline-view-for-new-classes-is-not-black/#post-586775 Fri, 18 May 2018 14:44:55 +0000 aaronlonin @kagemaru, Apologies for the lack of attention to this issue, the team has been quiet busy lately. We are going to work on a fix for this for the next release. Thanks for the reminder!

Cheers!
Aaron Lara

]]>
https://www.genuitec.com/forums/topic/outline-view-for-new-classes-is-not-black/#post-586660 <![CDATA[Reply To: Outline View for new classes is not black]]> https://www.genuitec.com/forums/topic/outline-view-for-new-classes-is-not-black/#post-586660 Fri, 18 May 2018 05:06:24 +0000 kagemaru @aaronlonin, any news as to when this bug will be fixed or how far along it is? The issue seems to be in progress for 10 months, which does seem somewhat long 🙂

]]>
https://www.genuitec.com/forums/topic/egit-history-highlight-color-low-contrast/#post-585694 <![CDATA[Reply To: EGit History highlight color low contrast]]> https://www.genuitec.com/forums/topic/egit-history-highlight-color-low-contrast/#post-585694 Fri, 11 May 2018 19:29:24 +0000 creative-resort Thank you,
I’ve tested various themes, with and without aero.

Only if I use the old-style Windows 2000 look, the highlight remains dark.
With Windows 7 basis (without aero) as well as using aero-designs, it does not work.

Weird thing is that it’s only the history view,
all other highlights remain as they were.

]]>
https://www.genuitec.com/forums/topic/egit-history-highlight-color-low-contrast/#post-585661 <![CDATA[Reply To: EGit History highlight color low contrast]]> https://www.genuitec.com/forums/topic/egit-history-highlight-color-low-contrast/#post-585661 Fri, 11 May 2018 15:51:55 +0000 support-swapna Hi,

It looks like you are using an optimized version of a Windows 7 theme, maybe with no Aero enabled. Such themes are known to provide limited support for SWT theming. In regular Windows themes the selection highlight is not bright. Attached is the screenshot for your reference.

Can you please switch your OS theme and check how it works?

–Swapna
Genuitec Support

Attachments:
You must be logged in to view attached files.
]]>
https://www.genuitec.com/forums/topic/ssh-console-view-background-remains-white/#post-585658 <![CDATA[Reply To: ssh console view background remains white]]> https://www.genuitec.com/forums/topic/ssh-console-view-background-remains-white/#post-585658 Fri, 11 May 2018 15:38:49 +0000 creative-resort This shell console is part of the PDT PHP Developers distribution of Eclipse.

]]>
https://www.genuitec.com/forums/topic/egit-history-highlight-color-low-contrast/#post-585640 <![CDATA[Reply To: EGit History highlight color low contrast]]> https://www.genuitec.com/forums/topic/egit-history-highlight-color-low-contrast/#post-585640 Fri, 11 May 2018 13:46:56 +0000 creative-resort Sure,
I’m on Windows 7 Professional, Service Pack 1

]]>
https://www.genuitec.com/forums/topic/can-not-see-last-line-in-r-console/#post-585629 <![CDATA[Reply To: Can not see last line in R Console]]> https://www.genuitec.com/forums/topic/can-not-see-last-line-in-r-console/#post-585629 Fri, 11 May 2018 13:19:10 +0000 support-swapna Jorgen,

Thank you for the screenshots. I have raised a bug for the dev team to work on it.
We will keep you posted when the fix is out.

Apologies for inconvenience caused.

–Swapna
Genuitec Support

]]>
https://www.genuitec.com/forums/topic/egit-history-highlight-color-low-contrast/#post-585628 <![CDATA[Reply To: EGit History highlight color low contrast]]> https://www.genuitec.com/forums/topic/egit-history-highlight-color-low-contrast/#post-585628 Fri, 11 May 2018 13:17:15 +0000 support-swapna Hi,

Sorry that you are seeing this issue. Thank you for the detailed steps and the screenshot.
I could not replicate the problem at my end with Eclipse Oxygen on Windows 10.

Can you please also share with us your OS and version details to help us investigate further?

–Swapna
Genuitec Support

]]>
https://www.genuitec.com/forums/topic/ssh-console-view-background-remains-white/#post-585627 <![CDATA[Reply To: ssh console view background remains white]]> https://www.genuitec.com/forums/topic/ssh-console-view-background-remains-white/#post-585627 Fri, 11 May 2018 13:16:22 +0000 support-swapna Hi,

Sorry that you are seeing this issue. Thank you for the screenshot.

Relevant Plugins Installed: Plugin+Version, Plugin+Version

Can you please share with us more details about the plugins you installed to get the Command Shell Console option in the Console view?

–Swapna
Genuitec Support

]]>
https://www.genuitec.com/forums/topic/egit-history-highlight-color-low-contrast/#post-585603 <![CDATA[EGit History highlight color low contrast]]> https://www.genuitec.com/forums/topic/egit-history-highlight-color-low-contrast/#post-585603 Fri, 11 May 2018 08:26:23 +0000 creative-resort Hi,
here is another issue:

When the Git History view is not in focus, the active line is highlighted too bright.

IDE Package: Eclipse for PHP Developers
IDE Version: Oxygen.3a Release (4.7.3a) Build id: 20180405-1200
Plugin: Git integration for Eclipse 4.9.2.201712150930-r

Steps to reproduce the issue:
1. Open view: History
2. enter a Git repository, so the History view is populated
3. click on a commit entry in history view
4. click outside of the History view (e.g. on an editor view)
5. The selected line in the History view becomes brigher, resulting in a low contrast between highlight and text

see screenshot

kind regards

Attachments:
You must be logged in to view attached files.
]]>
https://www.genuitec.com/forums/topic/ssh-console-view-background-remains-white/#post-585598 <![CDATA[ssh console view background remains white]]> https://www.genuitec.com/forums/topic/ssh-console-view-background-remains-white/#post-585598 Fri, 11 May 2018 08:11:20 +0000 creative-resort Hi,
I’ve discovered the following problem:

ssh console view background remains white

IDE Package: Eclipse for PHP Developers
IDE Version: Oxygen.3a Release (4.7.3a) Build id: 20180405-1200
Relevant Plugins Installed: Plugin+Version, Plugin+Version
Steps to reproduce the issue:
1. Open view: General > Console
2. add new Command Shell console, select SSH connection and connect to a server via SSH
3. the background is white

see screenshots

kind regards

Attachments:
You must be logged in to view attached files.
]]>