Genuitec » All Posts https://www.genuitec.com/forums/topics/myeclipse/java-ee-development-ejb-jsp-struts-xdoclet-etc/feed/ Wed, 16 Jan 2019 02:53:22 +0000 http://bbpress.org/?v=2.5.14-6684 en-US https://www.genuitec.com/forums/topic/why-does-restting-selection-take-so-long-timeabout-5-to-10min/page/2/#post-605558 <![CDATA[Reply To: Why does 'Restting Selection' take so long time(about 5 to 10min)?]]> https://www.genuitec.com/forums/topic/why-does-restting-selection-take-so-long-timeabout-5-to-10min/page/2/#post-605558 Fri, 21 Dec 2018 06:26:32 +0000 support-swapna Jack,

We have fixed the ‘Resetting selection’ problem in our latest release, MyEclipse 2018.12.0.
Please update from Help > Check for Updates and let us know how it works for you.

–Swapna
Genuitec Support

]]>
https://www.genuitec.com/forums/topic/why-does-restting-selection-take-so-long-timeabout-5-to-10min/#post-603438 <![CDATA[Reply To: Why does 'Restting Selection' take so long time(about 5 to 10min)?]]> https://www.genuitec.com/forums/topic/why-does-restting-selection-take-so-long-timeabout-5-to-10min/#post-603438 Fri, 23 Nov 2018 14:53:44 +0000 Brian Fernandes Jack,

Sorry to hear you’re experiencing a similar delay – this issue is under renewed investigation right now, but we’re still having a hard time reproducing it.

In your particular case though, we noticed a large number of Code Mining threads active, far more than there should be, and we wonder if your delays are actually being caused by this instead. Could you go to Preferences > Java > Editor > Code Minings and turn off the Show References and Show Implementations checkboxes. Restart your IDE and let us know if you still experience the issue.

If you still do, please let us know if your projects have the Spring facet enabled, by checking the Project Properties > Project Facets property page. Also, did you experience this issue with prior versions of MyEclipse?

]]>
https://www.genuitec.com/forums/topic/why-does-restting-selection-take-so-long-timeabout-5-to-10min/#post-603409 <![CDATA[Reply To: Why does 'Restting Selection' take so long time(about 5 to 10min)?]]> https://www.genuitec.com/forums/topic/why-does-restting-selection-take-so-long-timeabout-5-to-10min/#post-603409 Thu, 22 Nov 2018 23:26:15 +0000 jackwong06 have the same problem and it slows down my productivity a lot. Please fix it.

background:
Windows 10 Pro
me myeclipse version CI 2018.9.0
build id: 16.0.0-20180903

attach the dump files you requested.

in my case, IDE get slower and slower to response doing “Resetting Selection” until it crashed.

Attachments:
You must be logged in to view attached files.
]]>
https://www.genuitec.com/forums/topic/project-will-not-migrate/#post-599364 <![CDATA[Reply To: Project will not migrate]]> https://www.genuitec.com/forums/topic/project-will-not-migrate/#post-599364 Wed, 26 Sep 2018 14:06:26 +0000 Adam Dembowski That did the trick! Thank you so much for your help.

]]>
https://www.genuitec.com/forums/topic/project-will-not-migrate/#post-599355 <![CDATA[Reply To: Project will not migrate]]> https://www.genuitec.com/forums/topic/project-will-not-migrate/#post-599355 Wed, 26 Sep 2018 11:24:14 +0000 support-tony Adam,

Thanks for the files. We were able to replicate the problem from them. We did find that there was a file missing from the .settings folder, though it’s not clear why, if it was a valid MyEclipse 10.x project. However, you could try adding the file to that folder and check if the migration now works.

The file is org.eclipse.wst.common.component which should be in the .settings folder of the project and should contain (based on the files you sent us):

Please let us know how you get on with this.

]]>
https://www.genuitec.com/forums/topic/project-will-not-migrate/#post-599323 <![CDATA[Reply To: Project will not migrate]]> https://www.genuitec.com/forums/topic/project-will-not-migrate/#post-599323 Tue, 25 Sep 2018 20:03:11 +0000 Adam Dembowski Version: CI 2018.9.0
Build id: 16.0.0-20180903

]]>
https://www.genuitec.com/forums/topic/project-will-not-migrate/#post-599321 <![CDATA[Reply To: Project will not migrate]]> https://www.genuitec.com/forums/topic/project-will-not-migrate/#post-599321 Tue, 25 Sep 2018 20:00:38 +0000 Adam Dembowski Sorry about that, here you go.

Attachments:
You must be logged in to view attached files.
]]>
https://www.genuitec.com/forums/topic/project-will-not-migrate/#post-599315 <![CDATA[Reply To: Project will not migrate]]> https://www.genuitec.com/forums/topic/project-will-not-migrate/#post-599315 Tue, 25 Sep 2018 19:25:36 +0000 Brian Fernandes Adam,

Thank you for the files. Just wanted to confirm that these are are the files before you’ve attempted migration? (i.e. If migration did not work, did you restore the project from version control and send those files?) Even if not, there should be enough here to help us replicate, but I’d like to be clear on the state of the resources.

Could you also please confirm the version of MyEclipse you are using? You can see a build Id mentioned at Help > About.

]]>
https://www.genuitec.com/forums/topic/project-will-not-migrate/#post-599307 <![CDATA[Reply To: Project will not migrate]]> https://www.genuitec.com/forums/topic/project-will-not-migrate/#post-599307 Tue, 25 Sep 2018 18:03:58 +0000 Adam Dembowski other files

Attachments:
You must be logged in to view attached files.
]]>
https://www.genuitec.com/forums/topic/project-will-not-migrate/#post-599305 <![CDATA[Reply To: Project will not migrate]]> https://www.genuitec.com/forums/topic/project-will-not-migrate/#post-599305 Tue, 25 Sep 2018 18:02:28 +0000 Adam Dembowski Let me try this

Attachments:
You must be logged in to view attached files.
]]>
https://www.genuitec.com/forums/topic/project-will-not-migrate/#post-599304 <![CDATA[Reply To: Project will not migrate]]> https://www.genuitec.com/forums/topic/project-will-not-migrate/#post-599304 Tue, 25 Sep 2018 18:01:08 +0000 Adam Dembowski Sure thing.

]]>
https://www.genuitec.com/forums/topic/project-will-not-migrate/#post-599303 <![CDATA[Reply To: Project will not migrate]]> https://www.genuitec.com/forums/topic/project-will-not-migrate/#post-599303 Tue, 25 Sep 2018 17:43:40 +0000 Brian Fernandes Adam,

Sorry to hear you’re having issues with the migration.

Would it be possible for you to share with us the contents of the .settings folder, the .project and .classpath files before migration so we can try and replicate locally?

In addition, can you tell us what version of MyEclipse you are using right now?

]]>
https://www.genuitec.com/forums/topic/project-will-not-migrate/#post-599300 <![CDATA[Project will not migrate]]> https://www.genuitec.com/forums/topic/project-will-not-migrate/#post-599300 Tue, 25 Sep 2018 17:24:11 +0000 Adam Dembowski I have a J2EE project from myeclipse 10 that will not migrate and the error log is not very helpful.

This is the error I am getting:
com.genuitec.eclipse.core.GenuitecCoreException: Operation “Migrate ME Project references and deployment settings to Deployment Assembly” has failed to perform migration actions. Error for project ZebraServer.
at com.genuitec.eclipse.migration.core.project.internal.MigratingProject.internalPerformMigration(MigratingProject.java:693)
at com.genuitec.eclipse.migration.core.internal.MigratingObject.performMigration(MigratingObject.java:758)
at com.genuitec.eclipse.migration.core.internal.ObjectsMigrationJob$1.run(ObjectsMigrationJob.java:164)
at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2289)
at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2311)
at com.genuitec.eclipse.migration.core.internal.ObjectsMigrationJob.run(ObjectsMigrationJob.java:159)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:60)
Caused by: java.lang.NullPointerException
at com.genuitec.eclipse.migration.myeclipse.da.ModuleProjectConfigurationDelegate.init(ModuleProjectConfigurationDelegate.java:101)
at com.genuitec.eclipse.migration.myeclipse.da.ModuleProjectConfigurationDelegate.<init>(ModuleProjectConfigurationDelegate.java:87)
at com.genuitec.eclipse.migration.myeclipse.da.WebProjectConfigurationDelegate.<init>(WebProjectConfigurationDelegate.java:35)
at com.genuitec.eclipse.migration.myeclipse.da.DeploymentAssemblyConfiguratorFactory.create(DeploymentAssemblyConfiguratorFactory.java:20)
at com.genuitec.eclipse.migration.myeclipse.MEDeploymentAssemblyMigration.perform(MEDeploymentAssemblyMigration.java:49)
at com.genuitec.eclipse.migration.core.project.AbstractProjectMigrationDelegate.perform(AbstractProjectMigrationDelegate.java:107)
at com.genuitec.eclipse.migration.core.internal.MigrationOperation.perform(MigrationOperation.java:110)
at com.genuitec.eclipse.migration.core.project.internal.MigratingProject.internalPerformMigration(MigratingProject.java:687)
… 6 more

]]>
https://www.genuitec.com/forums/topic/why-does-restting-selection-take-so-long-timeabout-5-to-10min/#post-598871 <![CDATA[Reply To: Why does 'Restting Selection' take so long time(about 5 to 10min)?]]> https://www.genuitec.com/forums/topic/why-does-restting-selection-take-so-long-timeabout-5-to-10min/#post-598871 Mon, 24 Sep 2018 06:24:17 +0000 Brian Fernandes We were unable to replicate the issue in our testing environments, unfortunately. While the “Resetting selection” job does indeed run, it does not lock the IDE, and we were unable to get into a state described by other users on this thread. It is possible that something else is going awry, your current experience sounds terrible.

1) Could you get us some thread dumps while your IDE is locked? This might shed some light on what processes are causing it to lock up.

To take a thread dump, you will need to run: jstack -l 9000 > dump1.txt
Please replace 9000 with the PID of the Eclipse process, the jstack program can be found in the bin directory of any JDK installation. If you can generate 3-4 dumps (sent to different files, of course) during the period of slowness, and attach those files here, that could help a great deal.

2) If you haven’t already tried it, does removing the Spring facet fix the problem? This is not a solution of course, but would help us ascertain whether the problem is still being caused by the Spring tech.

We would really love to fix this problem, so your input would be invaluable. Apologies for the inconvenience caused.

]]>
https://www.genuitec.com/forums/topic/why-does-restting-selection-take-so-long-timeabout-5-to-10min/#post-598855 <![CDATA[Reply To: Why does 'Restting Selection' take so long time(about 5 to 10min)?]]> https://www.genuitec.com/forums/topic/why-does-restting-selection-take-so-long-timeabout-5-to-10min/#post-598855 Sun, 23 Sep 2018 21:03:13 +0000 amkd Has this issue been solved yet? I experience the same when I was using 2017 CI, trying to build the project will cause ‘resetting selection’ to run for several minutes. But that’s tolerable to me. However, now I’m using 2018 CI, and ‘resetting selection’ will be triggered every once when I change the code! I did not enable build automatically and didn’t even save the file, still, like even I haven’t finished typing for just one line and MyEclipse will start running validation/compilation for minutes and stops response on mouse hover and/or content assist.

]]>