Skip to main content

Prerequisites

To get started with Copilot4Eclipse, you will need:

  • An Eclipse IDE or Eclipse-based product based on Eclipse 4.28 (2023-06 release) or a more recent version.
  • A GitHub Copilot subscription (Individual level or Business level)
tip

MyEclipse 2023.1 is compatible with Copilot4Eclipse.

tip

If you are new to GitHub Copilot, use the free 30 day trial period for new subscribers to see if it is right for you.