Typescript Editor is not working after recent update

  1. CodeMix & Angular IDE > Webclipse 1.x Help

Tagged: 

This topic contains 24 replies, has 3 voices, and was last updated by 1 year, 10 months ago.

Viewing 15 posts - 1 through 15 (of 25 total)
  • Author
    Posts
  • #596241 Reply

    brajarrod
    Participant

    This is the error that is happening now:

    Implementation of project facet webclipse.typescript could not be found. Functionality will be limited.

    Attachments:
    You must be logged in to view attached files.
    #596245 Reply

    brajarrod
    Participant

    I also found this error: missing builder com.genuitec.eclipse.typescript.typeScriptBuilder

    #596249 Reply

    Brian Fernandes
    Moderator

    Brandon,

    This could be the result of some installation corruption after the update – your log, unfortunately, did not indicate any failures, or suggest what could be wrong.

    1) Can you let me know when you updated?
    2) Under Preferences > Webclipse – what’s the Build Id displayed?
    3) Can you try starting Eclipse with the -clean argument and see if that resolves the issue?
    (see https://www.genuitec.com/forums/topic/troubleshoot-using-the-clean-command-line-argument/ if you need help with -clean).

    #596251 Reply

    brajarrod
    Participant

    This is the sts.ini file:

    -clean
    -startup
    plugins/org.eclipse.equinox.launcher_1.3.201.v20161025-1711.jar
    –launcher.library
    plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.401.v20161122-1740
    -product
    org.springsource.sts.ide
    –launcher.defaultAction
    openFile
    -vmargs
    -Dosgi.requiredJavaVersion=1.8
    -Xms1024m
    -Dosgi.module.lock.timeout=10
    -Dorg.eclipse.swt.browser.IEVersion=10001
    -Xmx4096m
    -Xms512m
    -XX:PermSize=256m
    -XX:MaxPermSize=512m

    The -clean option is already in there.
    I updated today.
    Build Id: 1.11.0.201808131414

    #596252 Reply

    Brian Fernandes
    Moderator

    Brandon,

    Clear – yes, that is today’s build. Can you clear the error log and restart, see if it logs any additional info about the break?

    The most expedient solution at this time would be to try an install of Webclispe into a fresh STS base install, or try to uninstall Webclipse from your current STS installat and install it again. That should hopefully get the plugins installed and started correctly.

    #596253 Reply

    brajarrod
    Participant

    Attached new log file.
    I have already uninstalled and re-installed Angular-IDE several times. It has not fixed the issue yet. It’s as though typscript was just erased from the ide. I don’t see it in preferences or editors anymore. .ts files just open in default txt files.

    Attachments:
    You must be logged in to view attached files.
    #596256 Reply

    timwebb
    Keymaster

    Brandon,

    A couple quick questions:

    1. Does doing right-click Open With on the file show any other editors?
    2. If you go to Help > About > Installation Details and filter by typescript, do you see any plugins listed?

    Could you share your bundles.info file from Eclipse/configuration/org.eclipse.equinox.simpleconfigurator?

    Thanks and sorry you are running into this!

    #596258 Reply

    brajarrod
    Participant

    1. Yes, several. None say typescript tho.
    2. Yes, there is one typescript plugin.

    #596296 Reply

    timwebb
    Keymaster

    If you could share either here or at support@genuitec.com your bundles.info, it would be helpful to further diagnose what is wrong with your installation.

    #596314 Reply

    brajarrod
    Participant

    Sorry, I thought I uploaded it.
    The forum would not let me upload it, so I just emailed it to support@genuitec.com.

    • This reply was modified 1 year, 11 months ago by  brajarrod.
    #596320 Reply

    brajarrod
    Participant

    I tried to create a new Angular project and I got this error:

    java.lang.NoClassDefFoundError: com/genuitec/eclipse/typescript/facet/TypeScriptInstallDataModelProvider
    at com.genuitec.eclipse.modernweb.angular2.ui.project.NewAngularProjectDataModelOperation.execute(NewAngularProjectDataModelOperation.java:98)
    at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl$1.run(DataModelPausibleOperationImpl.java:385)
    at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2240)
    at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2267)
    at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.runOperation(DataModelPausibleOperationImpl.java:410)
    at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.runOperation(DataModelPausibleOperationImpl.java:360)
    at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.doExecute(DataModelPausibleOperationImpl.java:247)
    at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.executeImpl(DataModelPausibleOperationImpl.java:219)
    at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.cacheThreadAndContinue(DataModelPausibleOperationImpl.java:89)
    at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.execute(DataModelPausibleOperationImpl.java:207)
    at org.eclipse.wst.common.frameworks.internal.datamodel.ui.DataModelWizard$1CatchThrowableRunnableWithProgress.run(DataModelWizard.java:220)
    at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:119)
    Caused by: java.lang.ClassNotFoundException: com.genuitec.eclipse.typescript.facet.TypeScriptInstallDataModelProvider cannot be found by com.genuitec.eclipse.modernweb.angular2.ui_1.11.0.201808061657
    at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:461)
    at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:372)
    at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:364)
    at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:161)
    at java.lang.ClassLoader.loadClass(Unknown Source)

    #596322 Reply

    timwebb
    Keymaster

    Thanks, received it here.

    The installation looks consistent in terms of the plugins available. We’re brainstorming here what might result in the editor being unavailable — just to verify, could you point your IDE to a new workspace, import or create a simple TS project, and see if you can then edit the TypeScript file with our tools?

    I’ll let you know what else we come up with to help diagnose.

    #596326 Reply

    brajarrod
    Participant

    Ok. Created a new workspace and tried to create a new angular project. I got the same error:

    java.lang.NoClassDefFoundError: com/genuitec/eclipse/typescript/facet/TypeScriptInstallDataModelProvider
    at com.genuitec.eclipse.modernweb.angular2.ui.project.NewAngularProjectDataModelOperation.execute(NewAngularProjectDataModelOperation.java:98)
    at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl$1.run(DataModelPausibleOperationImpl.java:385)
    at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2240)
    at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2267)
    at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.runOperation(DataModelPausibleOperationImpl.java:410)
    at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.runOperation(DataModelPausibleOperationImpl.java:360)
    at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.doExecute(DataModelPausibleOperationImpl.java:247)
    at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.executeImpl(DataModelPausibleOperationImpl.java:219)
    at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.cacheThreadAndContinue(DataModelPausibleOperationImpl.java:89)
    at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.execute(DataModelPausibleOperationImpl.java:207)
    at org.eclipse.wst.common.frameworks.internal.datamodel.ui.DataModelWizard$1CatchThrowableRunnableWithProgress.run(DataModelWizard.java:220)
    at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:119)
    Caused by: java.lang.ClassNotFoundException: com.genuitec.eclipse.typescript.facet.TypeScriptInstallDataModelProvider cannot be found by com.genuitec.eclipse.modernweb.angular2.ui_1.11.0.201808061657
    at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:461)
    at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:372)
    at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:364)
    at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:161)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    … 12 more

    #596328 Reply

    brajarrod
    Participant

    Does the version of the typescript facet need to match the plugin version?
    This is in the org.eclipse.wst.common.project.facet.core.xml :

    The plugin version is 2.5.3.2018080917

    #596329 Reply

    brajarrod
    Participant

    Also, the configuration has the typescript plugin still in starting mode:

    com.genuitec.eclipse.typescript (2.5.3.201808091743) “TypeScript” [Starting]

    Not Active or Resolved.

    Could that be an issue?

Viewing 15 posts - 1 through 15 (of 25 total)
Reply To: Typescript Editor is not working after recent update

This topic is marked as closed to new replies, however your posting capabilities still allow you to do so.

You must be logged in to post in the forum log in