Can't read JavaDoc popup

  1. DevStyle > Theme Problems

This topic contains 15 replies, has 6 voices, and was last updated by  daniel.caminada 1 week, 2 days ago.

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #581133 Reply

    buddybu
    Participant

    Eclipse JEE
    Eclipse ID 4.7.3a

    DevStyle Config:
    Dark Green/Primary Colors/RecogEyes

    Open any java file and hover over an import or class or type to get the javadoc to display and you will get the popup with mostly black text on a black background.

    Attachments:
    You must be logged in to view attached files.
    #581137 Reply

    buddybu
    Participant

    When I go back to the Eclipse built in dark theme. I can read the popups.

    Attachments:
    You must be logged in to view attached files.
    #581141 Reply

    aaronlonin
    Moderator

    @buddybu, Sorry yuou are having this issue. Could you let us know the OS you are running on so we can investigate further? Also, can you try switching to a different workspace just to make sure the issue persists there?

    #581146 Reply

    buddybu
    Participant

    Windows 10 Pro

    And yes, if I switch to a new workspace, it works just fine. What do you need to know about my existing workspace that will help you diagnose the issue?

    #581148 Reply

    aaronlonin
    Moderator

    Excelent! My guess is that some preference was not properly written or was overriden by another plugin (Oomph for example sometimes messes with preferences). One thing we can try in your existing workspace is to go to DevStyle > Color Themes preference page and enable “Force colors”, then apply. This should override existing color preferences and hopefully fix this issue.

    Let me know if the issue persists so we can try something else.

    • This reply was modified 2 years, 3 months ago by  aaronlonin.
    #581150 Reply

    buddybu
    Participant

    I just switched back to the original workspace. Reapplied the DevStyle Theme, but did not check the force-colors checkbox. This forced me to restart Eclipse, and after restart, the problem has gone away. If it returns, I will let you know.

    Thanks.

    #581152 Reply

    aaronlonin
    Moderator

    Awesome! Thank you for using DevStyle!

    Have a great day!
    Aaron Lara

    #632170 Reply

    cbhawk89
    Participant

    I am having the same issue with the javadoc popups as reported above. I have tried to go to DevStyle > Color Themes preference page and enable “Force colors”, then apply. This does not solve the problem for me. I notice if I return to the Color Themes preference page the “Force colors” check box does not remain enabled. I have tried restarting eclipse multiple times. If this helps at all I recently upgraded the eclipse workspace for Oxygen to 2019-09. Perhaps I should attempt creating a new workspace to see if that solves the problem.

    #632300 Reply

    support-swapna
    Moderator

    Hi,

    I checked with DevStyle and Eclipse 2019-09 at my end, but could not replicate the problem with JavaDoc popup. The ‘Force colors’ is a one time action by design.

    Can you please let us know if you see the problem with JavaDoc in a new workspace as well?
    If yes, then please go to Window > Preferences > Oomph > Setup Tasks > Preference Recorder and see if the ‘Record into’ is checked? In case it is checked, then please uncheck it and shut down Eclipse.
    Go to [user_home]/.eclipse and move / delete the folders named *oomph* – this will make the (bad) saved preferences inaccessible. Restart Eclipse.

    If you are still seeing the issue, then please share with us your OS and version details.

    –Swapna
    Genuitec Support

    #647416 Reply

    harsha-dev
    Participant

    Hey,
    i Have tried both the above suggested solutions. I am still facing the issue.
    But it works fine when i change the workspace.

    Below are my Eclipse details:

    Version: 2019-03 (4.11.0)
    Build id: 20190314-1200

    Can you help me?

    Thank you.

    #648208 Reply

    aaronlonin
    Moderator

    @harsha-dev, just to double-check. Did you find and remove all the *oomph* directories in your [user_home]/.eclipse ?

    #650074 Reply

    kingofmambo
    Participant

    Hi! I’ve done all written above and still having the same issue.
    I delete all *oomph* directories in my [user_home]/.eclipse but when restarting eclipse these two directories appear:
    org.eclipse.oomph.p2
    org.eclipse.oomph.setup
    Even when I delete them, these 2 folders are always created after restarting eclipse. Not sure if that is the cause.

    #650187 Reply

    support-swapna
    Moderator

    Hi,

    Is the ‘Record into’ checked in the Window > Preferences > Oomph > Setup Tasks > Preference Recorder? If yes, then please uncheck it and shut down Eclipse and then delete the oomph folders.

    Do you see the problem in a new workspace as well? Please share with us your OS and version details, OS theme details, if any set.

    Apologies for inconvenience caused.

    –Swapna
    Genuitec Support

    #650885 Reply

    kingofmambo
    Participant

    Preference recorder is unchecked.
    When using a new workspace the issue with Javadocs is solved.
    My OS is Microsoft Windows 10 Pro Version 10.0.18362 Build 18362. My OS theme details are the ones defaulted by Windows.

    #650886 Reply

    aaronlonin
    Moderator

    Ok, thanks for the details. Then it seems like the preferences in the other workspace are wrong. Can you share them so we can have a look and see which preferences are wrong?

    The prefs are stored at workspace/.metadata/.plugins/org.eclipse.core.runtime/.settings
    Please create a zip file with all these files and share here or via email if you prefer at support@genuitec.com

    Cheers!
    Aaron Lara

Viewing 15 posts - 1 through 15 (of 17 total)
Reply To: Can't read JavaDoc popup

You must be logged in to post in the forum log in