facebook

Line numbers will not display in xml files

  1. MyEclipse IDE > General Development
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #675106 Reply

    Boeing-107
    Participant

    I have recently migrated my workspaces from 2017 to 2021 versions of MyEclipse.
    I have setup line numbers to display in the Preferences menu. General/Editors/Text Editors.
    It works in all other file types I have worked in, but xml files do not show line numbers.
    I can right click in the left margin of the file and the context menu has an option to show line numbers, but when I click on it nothing happens.
    I would like to have line numbers display on my xml files, please advise on how I can set my environment up so I can see line numbers
    Thanks
    -Scott

    #675107 Reply

    support-swapna
    Moderator

    Scott,

    Sorry for the missing line numbers in XML files. It is a bug in MyEclipse 2021 and a report is filed for the dev team to fix it.
    You can use the XML::Language Server editor instead for the line numbers. Right click on the XML file > Open With and choose the XML::Language Server.

    Hope this helps. Thank you for reporting it.

    –Swapna
    Genuitec Support

    #675449 Reply

    Boeing-107
    Participant

    I am also seeing issues using the regular xml editor and the delete key, is this part of the same issue?
    When will the fixes be released for the xml editor?
    Is there a way to change settings so it always opens xml in the “XML::Language Server” editor?

    Thanks
    -Scott

    #675470 Reply

    support-swapna
    Moderator

    Scott,

    We do not have the timeline yet for the fix. We will keep you posted once it is targeted.
    What exact problem are you seeing with the delete key?

    Currently there is no way to make the ‘XML::Language Server’ as default editor.
    Alternatively, you can also open the XML files in Generic Text Editor and make it as default editor. All the features including the line numbers should work with it. Right click on the XML file > Open With > Other, look for Generic Text Editor, select it and set as default.

    Hope this helps.

    –Swapna
    Genuitec Support

Viewing 4 posts - 1 through 4 (of 4 total)
Reply To: Line numbers will not display in xml files

You must be logged in to post in the forum log in