About myeclipsetomcat configuration

Home Forums Archived Forums MyEclipse Archived General About myeclipsetomcat configuration

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of support-swapna support-swapna 3 years, 10 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #319378
    Profile photo of karz_407
    karz_407
    Member

    I used myeclipse tomcat to run the restful web services example but it gave the following error. I am new to this i don’t know what to do plz help.

    31 Aug, 2011 11:27:15 AM org.apache.catalina.core.AprLifecycleListener init
    INFO: The Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /home/rvce/MyEclipse/Common/binary/com.sun.java.jdk.linux.x86_1.6.0.013/bin:/home/rvce/MyEclipse/Common/plugins/com.genuitec.eclipse.easie.tomcat.myeclipse_9.0.0.me201105051700/tomcat/bin
    31 Aug, 2011 11:27:15 AM org.apache.coyote.http11.Http11Protocol init
    SEVERE: Error initializing endpoint
    java.net.BindException: Address already in use:8080
    at org.apache.tomcat.util.net.JIoEndpoint.init(JIoEndpoint.java:501)
    at org.apache.coyote.http11.Http11Protocol.init(Http11Protocol.java:177)
    at org.apache.catalina.connector.Connector.initialize(Connector.java:1059)
    at org.apache.catalina.core.StandardService.initialize(StandardService.java:677)
    at org.apache.catalina.core.StandardServer.initialize(StandardServer.java:792)
    at org.apache.catalina.startup.Catalina.load(Catalina.java:518)
    at org.apache.catalina.startup.Catalina.load(Catalina.java:538)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:260)
    at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:412)
    31 Aug, 2011 11:27:15 AM org.apache.catalina.startup.Catalina load
    SEVERE: Catalina.start
    LifecycleException: Protocol handler initialization failed: java.net.BindException: Address already in use:8080
    at org.apache.catalina.connector.Connector.initialize(Connector.java:1061)
    at org.apache.catalina.core.StandardService.initialize(StandardService.java:677)
    at org.apache.catalina.core.StandardServer.initialize(StandardServer.java:792)
    at org.apache.catalina.startup.Catalina.load(Catalina.java:518)
    at org.apache.catalina.startup.Catalina.load(Catalina.java:538)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:260)
    at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:412)

    #319380
    Profile photo of support-swapna
    support-swapna
    Moderator

    karz_407 ,

    Sorry that you are seeing this issue with MyEclipse.

    Can you answer some more questions for me ?

    1) Can you share your Build ID from Help > About MyEclipse Enterprise Edition > Build Id ? Paste the Build Id here.

    2) Have you setup any other software to use port 8080?

    The Netstat command can list currently used ports, which might be helpful if you suspect an application is clashing with another one on an active port. Use the -an switch to show all connections and listening ports in numeric form. This would give you PID. Next use the windows task manager to check which program is using this port.
    Alternatively, you can configure your tomcat to run on a different port. If you are using sandbox tomcat, you can change the port number of tomcat here – open MyEclipse IDE, from menu options click on Window > Preferences > MyEclipse > Servers > Integrated Sandbox > MyEclipse Tomcat and change the port number on the right hand pane.

    3) If there is another software running on port 8080, you either stop it and run the MyEclipse Tomcat or configure the MyEclipse Tomcat to run on a different port as mentioned above.

    Let us know how this works for you.

Viewing 2 posts - 1 through 2 (of 2 total)

The forum ‘General’ is closed to new topics and replies.