Allow compiler compliance specification when creating EE pro

Home Forums MyEclipse IDE Feature Requests Allow compiler compliance specification when creating EE pro

This topic contains 3 replies, has 2 voices, and was last updated by Profile photo of support-tony support-tony 3 years, 7 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #320622
    Profile photo of vgriffin
    vgriffin
    Member

    Years ago, someone reported the annoying confusing behavior in 7.5 when they tried to create a jvm 1.6-compliant Web Project to run under Java EE5.0. It’s still a problem under 9.1.

    We’re using version 6 with EE 5. I don’t even have a 1.5 jdk on my dev box. I just created a Web Project several times t0 verify MyEclipse behavior. I select File > New > Web Project. Then, I enter a name, note that the default Java EE 5.0 is still selected, and click Finish. It pops the Incompatible Java Compliance Level box:

    Compiler compliance … should be 5.0. Your … default is 6.0. Do you want to use a custom setting for your project?

    If I click No, the box goes away and my project is created. If I display its properties, the compliance level is set to 1.5, the Use default… box is checked, the shadowed values show 1.5, and there’s an alert message about my lack of a 1.5 jdk.

    If I click Yes, I get the same results.

    There is also a link “Open workspace compiler settings”. If I click the link, it shows my workspace settings including (gasp!) compiler compliance 1.6. When I click OK there, that window and the popup both disappear and my project is created. With a compliance level of 1.5. Of course.

    The message in the box should be changed. It should be possible to create a Web Project (or other EE project) with the workspace default compliance level. Just in case a user wants a different compliance level for EE projects, there should be a workspace setting for the EE compliance level.

    I looked at the Web Project tutorial just to see if this issue was mentioned there. (It isn’t.) The tutorial should be updated to show more current pictures, etc.

    #320648
    Profile photo of support-tony
    support-tony
    Keymaster

    vgriffin,

    This is more of a problem than a feature request. Clicking No should not have resulted in the situation you describe and we have someone looking at that right now – a fix may get into release 10, due this month.

    #320656
    Profile photo of vgriffin
    vgriffin
    Member

    I had called it a “feature request” because of comments made by the support responder a couple of years ago. Also, it would be nice to be able to specify this stuff as preferences.

    Thanks for looking at it, and I very much look forward to having this feature behave correctly!

    #320668
    Profile photo of support-tony
    support-tony
    Keymaster

    vgriffin,

    The fix should be in release 10, due out this month. Thanks for raising it again.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.