Angular CLI server and Webclipse 1.11.0.201805291 with Angular 6

This topic contains 2 replies, has 2 voices, and was last updated by 5 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #591313 Reply

    Johannes
    Participant

    We are trying to upgrade to angular 6. After upgrading running “node_modules/angular-ide/bin/ng serve” fails with the following notice:

    `Error: Cannot find module ‘@angular/cli/node_modules/webpack-dev-server/lib/Server’

    Is there any additional module we have to include?

    #591321 Reply

    Johannes
    Participant

    Have found the solutions: Had to update node and npm and to run “ng update @angular/cli”. Now it seems to work (I have to fix several issues in my code).

    #591330 Reply

    support-swapna
    Moderator

    Johannes,

    Glad that you fixed them. Angular CLI 6 requires Node.js version 8.9 or above.
    Here is a thread which outlines steps for upgrading to Angular 6 for your reference : https://stackoverflow.com/questions/48970553/want-to-upgrade-project-from-angular-v5-to-angular-v6

    Please let us know if you see any other issues.

    –Swapna
    Genuitec Support

Viewing 3 posts - 1 through 3 (of 3 total)
Reply To: Angular CLI server and Webclipse 1.11.0.201805291 with Angular 6