Angular IDE does not start

This topic contains 8 replies, has 3 voices, and was last updated by  support-swapna 1 week, 3 days ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #592668 Reply

    kwakoo
    Participant

    I have downloaded and installed Angular IDE but it is not starting

    I get the following message:

    An error has occurred. See the log file
    /home/user/Workspaces/Angular IDE 2017 CI/.metadata/.log.

    but the log file .metadata/.log. is not visible or I can not see it.

    I am running it on ubuntu 16.04

    Please give me some tips I am new to the Angular IDE and eclipse though I know my way around angular.

    • This topic was modified 2 weeks, 6 days ago by  kwakoo. Reason: typo
    #592670 Reply

    aaronlonin
    Moderator

    @kwakoo, sorry you are having this issue. Angular IDE is currently based on Eclipse Neon which requires Java 8 but does not support java 9 or 10. We are currently working on a fix to detect unsuported (newer) versions and automatically set java. It’s very likely you are hitting this issue.

    There are some ways to workaround it, but first, could you please let me know which version of Java do you have in your system?

    cheers!
    Aaron Lara

    #592672 Reply

    aaronlonin
    Moderator

    It would be good to know what your log file contains. Maybe you can try accessing it using your terminal (given these are hidden files). A command like cat "/home/user/Workspaces/Angular IDE 2017 CI/.metadata/.log" should do.

    Assuming the version of Java you have installed is the issue:

    One way to go is to download (from here) the corresponding java JRE for your linux arch and uncompress it. Then edit the angularide.ini file located in your Angular IDE install directory. Before -vmArgs in a new line you can add -vm <path to java>
    Example:

    Another way to go is to install Java 8 in your system and after this Angular IDE should launch correctly. You can check this external tutorial: https://www.linode.com/docs/development/java/install-java-on-ubuntu-16-04/

    Let us know any concern.
    Cheers!

    • This reply was modified 2 weeks, 6 days ago by  aaronlonin.
    • This reply was modified 2 weeks, 6 days ago by  aaronlonin.
    #592759 Reply

    kwakoo
    Participant

    @aaronlonin Thank you! I should have posted earlier the issue. I spent many nights after work and it was not a joy ride going work early morning being stressed out and tired 🙂

    The Java version I was using was 10. Sorry I could not get you the log as I have deleted the workspaces.

    I have now installed Java following the link in your workaround note and IT WORKED FINALLY… But I am getting the error at the end of this note. But at least I am able to navigate through the IDE. At this stage, I am really excited to see if it does better than the others like VS code, Sublime, and Atom which I tried before. Nowadays I settled for VS code. Time permitting I will post my experience on this post whether I decide to use Angular IDE going forward or not after may be many nights to come.
    Please let me know if there is a workaround to the following error or if it is not a serious bug and can be ignored.
    Failed to execute operation
    Property not located:IProjectCreationPropertiesNew.PROJECT_LOCATION

    #592833 Reply

    support-swapna
    Moderator

    kwakoo,

    Glad that installing a compatible version of Java works.

    Failed to execute operation
    Property not located:IProjectCreationPropertiesNew.PROJECT_LOCATION

    Can you please clarify when exactly you are seeing the above error? Is it during Angular project creation?
    Please share with us the workspace log file by clicking on the ‘Export Log’ icon in the Error Log view for further investigation.

    Apologies for inconvenience caused.

    –Swapna
    Genuitec Support

    #592924 Reply

    kwakoo
    Participant

    Swapana,

    Thank you!

    The same goes here for the delay. Sorry! I am doing this in my spare time and takes time to come back to it.

    Anyway,

    To reproduce the error.

    – Launch the IDE;
    – Use start .. and select angular.
    – Fill in the project name in the form that follows;
    – When you click Finish button you will see the following error. I have attached screenshot as well.

    ‘Creating Angular project test3’ has encountered a problem.
    Failed to execute operation.

    When clicking the details button of the error message you find:

    Failed to execute operation
    Property not
    located:IprojectCreationPropertiesNew.PROJECT_LOCATION

    Attached is also the log file. Hope you will spot the exception in the log file.

    BEst Regards,

    Abebe

    Attachments:
    You must be logged in to view attached files.
    #593083 Reply

    support-swapna
    Moderator

    kwakoo,

    Thank you for the details and the screenshot. Unfortunately, it looks like the Angular project creation from the Start dialog is broken. Apologies for the terrible experience. I have filed a bug for the dev team to fix it.

    Please use the New > Angular Project wizard from the workbench to create Angular projects. We will keep you posted when the fix is out.

    Thank you for reporting it.

    –Swapna
    Genuitec Support

    #593243 Reply

    kwakoo
    Participant

    @swapna,

    Thank you! I have gone thru Angular-IDE. It has great features and I like it but I think it is not yet stable. For example,

    -It freezes in the middle of coding and I had to close and open.
    -Switching between projects is very confusing. I think would be good to highlight or make it visible on the explorer window when switching between projects in the terminal window,
    – I am not sure if there is a way to do it but I see no IntelliSense when adding modules after importing components.

    – The integration with the angular dev related environment is the best which I think should be a winner of the harts of developers. Please let me know when you have a stable version.

    Thank you once again,

    KW

    #593319 Reply

    support-swapna
    Moderator

    KW,

    Thank you for your feedback. Sorry that you are seeing problems.

    Can you please share with us more details to help us investigate further?

    1. When exactly are you seeing the freeze and for which file types? Does it freeze during particular actions like formatting or working with dialogs like Find/Replace? Also share with us the workspace log file by clicking on the ‘Export Log’ icon in the Error Log view.

    2. If possible, please share with us the thread dumps from the time when the IDE freezes to help us figure out which process is running. To take a thread dump, you will need to run
    jstack -l 9000 > dump1.txt
    Please replace 9000 with the PID of the MyEclipse process, the jstack program can be found in the bin directory of any JDK installation. If you can generate 3-4 dumps (sent to different files, of course) during the period of freeze, and attach those files here, that could help a great deal.

    3. I ran a few tests and do not see the problem with intellisense at my end. Did you install the CodeMix plugin too? Can you please share with us the code snippets to help us replicate the problem at our end?

    4. I have filed an enhancement request for switching between projects in Terminal+ view to be highlighted in the Explorer view. We will keep you posted when it is implemented.

    Apologies for inconvenience caused. We hope to resolve the issues you are seeing at the earliest.

    –Swapna
    Genuitec Support

Viewing 9 posts - 1 through 9 (of 9 total)
Reply To: Angular IDE does not start