Bridge$BridgeException: TypeError: undefined is not a function

This topic contains 3 replies, has 2 voices, and was last updated by Profile photo of support-swapna support-swapna 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #516294
    Profile photo of Giancarlo
    Giancarlo
    Participant

    Hello,

    i installed webclipse on new installed eclipse neon and created a new angular2 project, the project compile and run fine but in eclipse there are several problems:

    – every time i save a file show up an error
    – auto completion isn’t working
    – can’t jump to typescript type definitions

    in eclipse log the exception is always the same:

    com.genuitec.eclipse.typescript.services.internal.Bridge$BridgeException: TypeError: undefined is not a function

    how can fix this?

    #516388 Reply
    Profile photo of support-swapna
    support-swapna
    Moderator

    Giancarlo,

    Sorry that you are seeing this issue.

    I assume you are working with the latest Webclipse 2017 CI 3b release.
    Are you working with Neon 1 or Neon 2 (4.6.2)?
    Can you please send us the full .log file located at workspace dir/.metadata/.log for further investigation?

    Apologies for inconvenience caused.

    –Swapna
    MyEclipse Support

    #516394 Reply
    Profile photo of Giancarlo
    Giancarlo
    Participant

    Hello,

    i’m using

    Neon.2 Release (4.6.2) Build id: 20161208-0600
    Webclipse Angular 2 1.7.2.201703081933

    Attachments:
    You must be logged in to view attached files.
    #516399 Reply
    Profile photo of support-swapna
    support-swapna
    Moderator

    Giancarlo,

    Thank you for the details and the log file.

    Can you please check if you are using the correct version of Node.js to run TypeScript? Go to Window > Preferences > JavaScript > Runtimes. Ensure that the selected Node.js path in this page is the same on the TypeScript (Window > Preferences > TypeScript) page as well.

    Attached is the screenshot for your reference. If the path in the TypeScript page is different, then please use the same Node.js path you selected in the Runtimes page and check if you are still seeing issues.

    Please let us know how it works for you.

    –Swapna
    MyEclipse Support

    Attachments:
    You must be logged in to view attached files.
Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.