Cannot set php.executablePath & phpfmt.php_bin

This topic contains 2 replies, has 2 voices, and was last updated by  raphi 5 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #591167 Reply

    raphi
    Participant

    I cannot get to set the PHP paths required for validating and formatting my PHP files.

    I tried to set the paths with following tutorial, but i did not get it to work:
    https://www.genuitec.com/docs/web-apps/modern-web/getting-started-with-php-in-eclipse/#binary-path

    Also did some Google research and tried the following (none of them worked):
    C:\php\php.exe
    C:\\php\\php.exe
    C:/php/php.exe
    C://php//php.exe

    Always getting following Error: “Unable to write to Folder Settings because <valuetriedtoset> does not support the folder resource scope.”

    In the end i stayed at the default values and added the PHP installdir to my environment path variable and now it works. I’m using Windows 10 Version 1703, newest version of Codemix and Eclipse Oxygen.

    Don’t know if this is a bug or I am missing something.

    Thanks for taking a look at this,
    Raphi

    #591202 Reply

    Brian Fernandes
    Moderator

    Raphi,

    I tried this now and it appears that you have tried to set this at the project level (Project properties > CodeMix > Project Settings) instead of at the User or the Workspace level.

    That error message is cryptic and we’ll look into improving it 🙂 Can you try and set these values at the User / Workspace level instead?

    Thanks!

    #591247 Reply

    raphi
    Participant

    Hey Brian,

    Setting it with following “C:/php/php.exe” under Window –> Preferences –> CodeMix –> User Settings worked!

    Thank you very much for the quick support 🙂

Viewing 3 posts - 1 through 3 (of 3 total)
Reply To: Cannot set php.executablePath & phpfmt.php_bin

This topic is marked as closed to new replies, however your posting capabilities still allow you to do so.