Can't run project

This topic contains 12 replies, has 5 voices, and was last updated by  jhugohr 1 year, 1 month ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #598905 Reply

    Leonardo
    Participant

    After upgrading (angular 6) projects won’t work. This is the message:

    internal/modules/cjs/loader.js:583
    throw err;
    ^

    Error: Cannot find module ‘@angular/cli/node_modules/webpack-dev-server/lib/Server’
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:581:15)
    at Function.Module._load (internal/modules/cjs/loader.js:507:25)
    at Module.require (internal/modules/cjs/loader.js:637:17)
    at require (internal/modules/cjs/helpers.js:20:18)
    at Object.<anonymous> (/Users/leonardo/Documents/workspace/tgg/node_modules/angular-ide/addon/commands/serve.js:16:15)
    at Module._compile (internal/modules/cjs/loader.js:689:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:700:10)

    Thanks in advance

    #599085 Reply

    support-swapna
    Moderator

    Leonardo,

    Sorry that you are seeing this issue.

    We have a bug already filed for similar error when running ng update on a Angular CLI 1.7.4 project.

    Can you please let us know how you have upgraded the Angular CLI version of the project? Also let us know the previous version of Angular CLI on the project. If possible, please also share with us the project’s package.json to help us investigate further.

    Apologies for inconvenience caused.

    –Swapna
    Genuitec Support

    #599253 Reply

    Leonardo
    Participant

    I followed the guide at https://update.angular.io/ over a newly created project.

    I encountered some problems that I solved using the command: npm install –save-dev @angular/cli@latest

    ng update says that everything is up to date and fine but when I try to run the app (empty because is new) throws the error I mentioned before.

    I tried this approach to solve another problem I had when I did a merge on a project and the project would not run anymore saying that the project it’s not an Angular project:

    “Project XXXX is not an Angular CLI project.”

    That project is at level 6 running and configured OK on another wachine (workspace).

    Thanks

    #599372 Reply

    support-swapna
    Moderator

    Leonardo,

    Thank you for the details.

    Can you please run npm update for the project from the Terminal+ view and see if it fixes the issue?
    If you are still seeing issues, then please share with us your project’s package.json for further investigation.

    Please let us know how it works for you.

    –Swapna
    Genuitec Support

    #599951 Reply

    Leonardo
    Participant

    I did run the command but it made no difference. I tested some more and now I think I know the reason why my project is not recognized anymore.

    As I upgraded the project the old .angular-cli.json was deleted and the new angular.json was created. Now without the .angular-cli.json the IDE doesn’t recognize my project as an Angular project anymore.

    Is there something I can do to solve the problem?

    Thanks in advance

    #599961 Reply

    Brian Fernandes
    Moderator

    Leonardo,

    We do support projects with the newer angular.json format – perhaps you have an older version of Webclipse installed? Can you check the version on the Preferences > Webclipse page?

    I would actually now recommend you update Webclipse (in case you are on a version earlier than 2017 CI 14) and then go on to install CodeMix, which will provide superior Angular support. All Webclipse based installs will be automatically updated to CodeMix in the next month, but you can always do it manually right now. You can read more, and get CodeMix here: https://www.genuitec.com/products/webclipse/

    Note: I’ve assumed you have Webclipse installed as plugins into Eclipse. If, instead, you have Angular IDE standalone, do ensure you check for updates ad you should get the above CodeMix updates automatically installed.

    Hope this helps.

    #599967 Reply

    Leonardo
    Participant

    Well, I made it work but only using the Terminal. If I run “ng serve” the project runs and the “server” view updates correctly, but if I try to use de “server” view and select the project and press the play button, I get an error saying that the project is not and Angular project.

    I also noted that if I try to use the IDE to create a new component, it tells me that I need to select a source folder, when I try to select the folder and I do, there is a message at the bottom of the dialog saying “Selected project is not a valid angular cli project”

    Again, using the terminal I can create the component.

    I updated the webeclipse plugin today (1.11.0.20180924…)

    Thanks

    #600033 Reply

    ignaciom
    Moderator

    Leonardo,

    From Angular IDE, if you expand your project. Does the angular.json file is a direct children of the project or does the angular.json is inside a child directory of your project? If the angular.json file is inside a directory of your project, could you share how you create your project?

    To make a bit more clear…

    myproject
    – angular.json

    myproject
    – myangularsource
    -angular.json

    Best Regards
    Ignacio

    #600037 Reply

    Leonardo
    Participant

    I’m attaching a snapshot.

    Attachments:
    You must be logged in to view attached files.
    #600043 Reply

    ignaciom
    Moderator

    Leonardo,

    I’m attaching you a patch plugin just adding some extra entries on the log when you try to use these features of Angular IDE, create a component or start a server. To apply it:

    1. Shutdown your Angular IDE.
    2. Look at your install directory for the plugins directory. Make sure the attached jar filename matches with one inside this directory and replace it
    3. Start your Angular IDE, try to create a component and start a server. This will add some extra entries to the workspace log, just to check what is different on your side.
    4. Send to us your workspace log, it is usually located inside your selected workpsce dir .metadata/.log. Copy that file to somewhere else and change the name if you can before attach it here.

    This will provide to us enough information to get you a fix soon.

    Best Regards
    Ignacio

    #600044 Reply

    ignaciom
    Moderator

    I’m attaching the file again just removing the extension, when you download it rename it by just adding the .jar extension to the file.

    Cheers
    Ignacio

    #600045 Reply

    ignaciom
    Moderator
    #600110 Reply

    jhugohr
    Moderator

    Leonardo,

    do you have the following options available if you right click on your project and select the ‘New->’ menu option ? (see attachment)

    Also, is the project available on ‘Severs’ view?

    If so, can you share either screenshots or better record a brief video with the steps you are following when the message is being shown?

    were you able to replace the plugin? if so, can you go through the steps and attach the generated workspace log?

    Best Regards,
    Hugo Herrera

    Attachments:
    You must be logged in to view attached files.
Viewing 13 posts - 1 through 13 (of 13 total)
Reply To: Can't run project

This topic is marked as closed to new replies, however your posting capabilities still allow you to do so.

You must be logged in to post in the forum log in