facebook

Change Content Assist Behavior (on keystroke or just control+space)

  1. CodeMix & Angular IDE > Getting Help

This topic contains 7 replies, has 6 voices, and was last updated by  hypnos97 3 weeks ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #607104 Reply
    Aaron Lara
    Aaron Lara
    Moderator

    CodeMix lets you tailor how content-assist (IntelliSense) works when you are editing files. These are customized via settings and are called Quick Suggestions.

    If you don’t like CodeMix editor’s as-you-type Content Assist, here’s a way you can quickly disable it. By doing this you can still invoke Content Assist by pressing CTRL + SPACE.

    1. Go to Preferences > CodeMix > Workspace Settings page.
    2. Click the settings.json link at the bottom of the page. It will open a json file.
    3. Add the following lines under settings like this :

    4. Save the file.

    And that’s it! It will disable content assist on keystroke.

    Additionally there’s a feature called “Parameter Hints” which helps filling in parameters. This can also be turned off by just adding "editor.parameterHints.enabled": false in the same settings area. Like this:

    • This topic was modified 2 years, 5 months ago by Aaron Lara Aaron Lara.
    • This topic was modified 2 years, 4 months ago by Aaron Lara Aaron Lara.
    #612799 Reply

    lainhart
    Participant

    Hi Aaron –

    In my version of CodeMix (20190411) embedded in MyEclipse, I see that the settings.json file is accessed via Preferences->CodeMix->Extensions->path-intellisense.

    — Todd

    #612801 Reply
    Aaron Lara
    Aaron Lara
    Moderator

    Todd, Thanks for pointing that out! Yes, in the newest version of CodeMix we have changed our preferences pages and those options are now visible without needing to open the settings.json (see Screenshots attached). I will make sure to edit this post.

    Cheers!
    Aaron Lara

    • This reply was modified 2 years, 2 months ago by Aaron Lara Aaron Lara.
    Attachments:
    You must be logged in to view attached files.
    #617275 Reply

    rhinodubai123
    Participant

    I don’t think there is a work in approach to do it, But on the off chance that you need you can cripple ‘auto-finish’, and it should trigger just when you hit ctrl+space, that way it will likely illuminate your issue.Rhino Dubai

    #629053 Reply

    cleca
    Participant

    I followed these instruction but I still get annoying hin windows while typing. In particular: When editing a .jxs file and writing a line with a spread operator, i.e. … then I get a window where it says “Emmet Abbreviations”.

    How can I turn this OFF?

    Essentially, I only need occasional folding, syntax highlighting, bracket matching and an HTML tag auto close. That’s it.

    #629095 Reply

    Brian Fernandes
    Moderator

    Cleca,

    Seems like you are receiving completion for the trigger character. I’m going to suggest a number of additional settings to be turned off as well, just to be sure.

    Please go to Preferences > CodeMix and click the “Open Settings Json” button at the top of the dialog. In this file, please add the following properties in the settings section (ensure you leave other properties untouched).

         
    "settings": {          
      "emmet.showExpandedAbbreviation": "never",
      "emmet.showAbbreviationSuggestions": false,
      "editor.suggestOnTriggerCharacters": false,
      "htmlhint.enable": false,
      "html.suggest.html5": false
    }
    
    • This reply was modified 1 year, 7 months ago by  Brian Fernandes.
    • This reply was modified 1 year, 4 months ago by  Brian Fernandes.
    #629399 Reply

    cleca
    Participant

    Brian,

    thanx for the quick and efficient help. Impressive. Works. Cool.

    Took me a while to find the settings json again, as in my case it is not in Preferences > CodeMix but in CodeMix > Extensions > path-intellisense. Would be cool to have a button directly at Preferences > CodeMix.

    One more issue: I would like “Formatting” to ONLY do indentation (and not destroy the other formatting I manually placed into my Javascript code and which are there for a reason). Again I have the same problem: I already turned off all “Format” features in Formatter > Javascript but I still get all kinds of formatting changes. I would very much appreciate a hint 🙂

    Update: If there is a shortcut which ONLY does indent of the selected region that would be a cool solution, but didn’t find that in doc.

    • This reply was modified 1 year, 7 months ago by  cleca.
    #661416 Reply

    stevenrob
    Participant

    Thanks for sharing these valuable insights. They are a real source of learning for newbies like me.

Viewing 8 posts - 1 through 8 (of 8 total)
Reply To: Change Content Assist Behavior (on keystroke or just control+space)

You must be logged in to post in the forum log in