ClassNotFound – com.sun.jersey.spi.container.servlet.Servlet

Home Forums Archived Forums MyEclipse Archived Web Services ClassNotFound – com.sun.jersey.spi.container.servlet.Servlet

This topic contains 3 replies, has 2 voices, and was last updated by Profile photo of support-swapna support-swapna 3 years, 7 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #320453

    Hi,

    I have just installed MyEclipse 9 (Build Id – 9.1-20110701) running on Mac OS X (10.7.1)
    and have started to do your Restful Web Services Demo and as I start to run the MyEclipse Server Application I get the error

    SEVERE: Error loading WebappClassLoader
    delegate: false
    repositories:
    /WEB-INF/classes/
    ———-> Parent Classloader:
    org.apache.catalina.loader.StandardClassLoader@62facf0b
    com.sun.jersey.spi.container.servlet.ServletContainer
    java.lang.ClassNotFoundException: com.sun.jersey.spi.container.servlet.ServletContainer
    at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1358)

    Any pointers would be appreciated, log and project are attached.

    Clemo

    Attachments:
    You must be logged in to view attached files.
    #320476
    Profile photo of support-swapna
    support-swapna
    Moderator

    peclements,

    Sorry that you are seeing this issue with MyEclipse.

    Can you answer some more questions for us to understand the issue better ?

    1) Are you running the application on MyEclipse Tomcat ? Are you running Groovy on the server ?

    2) Can you recheck if you have included the “jersey-server.jar“ in the classpath and under web-inf/lib ?

    3) Also take a look at this thread which discusses the same issue :
    http://www.myeclipseide.com/PNphpBB2-printview-t-26453-start-0.html

    4) Clear the contents of the .log file which is located at <workspace dir>/.metadata/.log , replicate the issue and copy paste the entire contents of the .log file here for us to investigate it further.

    #320493

    Hi,

    Sorted by recreating the project and selecting the jersey-server.jar (not shown on the myeclipseide tutorial I followed) and it all works :)

    Thanks

    Clemo

    #320503
    Profile photo of support-swapna
    support-swapna
    Moderator

    peclements,

    Glad that it is working.
    Do let us know if you have any other issues.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.