Controlling WebSphere with MyEclipse 2020

  1. MyEclipse IDE
  2.  > 
  3. WebSphere Development
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #660526 Reply


    Hi, Genuitec!

    I just updated my local WebSphere Application Server installation from to and I haven’t been able to run or debug my WAS instance from within MyEclipse ever since. I receive the following error message when I attempt to Run or Debug the WAS instance from MyEclipse:

    runConfigActions script execution failed. Exit code: 1
    Exception caught while waiting for runConfigActions script to complete: C:\was85\profiles\AppSrv01\bin\runConfigActions.bat

    That said, I’m still able to:

    • Start the instance externally via startServer.bat from a command prompt. The instance starts just as expected and the MyEclipse console will detect that the WAS instance is running and display the SystemOut.log.
    • Publish local application changes from MyEclipse to the WAS instance without issue.
    • Stop the instance from MyEclipse using the Server view.

    This is a relatively minor inconvenience, but I would like to be able to debug our applications again on this local instance.

    With regard to my development environment, I’m running on Windows Server 2019 with the following versions of MyEclipse:
    Version: 2020.5.18
    Build id: 16.0.0-20200518

    Scott Sobotka

    #660532 Reply



    Sorry that you are seeing this issue. Thank you for the details.
    I could replicate the issue at my end with WAS version. A bug report is filed for the dev team to investigate further.

    As a workaround, you can create a file named runConfigActions.disableAtServerStartup (empty file) under the [profile_root]/properties/service/ directory and try starting the server again from inside MyEclipse. The suggested workaround fixes the startup problem at my end.
    Please give it a try and let us know if you see any issues.

    Apologies for inconvenience caused. Thank you once again for reporting this issue.

    Genuitec Support

    #660581 Reply


    Hi, Swapna.

    That worked perfectly! I’ll file that away if I ever run into other WAS startup issues.

    Thank you so much!

    –Scott Sobotka

    #660607 Reply



    Glad that the workaround helps. Thank you for getting back to us.
    Please let us know if you see any other issues.

    Genuitec Support

    #663354 Reply



    Are there any plans to fix this issue? The workaround worked for me but I need to confirm whether we need to incorporate this into out profile creation process. Thanks.


    #663378 Reply

    Brian Fernandes


    Yes, we do intend to fix this issue, but have been unable to prioritize a fix for the release we have due this week. We’re going to take a look at this for our next release, though I’m unsure at this time if this will be something we will be able to address in MyEclipse (via an env variable or startup switch). We will keep this thread updated with the fix progress – apologies for the delay.

    #682353 Reply


    And two years later, this issue still persists.
    What kind of message do you think that this conveys to prospective customers who are looking for a Rational Application Developer replacement?

Viewing 7 posts - 1 through 7 (of 7 total)
Reply To: Controlling WebSphere with MyEclipse 2020

You must be logged in to post in the forum log in