Error when installing the AspectJ maven connector

This topic contains 4 replies, has 2 voices, and was last updated by Profile photo of support-joy support-joy 3 years, 6 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #323648
    Profile photo of edbras
    edbras
    Member

    When importing maven project with the Iimport existing maven project wizard, I get the following error when a maven project depends on compile team weaving such that it want to install the AspectJ maven connector (m2e if I am not mistaken).
    Any idea why?

    Below you also find the installation details.
    Attached you find the log file.
    it concerns a new clean installation in a clean workspace.
    See my previous post for problems and the reason for clean installation.

    This time I choose for the customized installer.

    Please improve MyEclipse as to my experience it’s not well suited for larger development projects.
    As soon as work in many projects, doing the same as with less projects when all work fine, Myeclipse becomes fragil and it complaints about memory and small things like copy/paste etc… simple not work…
    Please make sure you test this….

    – Ed

    —-
    An error occurred while collecting items to be installed
    session context was:(profile=com.poweredbypulse.profile-0-rb-5513151-1330009548502, phase=com.genuitec.pulse2.client.common.download.PulseCollect, operand=, action=).
    Could not find repositories containing the following artifacts: [org.eclipse.update.feature,org.eclipse.ajdt.pde.build,2.1.3.e36x-20110622-1300, org.eclipse.update.feature,org.maven.ide.eclipse.ajdt.feature,0.13.0.201107281640, osgi.bundle,org.eclipse.ajdt.pde.build,2.0.2.e36x-20110622-1300, osgi.bundle,org.maven.ide.eclipse.ajdt,0.13.0.201107281640]

    —-

    *** Date:
    donderdag 23 februari 2012 20:03:52 uur CET

    ** System properties:
    OS=WindowsVista
    OS version=6.1.0
    Java version=1.6.0_13

    *** MyEclipse details:
    MyEclipse Enterprise Workbench
    Version: 10.0
    Build id: 10.0-20111028

    *** Eclipse details:
    MyEclipse Enterprise Workbench

    Version: 10.0
    Build id: 10.0-20111028

    Eclipse startup command=-os
    win32
    -ws
    win32
    -arch
    x86_64
    -showsplash
    -launcher
    C:\Users\ed\AppData\Local\MyEclipse\MyEclipse 10\myeclipse.exe
    -name
    Myeclipse
    –launcher.library
    C:\Users\ed\AppData\Local\MyEclipse\MyEclipse 10\../Common/plugins/org.eclipse.equinox.launcher.i18n.win32.win32.x86_64_3.2.0.v201103301700\eclipse_3215.dll
    -startup
    C:\Users\ed\AppData\Local\MyEclipse\MyEclipse 10\../Common/plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
    -exitdata
    1388_5c
    -install
    C:\Users\ed\AppData\Local\MyEclipse\MyEclipse 10
    -configuration
    C:\Users\ed\AppData\Local\MyEclipse\MyEclipse 10\configuration
    -vm
    C:\Users\ed\AppData\Local\MyEclipse\Common\binary\com.sun.java.jdk.win32.x86_64_1.6.0.013\bin\javaw.exe

    Attachments:
    You must be logged in to view attached files.
    #323649
    Profile photo of edbras
    edbras
    Member

    As follow up to the above exception, I just receive out of the blue the following exception (during Maven import):

    The Error popup in Eclipse shows the following message:
    —-
    An internal error occurred during: “Searching for markers”.
    Java heap space
    —-

    I notice during copying/pasting this message that I still have the same copy/paste message (see my previous post), whereas I didn’t install the EGIT plugin (yet).
    I have no idea where all these error come from, while I do a clean install.

    Please advice on these issues? and on the issues in my previous post if required ?
    Maybe it’s the 64 bit version that I use ?
    I am getting a bit frustrated….
    At these moment I seriously consider jumping (and the team) to InteliJ. It cost a bit more but seems to deal better with bigger projects as these…
    The only thing that holds me is the experience (and all the short cuts I know) I have with Eclipse…
    O maybe stop using MyEclipse. I basically use it for the perfect Tomcat launcher and hot deployment.
    The Spring and Hibernate stuff I find less important……. I hardly use them, know them all anyway…

    Details in the log:
    —-

    !ENTRY org.eclipse.core.resources 4 2 2012-02-23 20:03:32.705
    !MESSAGE Problems occurred when invoking code from plug-in: “org.eclipse.core.resources”.
    !STACK 0
    java.lang.IllegalArgumentException:
    at org.eclipse.core.runtime.Assert.isLegal(Assert.java:63)
    at org.eclipse.core.runtime.Assert.isLegal(Assert.java:47)
    at org.eclipse.core.runtime.Status.setSeverity(Status.java:248)
    at org.eclipse.core.runtime.Status.<init>(Status.java:86)
    at org.jibx.eclipse.builder.JibxBindingBuilder.bindAll(JibxBindingBuilder.java:169)
    at org.jibx.eclipse.builder.JibxBindingBuilder.build(JibxBindingBuilder.java:89)
    at org.eclipse.core.internal.events.BuildManager$2.run(BuildManager.java:728)
    at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
    at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:199)
    at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:239)
    at org.eclipse.core.internal.events.BuildManager$1.run(BuildManager.java:292)
    at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
    at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:295)
    at org.eclipse.core.internal.events.BuildManager.basicBuildLoop(BuildManager.java:351)
    at org.eclipse.core.internal.events.BuildManager.build(BuildManager.java:374)
    at org.eclipse.core.internal.events.AutoBuildJob.doBuild(AutoBuildJob.java:143)
    at org.eclipse.core.internal.events.AutoBuildJob.run(AutoBuildJob.java:241)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

    !ENTRY org.eclipse.core.resources 4 2 2012-02-23 20:04:43.196
    !MESSAGE Problems occurred when invoking code from plug-in: “org.eclipse.core.resources”.
    !STACK 0
    java.lang.IllegalArgumentException:
    at org.eclipse.core.runtime.Assert.isLegal(Assert.java:63)
    at org.eclipse.core.runtime.Assert.isLegal(Assert.java:47)
    at org.eclipse.core.runtime.Status.setSeverity(Status.java:248)
    at org.eclipse.core.runtime.Status.<init>(Status.java:86)
    at org.jibx.eclipse.builder.JibxBindingBuilder.bindAll(JibxBindingBuilder.java:169)
    at org.jibx.eclipse.builder.JibxBindingBuilder.build(JibxBindingBuilder.java:89)
    at org.eclipse.core.internal.events.BuildManager$2.run(BuildManager.java:728)
    at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
    at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:199)
    at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:239)
    at org.eclipse.core.internal.events.BuildManager$1.run(BuildManager.java:292)
    at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
    at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:295)
    at org.eclipse.core.internal.events.BuildManager.basicBuildLoop(BuildManager.java:351)
    at org.eclipse.core.internal.events.BuildManager.build(BuildManager.java:374)
    at org.eclipse.core.internal.events.AutoBuildJob.doBuild(AutoBuildJob.java:143)
    at org.eclipse.core.internal.events.AutoBuildJob.run(AutoBuildJob.java:241)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

    #323650
    Profile photo of edbras
    edbras
    Member

    Unf### Believable…

    And again it hangs…. just like in the previous post, exactly the same error…
    When Eclipse starts it start the workspace center, about 20, sometimes 75%…
    And the log contains the following:

    I really have to do my work which is currently impossible…
    I think I am going to install Eclipse basic JEE version and install/search for the plugin’s I need. I have no other choose apparantly as you guys are very busy and have no time to response and there is no way to get Myeclipse working such that I can use it!

    – Ed

    —-
    !ENTRY org.eclipse.ui 4 0 2012-02-23 20:18:59.816
    !MESSAGE Unhandled event loop exception
    !STACK 0
    org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.OutOfMemoryError: PermGen space)
    at org.eclipse.swt.SWT.error(SWT.java:4282)
    at org.eclipse.swt.SWT.error(SWT.java:4197)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:138)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4140)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3757)
    at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2696)
    at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2660)
    at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2494)
    at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:674)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:667)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
    at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
    Caused by: java.lang.OutOfMemoryError: PermGen space

    !ENTRY org.eclipse.core.jobs 4 2 2012-02-23 20:18:59.821
    !MESSAGE An internal error occurred during: “Updating Maven Dependencies”.
    !STACK 0
    java.lang.OutOfMemoryError: PermGen space

    !ENTRY org.eclipse.ui 4 4 2012-02-23 20:19:06.667
    !MESSAGE An internal error has occurred.
    !STACK 0
    java.lang.OutOfMemoryError: PermGen space

    !ENTRY org.eclipse.ui 4 0 2012-02-23 20:19:06.670
    !MESSAGE Error occurred during status handling
    !STACK 0
    java.lang.OutOfMemoryError: PermGen space

    !ENTRY org.eclipse.ui 4 4 2012-02-23 20:19:06.672
    !MESSAGE An internal error has occurred.
    !STACK 0
    java.lang.OutOfMemoryError: PermGen space

    !ENTRY org.eclipse.ui 4 0 2012-02-23 20:19:09.266
    !MESSAGE Unhandled event loop exception
    !STACK 0
    java.lang.OutOfMemoryError: PermGen space

    !ENTRY org.eclipse.ui 4 0 2012-02-23 20:19:09.269
    !MESSAGE Error occurred during status handling
    !STACK 0
    java.lang.OutOfMemoryError: PermGen space

    !ENTRY org.eclipse.ui 4 0 2012-02-23 20:19:14.821
    !MESSAGE Unhandled event loop exception

    !ENTRY org.eclipse.ui 4 0 2012-02-23 20:19:15.855
    !MESSAGE Unhandled event loop exception
    !STACK 0
    org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.OutOfMemoryError: PermGen space)
    at org.eclipse.swt.SWT.error(SWT.java:4282)
    at org.eclipse.swt.SWT.error(SWT.java:4197)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:138)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4140)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3757)
    at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2696)
    at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2660)
    at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2494)
    at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:674)
    at null
    at null
    at null
    at null
    at null
    at null
    at null
    at null
    at null
    at null
    at null
    at null
    at null
    at null
    at null
    at null
    Caused by: java.lang.OutOfMemoryError: PermGen space

    !ENTRY org.eclipse.core.jobs 4 2 2012-02-23 20:19:17.925
    !MESSAGE An internal error occurred during: “Flushing content description cache.”.
    !STACK 0
    java.lang.OutOfMemoryError: PermGen space

    #323678
    Profile photo of edbras
    edbras
    Member

    Apparently the dev support team is very busy.
    I bit disappointing as there aren’t there when I need them the most.
    As such, I had to make my own decisions:
    Sorry, but this time I am afraid you losing client(s).
    I switched to EE Eclipse edition.
    I can’t seem to get MEclipse working correctly with my/our work environment.
    My Experience: MyEclipse can’t work correctly with greater projects, even do the configurations are simple like in my case. The last few years when projects got getting bigger, MyEclipse got fragile and I had to start a clean install too many times (the last week: 2 times and even then is was giving many problems)
    Because of my simple configuration demands, I switched to EE Eclipse and it seem to work fine: more smooth and faster reaction on interaction. I haven’t seen my copy/paste problem coming by so that looks good.
    I will test this environment for a month. If all run ok, I will no continue working with MyEclipse (finally as I had my doubt the last few years).
    After a month I will give advice to the board to not use MyEclipse such that all our agile groups scattered around the world will not use MyEclipse anymore.
    Sorry, but this time I am afraid you will lose clients.

    I hope in the future MyEclipse will “really” be improved.. (of course you always try to improve but that doesn’t seem to be enough).

    Good luck,
    Ed

    #323694
    Profile photo of support-joy
    support-joy
    Member

    Ed,

    I apologize for the delay in responding. I have escalated your issue. We are investigating your issue. Please refer http://www.myeclipseide.com/index.php?name=PNphpBB2&file=viewtopic&p=129527#129527

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.