Error when starting myeclipse

Home Forums MyEclipse IDE Comments Error when starting myeclipse

This topic contains 5 replies, has 4 voices, and was last updated by Profile photo of support-swapna support-swapna 3 years, 3 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #246694
    Profile photo of eldobbs
    eldobbs
    Member

    When I try to start myeclipse I recieve the following error(listed below this memo). I have tried uninstalling/reinstalling to no avail….PLEASE HELP!!!!

    !SESSION 2006-02-13 15:50:34.465 ———————————————–
    eclipse.buildId=I20050627-1435
    java.version=1.4.2_09
    java.vendor=Sun Microsystems Inc.
    BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
    Command-line arguments: -os win32 -ws win32 -arch x86

    !ENTRY org.eclipse.osgi 2006-02-13 15:50:34.746
    !MESSAGE Error reading configuration: c:\eclipse\configuration\org.eclipse.osgi\.manager\.fileTableLock (Access is denied)
    !STACK 0
    java.io.FileNotFoundException: c:\eclipse\configuration\org.eclipse.osgi\.manager\.fileTableLock (Access is denied)
    at java.io.FileOutputStream.openAppend(Native Method)
    at java.io.FileOutputStream.<init>(FileOutputStream.java:177)
    at org.eclipse.core.runtime.internal.adaptor.Locker_JavaNio.lock(Locker_JavaNio.java:34)
    at org.eclipse.core.runtime.adaptor.FileManager.lock(FileManager.java:361)
    at org.eclipse.core.runtime.adaptor.FileManager.open(FileManager.java:658)
    at org.eclipse.core.runtime.adaptor.EclipseAdaptor.initFileManager(EclipseAdaptor.java:809)
    at org.eclipse.core.runtime.adaptor.EclipseAdaptor.initialize(EclipseAdaptor.java:139)
    at org.eclipse.osgi.framework.internal.core.Framework.initialize(Framework.java:126)
    at org.eclipse.osgi.framework.internal.core.Framework.<init>(Framework.java:104)
    at org.eclipse.osgi.framework.internal.core.OSGi.createFramework(OSGi.java:90)
    at org.eclipse.osgi.framework.internal.core.OSGi.<init>(OSGi.java:31)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:272)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:159)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:324)
    at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
    at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
    at org.eclipse.core.launcher.Main.run(Main.java:973)
    at org.eclipse.core.launcher.Main.main(Main.java:948)

    !ENTRY initial@reference:file:plugins/org.eclipse.core.runtime_3.1.0.jar/ 0 0 2006-02-13 15:50:35.215
    !MESSAGE FrameworkEvent.ERROR
    !STACK 0
    org.osgi.framework.BundleException: Exception in org.eclipse.core.internal.runtime.PlatformActivator.start() of bundle org.eclipse.core.runtime.
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:1013)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:969)
    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:321)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:339)
    at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1024)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:576)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:498)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:275)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:458)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:189)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:291)
    Caused by: java.io.FileNotFoundException: c:\eclipse\configuration\org.eclipse.core.runtime\.manager\.fileTableLock (Access is denied)
    at java.io.FileOutputStream.openAppend(Native Method)
    at java.io.FileOutputStream.<init>(FileOutputStream.java:177)
    at org.eclipse.core.runtime.internal.adaptor.Locker_JavaNio.lock(Locker_JavaNio.java:34)
    at org.eclipse.core.runtime.adaptor.FileManager.lock(FileManager.java:361)
    at org.eclipse.core.runtime.adaptor.FileManager.open(FileManager.java:658)
    at org.eclipse.core.internal.runtime.InternalPlatform.initializeRuntimeFileManager(InternalPlatform.java:786)
    at org.eclipse.core.internal.runtime.InternalPlatform.start(InternalPlatform.java:1086)
    at org.eclipse.core.internal.runtime.PlatformActivator.startInternalPlatform(PlatformActivator.java:141)
    at org.eclipse.core.internal.runtime.PlatformActivator.start(PlatformActivator.java:57)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:994)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:988)
    … 10 more
    Root exception:
    java.io.FileNotFoundException: c:\eclipse\configuration\org.eclipse.core.runtime\.manager\.fileTableLock (Access is denied)
    at java.io.FileOutputStream.openAppend(Native Method)
    at java.io.FileOutputStream.<init>(FileOutputStream.java:177)
    at org.eclipse.core.runtime.internal.adaptor.Locker_JavaNio.lock(Locker_JavaNio.java:34)
    at org.eclipse.core.runtime.adaptor.FileManager.lock(FileManager.java:361)
    at org.eclipse.core.runtime.adaptor.FileManager.open(FileManager.java:658)
    at org.eclipse.core.internal.runtime.InternalPlatform.initializeRuntimeFileManager(InternalPlatform.java:786)
    at org.eclipse.core.internal.runtime.InternalPlatform.start(InternalPlatform.java:1086)
    at org.eclipse.core.internal.runtime.PlatformActivator.startInternalPlatform(PlatformActivator.java:141)
    at org.eclipse.core.internal.runtime.PlatformActivator.start(PlatformActivator.java:57)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:994)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:988)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:969)
    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:321)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:339)
    at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1024)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:576)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:498)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:275)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:458)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:189)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:291)

    !ENTRY initial@reference:file:plugins/org.eclipse.update.configurator_3.1.0.jar/ 0 0 2006-02-13 15:50:35.246
    !MESSAGE FrameworkEvent.ERROR
    !STACK 0
    org.osgi.framework.BundleException: Exception in org.eclipse.update.internal.configurator.ConfigurationActivator.start() of bundle org.eclipse.update.configurator.
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:1013)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:969)
    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:321)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:339)
    at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1024)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:576)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:498)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:275)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:458)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:189)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:291)
    Caused by: java.lang.Exception: Cannot initialize the Update Configurator
    at org.eclipse.update.internal.configurator.ConfigurationActivator.initialize(ConfigurationActivator.java:89)
    at org.eclipse.update.internal.configurator.ConfigurationActivator.start(ConfigurationActivator.java:67)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:994)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:988)
    … 10 more
    Root exception:
    java.lang.Exception: Cannot initialize the Update Configurator
    at org.eclipse.update.internal.configurator.ConfigurationActivator.initialize(ConfigurationActivator.java:89)
    at org.eclipse.update.internal.configurator.ConfigurationActivator.start(ConfigurationActivator.java:67)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:994)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:988)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:969)
    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:321)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:339)
    at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1024)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:576)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:498)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:275)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:458)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:189)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:291)

    !ENTRY org.eclipse.osgi 2006-02-13 15:50:35.262
    !MESSAGE Startup error
    !STACK 1
    java.lang.IllegalStateException: Bundle initial@reference:file:plugins/org.eclipse.core.runtime_3.1.0.jar/ [1] is not active.
    at org.eclipse.core.runtime.adaptor.EclipseStarter.ensureBundlesActive(EclipseStarter.java:410)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:297)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:159)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:324)
    at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
    at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
    at org.eclipse.core.launcher.Main.run(Main.java:973)
    at org.eclipse.core.launcher.Main.main(Main.java:948)

    #246698
    Profile photo of Riyad Kalla
    Riyad Kalla
    Member

    These errors are a straight Eclipse installation problem. I would encourage you to go here: http://www.eclipse.org/downloads/ and download the most recent (Eclipse 3.1.2) and unzip it to a new location, then install MyEclipse 4.1 GA against it into a new location as well and run it. That should get you fixed up.

    #246703
    Profile photo of eldobbs
    eldobbs
    Member

    Thanks, that did it! And also thanks for the quick response, im very impressed

    However, I would like to know how do i get rid of the original eclipse install? when I try to delete the directory, i recieve the permission denied alert. I am using a machine at work that was recycled from another user who had installed eclipse earlier.

    Thanks again

    #246704
    Profile photo of Riyad Kalla
    Riyad Kalla
    Member

    Well you have the right method, to uninstall Eclipse you simply erase the directory. If you don’t have permissions to do that, try and ask the administrator to come over and erase the directory for you. There is no installer to run or anything like that.

    #324666

    Same problem I am facing with Indigo 3.7.0 which is latest Eclipse for EE developments
    I am logged in as administrator but access for .fileTableLock is denied.
    please help me.

    #324670
    Profile photo of support-swapna
    support-swapna
    Moderator

    yogesh,

    Are you working with Eclipse IDE or MyEclipse ? Did you install MyEclipse on top of Eclipse IDE using the Update site?

    If you are working with only Eclipse IDE, then I suggest you cross post to Eclipse forums : http://www.eclipse.org/forums/ for better support.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.