Fatal error when try to edit .xml file

  1. MyEclipse Archived
  2.  > 
  3. Old Posts
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #229659 Reply


    Created WEB-INFO folder. Tried to create new file within that folder, with name web.xml, but got immediate error dialog that says: Cannot open default editor on web.xml. Unable to instantiate editor: org.jboss.ide.eclipse.jdt.j2ee.xml.ui.editors.WebXmlEditor java.lang.NoClassDefFoundError:

    #229728 Reply

    Scott Anderson


    We don’t ship this class. Its provided by another product you have installed so you should consult them for a workaround. If you’ll install MyEclipse on a clean Eclipse 3.0.2 installation you shouldn’t have any further problems.

    #229749 Reply


    I started over with a fresh Eclipse 3.0.2 installation. Then I purchased, downloaded, and installed MyEclipse. I still get the same error.

    #229751 Reply


    I should mention that this only happens when I first create a .xml file, or when I double-click on an existing .xml file. If I right click and select Open with <some editor> it works fine.

    #229755 Reply

    Riyad Kalla

    As Scott mentioned we don’t ship that class, so what is likely happening is that you are reusing the same workspace which stores plugin cache data as well as file association information, so I’m guessing in your old workspace your XML files were associated with the JBossIDE’s XML editor and not the MyEclispe XML Editor. You can fix this by navigating to Window > Preferences > Workbench > File Associations and changing the .xml association to use the “MyEclipse XML Editor” by default.

Viewing 5 posts - 1 through 5 (of 5 total)
Reply To: Fatal error when try to edit .xml file

You must be logged in to post in the forum log in