Floating point exception when upgrading SDC

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of ic.gc.ca ic.gc.ca 4 days, 8 hours ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #512116 Reply
    Profile photo of ic.gc.ca
    ic.gc.ca
    Participant

    I’m trying to upgrade SDC. I have “Secure Delivery Center – 2015 SR4b” running now on:

    SUSE Linux Enterprise Server 10 SP3 (x86_64)
    Linux version 2.6.16.60-0.54.5-smp (geeko@buildhost) (gcc version 4.1.2 20070115 (SUSE Linux))

    I downloaded secure-delivery-hub-2017-installer-linux.run and tried to run:

    /data00/sdc/downloads/secure-delivery-hub-2017-installer-linux.run --unattended /home/sdc/unattended.properties

    I get the following result:

    Starting installer – please wait…
    – Preparing install engine
    – Extracted install engine
    – Detected JVM architecture: 32 bit
    – Launching install engine with console output
    /data00/sdc/downloads/secure-delivery-hub-2017-installer-linux.run: line 337: 21454 Floating point exception${distdir}/${installername}/installer/${exename} “${0}” ${propspad} –unattended “${unattendedfile}” ${otherargs}
    – Exited install engine

    There are no logs created, so there’s not enough information to debug this… Help is welcomed.

    Thanks

    #512119 Reply
    Profile photo of ignaciom
    ignaciom
    Participant

    Indeed, a weird error 🤔. Could you please share with us the output of executing java -version. From 2017 SDC installers require Java 1.8 I wonder if there is something different with your system configuration. A workaround could be to download the latest 1.8 JRE from oracle site and extract it somewhere on your system, no need to properly install, the installer will do the right thing, then when executing the installer do it with something like:

    /data00/sdc/downloads/secure-delivery-hub-2017-installer-linux.run -vm ${YOUR_PATH_FOR_EXTRACTED_JRE} --unattended /home/sdc/unattended.properties

    The ${YOUR_PATH_FOR_EXTRACTED_JRE} should be the root of the JVM that will mean having the bin directory as first child.

    Best Regards
    Ignacio
    SDC Support

    • This reply was modified 4 days, 23 hours ago by Profile photo of ignaciom ignaciom.
    #512200 Reply
    Profile photo of ic.gc.ca
    ic.gc.ca
    Participant

    Ignacio, thanks for the quick response and succinct suggestion. I still have the same problem, though…

    As requested, here’s the output of java -version for the original JVM that caused the error:

    java version “1.8.0_66”
    Java(TM) SE Runtime Environment (build 1.8.0_66-b17)
    Java HotSpot(TM) Server VM (build 25.66-b17, mixed mode)

    I got the most recent 32bit and 64bit JREs from Oracle and tried:

    First for 32-bit:

    Then for 64-bit:

    Thanks.

Viewing 3 posts - 1 through 3 (of 3 total)
Reply To: Floating point exception when upgrading SDC