Flush Runtime Logs

This topic contains 8 replies, has 2 voices, and was last updated by  Brian Fernandes 3 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #609169 Reply

    jacobshen
    Participant

    When I save the file, myeclipse will always show the dialog for a long time, and I can’t do anything. It’s annoying. Is there any way to avoid this? Thanks!

    Attachments:
    You must be logged in to view attached files.
    #609171 Reply

    Brian Fernandes
    Moderator

    Jacob,

    Sorry to hear you’re running into this – certainly sounds annoying. Can you please answer the following questions for us:

    1) What version of MyEclipse is this? Please check the build Id at Help > About
    2) Does this happen when you’re saving all types of files? Does it happen only when you’re saving a file in a particular project? You could try creating a dummy project and edit / save files there to see if it makes a difference.
    3) Have you added any third party software to MyEclipse? Has this started happening just now (if yes, can you think of any recent changes that may be causing this?), or have you always had this experience with this version of MyEclipse?
    4) Please clear your Eclipse error log, using the Delete Log button in the Error log view, reproduce the error and then shut down. Please share this file with us: [workspace_location]/.metadata/.log.

    We will have further questions, but these answers will help us drive the investigation in the right direction. Thanks!

    #609173 Reply

    jacobshen
    Participant

    Brian,
    Thanks for your reply, here is the answers:

    1) Version: CI 2018.12.0
    2) It happens in any projects, any files. Sometimes no flush runtime logs, but still have to wait(See the Attachment).
    3) I added some plugins, like jRebel. This problem also happened in the previous versions, even in mac OS, it also occurred. At first I thought maybe my computer is too old to run this version of MyEclipse, recently I changed to a new one but still the same.
    4) I uploaded the log file. Looks like my project has some error, is this the reason that cause the problem?
    Hope these can help, Thanks again.

    Attachments:
    You must be logged in to view attached files.
    #609178 Reply

    Brian Fernandes
    Moderator

    Jacob,

    Thanks for the prompt response. I don’t think the errors in the project result in this “waiting/flushing” delay.

    1) Something to try though, is to see if you experience the delay in a non-Spring project.
    2) In your MyEclipse perspective, do you have the JPA Annotations, Spring Annotations or JAX-WS annotations views open? If yes, please close them all, restart MyEclipse and see if you can reproduce the delays. This is a bug that was fixed in 2018.12, so it should not make a difference, but would like to make sure.
    3) Any idea if the problem occurred prior to installing JRebel? Does it happen only to projects that are deployed – with the server running?
    4) If you can reproduce the problem and get us 2-3 thread dumps while your instance is stuck, we can see what processes are running and hopefully figure this out. Thread dump instructions follow:

    jstack -l 9000 > dump1.txt
    Please replace 9000 with the PID of the MyEclipse process, the jstack program can be found in the bin directory of any JDK installation. If you can generate 2-3 dumps (sent to different files, of course) during that period, please attach those files here.

    #609181 Reply

    jacobshen
    Participant

    Brian,
    Thanks for help.
    1) I just created a simple java project and tried to do save actions. No delay occurs.
    2) I have none of these views open.
    3) I stopped the server, still happened.
    4) The PID of the MyEclipse process, you mean javaw.exe not myeclipse.exe right? I attached 3 files.
    Hope I did right, because I don’t quite understand this.

    Attachments:
    You must be logged in to view attached files.
    #609190 Reply

    Brian Fernandes
    Moderator

    Jacob,

    Just wanted to say that those dumps have been very useful. We’re currently looking at all the involved pieces and trying to figure out the reason for the delays, and see if we can send you a workaround.

    We’re looking at this as a high priority case, please stay tuned for updates. Apologies for the frustrating experience!

    #609196 Reply

    Brian Fernandes
    Moderator

    Jacob,

    Could you go to Window > Preferences > Frameworks > Spring, uncheck the AOP Reference Model Builder, and then choose Apply and Close?

    Note that this property can be set at the project level too, so you might wan to confirm that it is not overridden and ON at the project level. Check the Project Properties > Project Facets > Spring page and the General Project Configuration tab.

    Once you’re sure it’s off, restart MyEclipse just to be doubly sure these changes take effect. Can you still replicate the problem?

    Thanks!

    #609199 Reply

    jacobshen
    Participant

    Brian,
    Seems the problem is resolved, no more delay now. Though I don’t know why, but It helps.
    Thanks for your help! The problem has annoyed me for a long time, I truly appreciate it.

    #609266 Reply

    Brian Fernandes
    Moderator

    Jacob,

    Thank you for writing back and letting us know – we’re glad this fixed the problem, and sorry you had to put up with it for so long!

    Internally we know why this “AOP Builder” causes the problem (the fault is elsewhere, not with the builder itself), though we’re still unable to reproduce the massive delays that you have been experiencing. We’ve targeted this as a critical fix for the next MyEclipse release, so you won’t have to turn off the builder when you update to the next version.

    Thanks again for reaching out to us, and helping us fix an important bug.

Viewing 9 posts - 1 through 9 (of 9 total)
Reply To: Flush Runtime Logs

You must be logged in to post in the forum log in