formatter and auto completes stops working after formatting PHP code

This topic contains 8 replies, has 3 voices, and was last updated by  Dale 2 weeks, 2 days ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #601305 Reply

    Dale
    Participant

    So i’m using angular 6 in the ide and works ok most of the time. I also have php files in the same project.

    After formatting the php files the formatter, auto completes stops working for all files.

    I have to close and open webclipse ide to get it working again.

    I’ve uninstalled, then installed with latest using a new workspace and same thing happens. PHP is linked to xampp running locally.

    Any ideas?

    Thanks

    #601306 Reply

    Dale
    Participant

    Also i get this:
    Exit value: 1

    Process output:

    [main 5:41:41 PM] update#ctor – updates are disabled

    #601331 Reply

    support-swapna
    Moderator

    Dale,

    Sorry that you are seeing this issue.

    Can you please give us some more details?

    1. Can you please clarify if you have upgraded to the new CodeMix 2.0 or working with Webclipse plugin on Eclipse IDE or with stand alone Angular IDE? If you are working with Eclipse IDE, then please share with us the Eclipse version details from Help > About section.

    2. I am not sure how you are linking the PHP file to XAMPP locally. Can you please elaborate on the steps to help me replicate your environment? Also let us know the editor in which the PHP files are being opened. Right click on the PHP file > Open With and check which editor is selected.

    3. Please also share with us the log file from the new workspace for further investigation. Click on the ‘Export Log’ icon in the Error Log view, save it as .txt file and attach it. If you do not find the Error Log view, then the log file will be located in your workspace dir/.metadata/.log.

    4.

    Exit value: 1
    Process output:
    [main 5:41:41 PM] update#ctor – updates are disabled

    When exactly are you see this error?

    Apologies for inconvenience caused.

    –Swapna
    Genuitec Support

    #601359 Reply

    Dale
    Participant

    Hi

    1) i’m using webclipse ide
    eclipse:
    Version: 4.9.0.v20180906-1121
    Build id: I20180906-0745

    please see images attached

    2) the file is opened with PHP :: Codemix
    at first it said it needed php 7 and was linking with 5.
    So if you right click on a php file -> properties -> run / debug, then you can see the php executable path in the advanced section: ‘C:\xampp7\php\php.exe’ it might not be related but i changed that.
    Also just saw it sets ‘ “runtimeExecutable”: “C:\\xampp7\\php\\php.exe”‘ in launch.json

    3) attached .log from metadata/.log. i have also attached log_old.log from my other workspace which may also help

    4) this pops up on the start up sometimes.

    Many Thanks,
    Dale

    Attachments:
    You must be logged in to view attached files.
    #601427 Reply

    Salvador Cabrera
    Participant

    Hi Dale,

    In order to help you resolve this problem, we need to gather more info about what’s going with your Eclipse.
    To enable logging this info, you’ll need to:

    – Edit eclipse.ini, you can find this file in the same dir as your eclipse executable, add the following lines at the bottom:

    – Start Eclipse and replicate the problem
    – Close Eclipse

    Please share the “.log” files located in the “.codemix” in your user directory.

    Best Regards,
    Sal

    #601553 Reply

    Dale
    Participant

    Hi Sal

    Please find document attached.

    So basically i:
    1. opened the php file and pressed ctrl + shift + f to format (did this a couple of times as the first line didn’t format but it did in other places)

    2. opened a typescript file and pressed the same format keys and no longer formats.

    On start i got but was working fine after:
    -Exit value: 1
    -Process output:
    -[main 10:44:47 PM] update#ctor – updates are disabled

    at one point a dialog popped up in the corner when trying to format both files:

    – there is no document formatter for ‘php’-files installed

    – there is no document formatter for ‘typescript’-files installed

    Hope this helps.

    Thanks
    Dale

    Attachments:
    You must be logged in to view attached files.
    #601574 Reply

    Salvador Cabrera
    Participant

    Hi Dale,

    Thanks for your help, we have identified a problem when trying to update some extensions at launch but this process always fails and can cause some unexpected behavior.
    We are working on a potential fix for you which i estimate it should be ready tomorrow.
    As a temporary workaround, when you start Eclipse, please wait until the CodeMix Engine has been restarted (Few seconds after the christian-kohler.npm-intellisense.1.3.0.vsix and linyang95.php-symbols.2.1.0.vsix, see the attached screenshot).
    Then you can proceed to use Eclipse as usual.

    Please let us know how it goes.

    Best Regards,
    Sal

    Attachments:
    You must be logged in to view attached files.
    #601667 Reply

    Salvador Cabrera
    Participant

    Hi Dale,

    We have released a fix for this recurrent extensions update process problem, christian-kohler.npm-intellisense.1.3.0.vsix and linyang95.php-symbols.2.1.0.vsix extensions had problems with the version in the manifest files, the corrected versions of these extensions are already available to get installed.

    In order to get these fixed extensions you just need to restart Eclipse, and this will trigger the extensions update process one more time to pull the fixed extensions, so if you restart Eclipse again, you shouldn’t see these extensions being updated anymore.

    Please let us know if you have any remaining issues.

    Best Regards,
    Sal

    #601751 Reply

    Dale
    Participant

    I can confirm it is working now. Even better with the latest release fixes as well.

    Cheers
    Dale

Viewing 9 posts - 1 through 9 (of 9 total)
Reply To: formatter and auto completes stops working after formatting PHP code