Installation broken, can’t uninstall…

  1. MyEclipse Archived
  2.  > 
  3. Old Posts
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #196134 Reply


    Install hung at “Installing… Uninstall MyEclipse Enterprise Workbench.exe”

    Jboss launching in Eclipse (which worked before) now totally broken and I can’t uninstall MyEclipse. Shouldn’t have installed this.

    #196135 Reply

    Scott Anderson

    I’m sorry to hear about your experience and must admit we’re very surprised to hear this. We’ve installed and uninstalled this InstallAnywhere-based installer hundreds of times, on mutiple configurations, and have never seen a problem such as this. Did you quit all executing Windows applications as the installer suggested? Which operating system are you running on? Are you very low on disk space or RAM? Any insight you can provide as to any unique properties of your system will help us to see if we can reproduce this behavior.

    That said, since the workbench is installed as an Eclipse product extension, manual uninstallation is very simple if the uninstaller won’t function. Your base Eclipse plugins and settings have not been modified in any way. To revert to your prior configuration, just perform the following:
    1) Exit Eclipse
    2) Delete the file <eclipseinstallation>/links/com.genuitec.eclipse.MyEclipse.link
    3) Delete the directory into which you installed MyEclipse
    4) Restart Eclipse as you used to.

    Again, we apologize for the inconvenience you’ve experienced. Since your machine has been shown to be problematic, to try MyEclipse again I’d suggest you install a separate, clean Eclipse 2.1 installation and then run a fresh MyEclipse installer against that after a reboot.


    MyEclipse Support

    #196136 Reply


    Go to the installation folder and find the uninstaller program there. run that uninstaller will remove your installation.

    But it’s still wired that there is no such an entry in windows add/remove programs to uninstall this plugin.

    Another weird thing is you need to manually delete the link file under %eclipse_home%\link folder

    #196137 Reply

    Scott Anderson

    While it is true that the 2.0 EA installer doen’t add a link on the program menu for uninstalling, it does remove the link file from the <eclipse_home>/links folder when the uninstaller is run in every configuration we’ve seen. On what platform did you experience this behavior?

    A full, automated uninstall can be accessed through the normal Windows manner of going to Control Panels->Add Remove Programs and choosing MyEclipse Enterprise Workbench from the installations selected.

    Version 2.0.1 EA, which is available for download now does have an uninstall link in the program menu as you requested.


    MyEclipse Support

    #196144 Reply


    My platform is windows2000 + sp3 with latest windows hotfix installed. I don’t know why I experienced such a strang thing for the uninstallation.

    Anyway, it’s a great plugin for eclipse platform.

    #196173 Reply


    I’ve also been faced with that king of trouble uninstalling MyEclipse on my win2K sp2, it was even worst in that it had frozen my computer and had to restart it by pushing the reset button !

    Why don’t you say that before installing MyEclipse, we have to delete the following plugins : com.aston.plugins, com.genuitec.eclipse.???, net.sf.solareclipse.??? , because they conflict with the v2 ones included.

    When do you intend to be functionaly at the Lomboz level ?

    #196174 Reply


    We’re sorry to hear about your experience with the uninstallation process of MyEclipse. Which version were you uninstalling? What else was running at the time? When was the last time the machine had been rebooted?

    Regarding the recommendation for uninstalling other products: we specifically don’t recommend this approach because we don’t want to modify a user’s base installation. That way, if for whatever reason, you want to go back to what you had before trying MyEclipse it is very easy for you to do so. Since MyEclipse installs as a product extension, there shouldn’t be any conflict with the plugins you currently have installed. Any that are included in the MyEclipse environment will have higher version number associated with them so they will be loaded by the Eclipse plugin bootstrap process instead of any older duplicated versions from the workbench.

    Regarding functionality, please bear in mind that this is simply the first early adopter release of the product. To find out when a particular feature will become available, please see the product roadmap at http://www.myeclipseide.com/index.php?module=ContentExpress&func=display&ceid=6. If a particular feature you’d like to see is not on the roadmap, please be sure to request it in the appropriate forum.

    #196185 Reply


    I’m also unable to uninstall 2.0.2EA (using WinXP SP1). I’ve tried both Add/Remove Programs, Uninstall from Programs menu and running the uninstaller direct from the directory. Nothing happends..

    So, I installed 2.0.3EA over it. Was that wise? Now, Eclipse tells me that I have two (2.0.[2|3]EA) changes/updates to confirm.

    I followed the 4 step instruction posted in this forum earlier to remove MyEclipse.

    The error log says:

    An unexpected exception has been detected in native code outside the VM.
    Unexpected Signal : EXCEPTION_ACCESS_VIOLATION occurred at PC=0x10010000

    NOTE: We are unable to locate the function name symbol for the error
    just occurred. Please refer to release documentation for possible
    reason and solutions.

    Current Java thread:
    at sun.awt.windows.WToolkit.init(Native Method)
    at sun.awt.windows.WToolkit.run(WToolkit.java:222)
    at java.lang.Thread.run(Thread.java:536)

    Dynamic libraries:
    0x00400000 – 0x00455000 C:\program Files\MyEclipse\MyEclipse-UninstallerData\Uninstall MyEclipse Enterprise Workbench v2.0.2 EA.exe
    0x77F50000 – 0x77FF7000 C:\WINDOWS\System32\ntdll.dll
    0x77E60000 – 0x77F46000 C:\WINDOWS\system32\kernel32.dll
    0x77DD0000 – 0x77E5D000 C:\WINDOWS\system32\ADVAPI32.dll
    0x78000000 – 0x7807F000 C:\WINDOWS\system32\RPCRT4.dll
    0x77D40000 – 0x77DC6000 C:\WINDOWS\system32\USER32.dll
    0x77C70000 – 0x77CB0000 C:\WINDOWS\system32\GDI32.dll
    0x77C00000 – 0x77C07000 C:\WINDOWS\system32\VERSION.dll
    0x6D330000 – 0x6D45A000 c:\program files\java\j2sdk1.4.1_01\jre\bin\client\jvm.dll
    0x76B40000 – 0x76B6C000 C:\WINDOWS\System32\WINMM.dll
    0x77C10000 – 0x77C63000 C:\WINDOWS\system32\MSVCRT.dll
    0x6D1D0000 – 0x6D1D7000 c:\program files\java\j2sdk1.4.1_01\jre\bin\hpi.dll
    0x6D300000 – 0x6D30D000 c:\program files\java\j2sdk1.4.1_01\jre\bin\verify.dll
    0x6D210000 – 0x6D229000 c:\program files\java\j2sdk1.4.1_01\jre\bin\java.dll
    0x6D320000 – 0x6D32D000 c:\program files\java\j2sdk1.4.1_01\jre\bin\zip.dll
    0x6D000000 – 0x6D0FB000 C:\Program Files\Java\j2sdk1.4.1_01\jre\bin\awt.dll
    0x73000000 – 0x73023000 C:\WINDOWS\System32\WINSPOOL.DRV
    0x76390000 – 0x763AC000 C:\WINDOWS\System32\IMM32.dll
    0x771B0000 – 0x772D1000 C:\WINDOWS\system32\ole32.dll
    0x10000000 – 0x10089000 C:\WINDOWS\System32\nView.dll
    0x773D0000 – 0x77BC2000 C:\WINDOWS\system32\SHELL32.dll
    0x70A70000 – 0x70AD4000 C:\WINDOWS\system32\SHLWAPI.dll
    0x76BF0000 – 0x76BFB000 C:\WINDOWS\System32\PSAPI.DLL
    0x73760000 – 0x737A4000 C:\WINDOWS\System32\DDRAW.dll
    0x73BC0000 – 0x73BC6000 C:\WINDOWS\System32\DCIMAN32.dll
    0x71950000 – 0x71A34000 C:\WINDOWS\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.10.0_x-ww_f7fb5805\comctl32.dll
    0x77340000 – 0x773CB000 C:\WINDOWS\system32\comctl32.dll
    0x0A9F0000 – 0x0AA06000 C:\WINDOWS\System32\NVWRSSV.DLL
    0x76C90000 – 0x76CB2000 C:\WINDOWS\system32\imagehlp.dll
    0x6D510000 – 0x6D58D000 C:\WINDOWS\system32\DBGHELP.dll

    Local Time = Sun May 18 18:46:45 2003
    Elapsed Time = 1
    # The exception above was detected in native code outside the VM
    # Java VM: Java HotSpot(TM) Client VM (1.4.1_01-b01 mixed mode)

    Any help appreciated.

    #196187 Reply

    Scott Anderson


    Our installer and uninstaller are created with the latest version of Zero G’s Install Anywhere Enterprise. Have you ever had an issue running any other Install Anywhere or Swing-based installer? The reason I ask is that I’ve got a Win 2K laptop upon which I’ve hopelessly bashed something deep in the internals so that I get a blue screen whenever I run ANY Swing application. Just want to be sure you don’t have any kind of a similar situation.

    The next thing we need to do is get you up and running properly so what I’d suggest is going through the manual uninstall that is documented earlier in this thread and as an FAQ. Then start Eclipse without any version of MyEclipse installed. Check your perspectives and open any additional views you need just to ensure that everything looks ok. Then, close ALL your editors and exit Eclipse. Next, run the new 2.0.3 EA installer and restart Eclipse. This should get you up and running. Please let us know if you discover anything that might shed some light on the problem you experienced and let us know whether or not this procedure got you up and running.


    MyEclipse Support

Viewing 9 posts - 1 through 9 (of 9 total)
Reply To: Installation broken, can’t uninstall…

You must be logged in to post in the forum log in