Invalid html completion of parameterized types.

  1. CodeMix & Angular IDE > Suggestions

This topic contains 4 replies, has 2 voices, and was last updated by  support-tony 1 year, 10 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #604113 Reply

    Paul
    Participant

    Start typing something like ‘new Array<string>’ and it’ll auto complete a closing html tag ‘new Array<string></string>’. HTML completion should only occur inside strings or comments.

    #604129 Reply

    support-tony
    Keymaster

    Paul,

    That must be really annoying but, so far, I’ve been unable to replicate the problem so some extra information would help.

    1. Which editor are you seeing the problem in and with which type of source file?
    2. Which release of CodeMix are you using, with which release of eclipse? If you’re using MyEclipse or Angular IDE, please mention the release of that product.

    Hopefully, this will give us enough info to be able to determine the cause and get you sorted.

    #604130 Reply

    Paul
    Participant

    Latest version installed via npm.

    Typescript files (*.ts)

    #604131 Reply

    support-tony
    Keymaster

    Paul,

    Thanks for that. I can now replicate the issue and have raised a problem report for development to investigate. We’ll get back to you about the fix to the problem.

    Thanks for reporting it and apologies for the inconvenience.

    #604145 Reply

    support-tony
    Keymaster

    Paul,

    I’m not sure if this would be an option for you but it’s possible to exclude TypeScript files from the auto-closing of tags. If you go to the Preferences page for CodeMix and select Settings>Workspace Settings, click the setting.json link near the bottom, to edit the settings file directly. Now add a setting similar to the following:

    Instead of the languages I’ve listed, just list those languages where you want to see automatic closing of tags. The list of languages currently set, may not be in this file, as they are implied, but can be seen by hovering over the value of the auto-close-tag-activationOnLanguage setting, as shown in the attached screenshot.

    We will still investigate how to allow auto-close in the appropriate sections of TypeScript files but I hope this helps.

    Attachments:
    You must be logged in to view attached files.
Viewing 5 posts - 1 through 5 (of 5 total)
Reply To: Invalid html completion of parameterized types.

You must be logged in to post in the forum log in