Javadoc hover not working

Home Forums MyEclipse IDE WebSphere Development Javadoc hover not working

This topic contains 7 replies, has 3 voices, and was last updated by Profile photo of support-tony support-tony 3 years, 5 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #322207

    In the Java editor, when I hover over a class, the popup window opens but it says, “This element neither has attached source nor attached Javadoc and hence no Javadoc could be found.”

    This only happens with non-Java classes, i.e. hovering over a String will open up the Javadoc for java.lang.String, but if I hover over a Spring WebArgumentResolver I get the message above.

    I have went into the Libraries tab under Java Build Path and verified that I have the Javadoc location set for all my libraries. For the Spring JARs, I am using: http://static.springsource.org/spring/docs/3.0.x/javadoc-api/

    I don’t have this issue with the same project on a different computer.

    I reference Javadoc quite often for Spring, so it’s making development a pain. Any ideas?

    Edit: Attached MyEclipse info.

    Attachments:
    You must be logged in to view attached files.
    #322237
    Profile photo of support-joy
    support-joy
    Member

    awnry,

    Sorry to hear you are running into this issue. You have attached configuration details. I would require you to send me installation details. Please provide below details to help me investigate further –
    1. Open MyEclipse IDE, from menu options click on MyEclipse > Installation Summary > Installation Details and copy and paste the same here
    2. Could you attach the sample project as .zip to help me reproduce this at my end
    3. Clear your .log file located at [your workspace dir]/.metadata/.log, replicate the issue and attach the file here

    #322328

    Hi support-joy,

    Sorry for the delay. I’ve been busy at work. :)

    Here is the install details; I meant to post these before, but I guess I copied the wrong thing.

    *** Date: 
    Friday, January 13, 2012 11:21:39 AM CST
    
    ** System properties:
    OS=WindowsXP
    OS version=5.1.0
    Java version=1.6.0_13
    
    
    *** MyEclipse details:
    MyEclipse Enterprise Workbench
    Version: 9.1
    Build id: 9.1-20110701
    
    
    *** Eclipse details:
    MyEclipse Enterprise Workbench
    
    Version: 9.1
    Build id: 9.1-20110701
    
    
    
    
    
    
    Eclipse startup command=-os
    win32
    -ws
    win32
    -arch
    x86
    -showsplash
    -launcher
    C:\Program Files\MyEclipse\MyEclipse 9\myeclipse.exe
    -name
    Myeclipse
    --launcher.library
    C:\Program Files\MyEclipse\MyEclipse 9\../Common/plugins/org.eclipse.equinox.launcher.i18n.win32.win32.x86_3.2.0.v201103301700\eclipse_3215.dll
    -startup
    C:\Program Files\MyEclipse\MyEclipse 9\../Common/plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
    -install
    C:\Program Files\MyEclipse\MyEclipse 9
    -configuration
    C:\Program Files\MyEclipse\MyEclipse 9\configuration
    -vm
    C:\Program Files\MyEclipse\Common\binary\com.sun.java.jdk.win32.x86_1.6.0.013\jre\bin\client\jvm.dll
    

    I posted a very barebones project that illustrates the problem. It will not compile because I removed a LOT of things I couldn’t post for security reasons, but if you go to the only Java file, AccountController, and hover over any of the Spring annotations or imports you shouldn’t see any Javadoc pop up, despite the Javadoc location being set in the build path libraries tab.

    After deleting the log file in .metadata, nothing I do creates a new one, yet the problem still remains when hovering over the Spring stuff.

    Attachments:
    You must be logged in to view attached files.
    #322394
    Profile photo of support-joy
    support-joy
    Member

    awnry,

    Thank you for the attached project. I am afraid, I could not replicate the issue. I am able to see the Javadoc while hovering on the spring annotations or imports. Could you attach screenshot to help me get a visual and also .log file located at [your workspace dir]/.metadata/.log.

    I would recommend you create a new barebone project and see if you can recreate this issue. Next create a new workspace and retry.

    Let me know how this works for you.

    #322480

    Yeah, I think it’s my workspace or MyEclipse itself because the same project on another machine does not have the problem. I’ve attached my .log as well as a screenshot.

    I’ve tried creating a new barebones project as well as a new workspace, but neither worked unfortunately.

    Attachments:
    You must be logged in to view attached files.
    #322502
    Profile photo of support-joy
    support-joy
    Member

    awnry,

    Thank you for the attached .log file. I see below issue repeatedly listed

    !ENTRY com.genuitec.eclipse.core.common 1 0 2012-01-19 10:46:34.162
    !MESSAGE Resource ‘/Enrollment/WebContent/WEB-INF/channel.jsp’ does not exist.
    !STACK 1
    org.eclipse.core.internal.resources.ResourceException: Resource ‘/Enrollment/WebContent/WEB-INF/channel.jsp’ does not exist

    Please investigate in these lines and fix this issue – either channel.jsp does not exist in the listed path or a reference is missing. Next clear .log file, replicate and recheck.

    You mention this is the issue with your current workspace. I would recommend you perform -clean, refer – https://www.genuitec.com/forums/topic/troubleshoot-using-the-clean-command-line-argument/

    In case clean does not resolve the issue, I have to recommend you to create a new workspace.

    #322640

    Hi support-joy,

    I ran myeclipse -clean, but that did not help.

    I also created a new workspace, and imported the project, but still nothing. :( I even tried checking out a fresh working copy into the new workspace.

    Those errors in the log are from a different project.

    Is there anything else I can try?

    #322655
    Profile photo of support-tony
    support-tony
    Keymaster

    awnry,

    The problem is that you have some jars defined twice in your project. You have them defined in Web App Libraries and as stand-alone jars, which appear under Referenced Libraries. The Web App Libraries appear first in the ordering of libraries but don’t have Javadoc attached and so the hover help finds the class using the Web Apps Libraries definition, without Javadoc.

    So you should remove the duplicate references to jars and attach Javadoc to the single reference left.

    Please let us know if this fixes the problem.

    I’m not sure why it works on another machine but if the Web App Libraries are moved to the bottom of the ordering (or if the Javadoc is attached to both definitions), then that would explain it.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.