Jboss Server Does Not Recognize Deployment After Migration

This topic contains 1 reply, has 2 voices, and was last updated by  support-swapna 5 months, 2 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #544692 Reply

    eugenejsn
    Participant

    Initially, I created a project on MyEclipse Pro 2014 version. Recently, I migrated the project over to MyEclipse 2017 version. However, after I migrated over, I cannot add my EAR deployment to the Jboss As v7x server (before on the 2014 version it can). Whenever I right click on the server and select add/remove deployments, it popups a message saying, “There are no resources that can be added or removed from the server.”

    Any help would be appreciated.

    Thanks,

    Eugene

    #544744 Reply

    support-swapna
    Moderator

    Eugene,

    Thank you for upgrading to MyEclipse 2017. Sorry that you are seeing this issue. JBoss AS 7.x does not support deployment of JavaEE 7 and higher.

    Do you remember choosing any particular runtime in the Migration wizard for the project?

    You can check the JavaEE version for the project in the Project Facets page. Right click on the project > Properties > Project Facets and see if the EAR version is higher than 6.0. Switch to the Runtimes tab, uncheck the selection and then you can set the EAR version to a lower number and then select the appropriate runtime.

    You can also check why the project is not showing up for deployment by right clicking on the project > Run As > MyEclipse Server Application and select ‘JBoss AS 7.x’. You will be reported about the problem in the dialog. If you still need help, then please share with us the message to help us assist you further.

    Apologies for inconvenience caused. Let us know how you get on with this issue.

    –Swapna
    MyEclipse Support

Viewing 2 posts - 1 through 2 (of 2 total)
Reply To: Jboss Server Does Not Recognize Deployment After Migration