JPA / EJB reverse engineer not working in 2015 CI11

  1. MyEclipse IDE
  2.  > 
  3. Java EE Development (EJB, JSP, Struts, XDoclet, etc.)
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #353797 Reply

    Scott Dunbar

    Hi all,
    I periodically use the reverse engineering capabilities of MyEclipse. I’ve been using 2014 for quite some time and recently upgraded to 2015 CI. Today I tried for the first time to use the JPA reverse engineering. It allows me to try but not select a source code directory. In short it is broken.

    I tried to add the JPA facet to my project but I can have Hibernate and JPA enabled (!). That makes no sense.

    Is this either (1) broken or (2) no longer available at my subscription level? I saw that some things like JAX-RS (which is EE, not Spring) only sorta work with the Spring version even though they have nothing directly to do with Spring.

    Do I need to upgrade to a Spring version even if I don’t use Spring so that I can get EE features?

    #353799 Reply



    Sorry that you are seeing issues with MyEclipse 2015 CI 11. I could not replicate the issue with JPA reverse engineering at my end on CI 11.

    I checked with a Professional license and I see the JAX-RS support included.

    Can you please give us some more details?

    1. Can you please go through the JPA tutorial here and check if you see the issue with a new project to rule out project specific issues? : https://www.genuitec.com/products/myeclipse/learning-center/persistence/myeclipse-jpa-tutorial/

    Switch to a new workspace and follow the tutorial.

    2. If you are still seeing issues, please send us the screenshots of the issue you are seeing to help us get a visual. If possible please share with us the project along with the database details.Also attach the .log file which is located at <workspace dir>/.metadata/.log.

    3. Please share the MyEclipse Build Id from Help > About section. Also ‘pm’ me your license details to help us investigate further.

Viewing 2 posts - 1 through 2 (of 2 total)
Reply To: JPA / EJB reverse engineer not working in 2015 CI11

You must be logged in to post in the forum log in