JSTL 1.1 – bad XSD ref. in JWSDP [Closed]

This topic contains 6 replies, has 3 voices, and was last updated by Profile photo of support-michael support-michael 11 years ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #219374 Reply

    I had this in another thread but it was marked closed, so posting here.

    I’ve tried your test project for JSTL at


    , but I noticed you didn’t have the JSTL 1.1 TLD files in your WEB-INF. It seems that if you try and use the the 1.1 TLD files the TLD editor seems to think these files are malformed in some way. Or atleast that is what I am getting.

    The error reported in the problem description is…
    “cvc-elt.1: Cannot find the declaration of element ‘taglib'”

    Is there anything special required to get the MyElcipse TLD editor to recognize schema based tld files?

    Roy Wells

    #219385 Reply
    Profile photo of Scott Anderson
    Scott Anderson


    If the new files refer to a custom schema you should add them to the XML Catalog at Window > Preferences > MyEclipse > Editors > XML > XML Catalog.

    #219405 Reply

    These are the standard TLD files from sun for the JSTL 1.1 Taglibraries coming from the JWSDP distribution. I even see the entry in the XML Catalog referring to the appropriate schema location.


    do Taglibraries for the latest servlet spec not work?

    to recreate what I’m seeing. Take the TestJSTL1.1 project i mentioned and import the JSTL 1.1 tld files into the WEB-INF directory.

    Roy Wells

    #219462 Reply
    Profile photo of support-michael

    What version of MyEclipse are you using for this evaluation?

    I am not able to replicate this behavior with the latest ME 3.8.2 release.

    #219477 Reply

    Eclipse Platform

    Version: 3.0.1
    Build id: 200409161125Eclipse Platform

    MyEclipse Help Documentation

    Version: 3.8.2
    Build id: 200409171200-3.8.2

    Windows Server 2003

    The steps I followed …

    1) created a webproject.

    2) imported jstl.jar and standard.jar from the latest download of Java Web Services Developer Pack.

    3) imported c.tld from the same web services developer pack.

    4) problem marker shows up on c.tld.

    I can however import c-1_0.tld with out any problems.

    Thanks for the help.

    #219478 Reply

    I figured it out..

    the tld’s from Sun have this in the xsi:schemalocation

    xsi:schemaLocation=”http://java.sun.com/xml/ns/j2ee web-jsptaglibrary_2_0.xsd”

    however if you change it to


    the problem markers go away.

    I would assume both are probably valid but tld editor only likes the latter version.

    Roy Wells.

    #219485 Reply
    Profile photo of support-michael

    Thanks for the feedback. In my 1st reply I tried the exact steps using with JSTL 1.1 (standard 1.2 from Jakarta) and it worked w/o issue. So I was assuming either the TLD or something else was incorrect. I’m glad this is working for you.

Viewing 7 posts - 1 through 7 (of 7 total)
Reply To: JSTL 1.1 – bad XSD ref. in JWSDP [Closed]