facebook

MarketplaceDiscoveryStrategy failed with an error

  1. MyEclipse IDE > Installation, Configuration & Updates

This topic contains 4 replies, has 3 voices, and was last updated by  jheasly 1 week, 1 day ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #674813 Reply

    jheasly
    Participant

    Hi,
    I continue to encounter the MarketplaceDiscoveryStrategy PKIX path builder failure when trying to access the Marketplace after updating my config.ini file:
    com.genuitec.pulse.delivery.mpc.include.patterns=^https\://marketplace.eclipse.org.*

    I can access the URL logged in the error details with the IDE’s internal browser and am using the Native provider in Network Connections which is consistent with my Windows 10 proxy settings. The URL is:

    https://marketplace.eclipse.org/api/p?client=org.eclipse.epp.mpc.core&client.version=1.8.0.v20190725-1807&os=win32&ws=win32&nl=en_US&java.version=13&product=com.genuitec.myeclipse.product.ide&product.version=16.0.0.CI-005&runtime.version=3.16.0.v20190823-1314&platform.version=4.13.0.v20190916-1045

    I am using
    MyEclipse Enterprise Workbench
    Version: 2019.12.5
    Build id: 16.0.0-20191205.

    Is there a fix for this issue in a more recent version of My Eclipse? (I looked in the Delivery Log but didn’t see it explicitly called out.)

    Thank you for any help you can provide! Let me know if you need more information.

    #674820 Reply

    support-swapna
    Moderator

    Hi,

    Sorry that you are seeing this issue. Manually adding the https url should work in older versions. Our newer versions refer to the https url automatically.

    1. Can you please share with us the screenshot of the Network Connections preferences page along with the .log file located at workspace dir/.metadata/.log? Rename the extension to .txt and attach it here. Before sending us the log, clear the contents, restart the IDE, try to access the Marketplace and then send it to help us get the fresh list of errors logged.

    2. If you ignore the marketplace, are you able to install plugins from an update site with these proxy settings? If you add any update site in the Help > Install from Site dialog – for example: https://dbeaver.io/update/latest – does this show you a list of items that can be installed (you don’t need to proceed with the install), or does this also fail? This will help us determine whether the problem is with the proxy settings or something specifically wrong with the marketplace.

    Apologies for inconvenience caused.

    –Swapna
    Genuitec Support

    #674883 Reply

    jheasly
    Participant

    Hi,

    Thank you for your response. Screenshots of Network Connections page and Update from Sites page attached, as well as .log file, cleared and re-populated per your instructions, and renamed. I hope this is what you need – let me know if not.

    Joe H

    Attachments:
    You must be logged in to view attached files.
    #674903 Reply

    Brian Fernandes
    Moderator

    Joe,

    Thanks for the details and the log file. The error you see is actually different from this issue with the marketplace that affected earlier versions of MyEclipse.

    I believe what you’re running into, is Java’s inability to communicate with HTTPS URLs (so HTTP URLs would work, and HTTPS URLs would work in the browser, just not through Java), due to the way in which some proxy servers behave. You could prove this by repeating the test Swapna suggested above with an HTTPS update site – https://update.zeroturnaround.com/update-site/ or https://download.eclipse.org/egit/github/updates. Does this work?

    Also, if I understand correctly, you are connected through a proxy (even if transparent), correct?

    The only solution I can think of now would be to try installing a more recent version of Java and modify your myeclipse.ini file (the -vm argument) to point to that version. Given that you are already on Java 13, the chances of Java 16 making a difference here isn’t too high, but it would be worth trying.

    #675012 Reply

    jheasly
    Participant

    Thank you for the reply, Brian.

    Yes, I do connect thru a proxy, tho it’s ‘transparent’ to me. Maybe not if it’s behind these errors…

    I tried Swapna’s test using the URLs you suggested. The JRebel site works – I get upgrade options to select in the Available Software panel when I select it. The github site does not work – I get the PKIX error. I tried with tne Eclipse Discovery site (http://downloads.genuitec.com/downloads/packs/eclipse-discovery/v4.13.0/updatesite), and found that the http URL worked but the https URL caused the PKIX error. If this suggests anything else to you, please let me know. Meanwhile I’ll see if our network team can add anything.

    Thanks again,
    Joe

Viewing 5 posts - 1 through 5 (of 5 total)
Reply To: MarketplaceDiscoveryStrategy failed with an error

You must be logged in to post in the forum log in