Matisse InvalidComponent can not load class

Home Forums Archived Forums MyEclipse Archived Matisse/Swing UI Development Matisse InvalidComponent can not load class

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of support-swapna support-swapna 3 years, 3 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #325010

    I have some custom components, suddenly they are shown as invalid component in all forms added.I am tried changing dt.jar location, setting same java version my eclipse ini file and project path.But it does not work.When I run program, it is able to show components.

    If I make any changes to form, all component references indicates errors.When I remove component Matisse Custom Palette, add again it gives exception

    Can not load component class.the class must be compiled and must be on the classpath of project.

    java.lang.ClassNotFoundException:
    at com.genuitec.eclipse.dehory.util.MatisseClassLoader.findClass(MatisseClassLoader.java:335)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Unknown Source)
    at org.netbeans.modules.form.project.ClassPathUtils.loadClass(ClassPathUtils.java:115)
    at org.netbeans.modules.form.MetaComponentCreator.prepareClass0(MetaComponentCreator.java:1325)
    at org.netbeans.modules.form.MetaComponentCreator.access$5(MetaComponentCreator.java:1310)
    at org.netbeans.modules.form.MetaComponentCreator$4.run(MetaComponentCreator.java:1293)
    at org.netbeans.modules.form.FormLAF$2.run(FormLAF.java:228)
    at org.openide.util.Mutex.doEventAccess(Mutex.java:1355)
    at org.openide.util.Mutex.readAccess(Mutex.java:317)
    at org.netbeans.modules.form.FormLAF.executeWithLookAndFeel(FormLAF.java:213)
    at org.netbeans.modules.form.MetaComponentCreator.prepareClass(MetaComponentCreator.java:1290)
    at org.netbeans.modules.form.MetaComponentCreator.precreateVisualComponent(MetaComponentCreator.java:244)
    at org.netbeans.modules.form.HandleLayer$NewComponentDrag.init(HandleLayer.java:2634)
    at org.netbeans.modules.form.HandleLayer$NewComponentDrag.<init>(HandleLayer.java:2628)
    at org.netbeans.modules.form.HandleLayer.mouseMoved(HandleLayer.java:1712)
    at java.awt.AWTEventMulticaster.mouseMoved(Unknown Source)
    at java.awt.Component.processMouseMotionEvent(Unknown Source)
    at javax.swing.JComponent.processMouseMotionEvent(Unknown Source)
    at java.awt.Component.processEvent(Unknown Source)
    at java.awt.Container.processEvent(Unknown Source)
    at java.awt.Component.dispatchEventImpl(Unknown Source)
    at java.awt.Container.dispatchEventImpl(Unknown Source)
    at java.awt.Component.dispatchEvent(Unknown Source)
    at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
    at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
    at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
    at java.awt.Container.dispatchEventImpl(Unknown Source)
    at java.awt.Component.dispatchEvent(Unknown Source)
    at java.awt.EventQueue.dispatchEvent(Unknown Source)
    at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.run(Unknown Source)

    #325046
    Profile photo of support-swapna
    support-swapna
    Moderator

    deryaaltuntas ,

    Sorry that you are seeing this issue.

    1. Can you please share the Installation details from MyEclipse > Installation Summary > Installation Details ? Paste them here for us.

    2. Did you install any third party plugins? Did you update any of the features recently which might have caused this issue?

    3. Are you seeing this issue with a particular custom component or all of them?

    4. Can you switch to a new workspace, replicate the issue and send us the .log file which is located at <workspace dir>/.metadata/.log ?

Viewing 2 posts - 1 through 2 (of 2 total)

The forum ‘Matisse/Swing UI Development’ is closed to new topics and replies.