Maven Error

This topic contains 1 reply, has 2 voices, and was last updated by  support-swapna 5 months, 1 week ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #606476 Reply

    Hi,

    I tried to create a Maven Project on Eclipse IDE and I am getting the error as ‘Could not resolve archetype org.apache.maven.archetypes:maven-archetype-quickstart:1.1 from any of the configured repositories.

    Please help me in resolving the above issue.

    Thanks,

    Attachments:
    You must be logged in to view attached files.
    #606533 Reply

    support-swapna
    Moderator

    Pavithra,

    It looks a problem with downloading the Maven archetypes.

    1. Are you behind a firewall or proxy? If yes, then you need to create a file called settings.xml in [user home]/.m2 directory and add in the proxy information: http://maven.apache.org/settings.html

    2. You can also try deleting the .m2 directory and restart the IDE. Maven will attempt to download the archetypes again. It will take some time for them to download.

    3. Please also telnet repo.maven.apache.org [port number] to rule out networking issues.

    Can you please clarify if you have installed any of the Genuitec products like Angular IDE, CodeMix etc in Eclipse? If you are working only with Eclipse, then I suggest you cross post to development related forums like stackoverflow.com for further help with Eclipse + Maven.

    Hope this helps. Please let us know if you have any further questions.

    –Swapna
    Genuitec Support

Viewing 2 posts - 1 through 2 (of 2 total)
Reply To: Maven Error

You must be logged in to post in the forum log in