My Eclipse 10 JVM crash

This topic contains 10 replies, has 4 voices, and was last updated by Profile photo of Cedric Jean-Marie Cedric Jean-Marie 3 years, 7 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #324784 Reply

    Recently our infrastructure team had to update our Linux Red Hat OS which is where My Eclipse is installed. Ever since the update the moment I open a project and start navigating the files or working on a file it crashes. The java version before the update was:

    java version “1.6.0_20”
    OpenJDK Runtime Environment (IcedTea6 1.9.10) (rhel-
    OpenJDK Server VM (build 19.0-b09, mixed mode)

    After the upldate I get this:

    java version “1.6.0_22”
    OpenJDK Runtime Environment (IcedTea6 1.10.6) (rhel-
    OpenJDK Server VM (build 20.0-b11, mixed mode)

    When My eclipse crashes the terminal window states the following:

    Architecture: Linux/i386
    Redirecting System.out and System.err to /root/Genuitec/Common/logs/profile-rmb-3344934-console.log
    # An unexpected error has been detected by Java Runtime Environment:
    # SIGSEGV (0xb) at pc=0x06323266, pid=31722, tid=1397619600
    # Java VM: Java HotSpot(TM) Server VM (11.3-b02 mixed mode linux-x86)
    # Problematic frame:
    # V []
    # An error report file with more information is saved as:
    # /root/Genuitec/MyEclipse10/hs_err_pid31722.log
    # If you would like to submit a bug report, please visit:

    I’ve attached the error log as well.

    Any help on this matter would be appreciated, thanks.


    You must be logged in to view attached files.
    #324817 Reply
    Profile photo of support-joy


    Sorry to hear you are running into this issue. I have escalated your post to dev team member, they would get back to you on this.

    I would recommend you repair your ME 10 profile. Open MyEclipse 10 installer file, double click on the same. Next you could choose to repair your MyEclipse profile or create another copy of MyEclipse. Follow the wizard till completion.

    Let me know how this works for you.


    #324819 Reply
    Profile photo of support-tony


    If the repair doesn’t work, try switching MyEclipse to use the Java installed on RedHat (it’s currently using the inbuilt JDK). This can be done by altering your myeclipse.ini file, changing the line under “-vm”. If you’re not sure where the myeclipse.ini file is, this FAQ should help locate it.

    #324824 Reply

    Hi all,

    I’ve tried both the repair and changing the java to the one installed on RH and still it crashes within minutes of being open. If you have any other suggestions please let me know, I’m desperate to get this resolved.

    Thanks for all your help,


    #324848 Reply
    Profile photo of support-tony


    Please you attach the latest hs_err… file, following the Java change. Also, attach or paste the contents of your myeclipse.ini file. There may be some VM parameters that are causing problems.

    Try installing again, as a second installation and see if that new installation works.

    If the problem persists, it’s most likely to be something in the OS update. Unfortunately, I don’t have a RedHat system on which to try to replicate the problem. Are there other Java programs you can run to see if they have the same problem?

    #324872 Reply

    I re-installed before I posted here and still got the same result. This is installed on a development machine where we have tomcat running multiple war files. Each war is a website that is functioning properly. It’s not quite the same as a My Eclipse but it does use Java. Hope that helps.

    Here is the latest file along with my ini contents:

    #ansi (do not remove)
    #ansi (do not remove)

    You must be logged in to view attached files.
    #324913 Reply
    Profile photo of support-tony


    The crash after the Java change is actually in a different place, though it may be related to the previous one. I’ve asked one of the development team to take a look. They should get back to you before too long.

    #324986 Reply
    Profile photo of Brian Fernandes
    Brian Fernandes


    The problem appears to be related to your new OS as opposed to the Java implementation. Could you tell me exactly what Red Hat version you are using right now? Also, what is the GTK and Gnome version used by this version of Red Hat?

    If you go to Window > Preferences > General > Web Browser – what external browsers do you see listed? Could you try switching to any of these other browsers – does that help?

    #324995 Reply

    RH Version:
    Red Hat Enterprise Linux Server release 5.8 (Tikanga)


    Gnome gnome-panel 2.16.1

    I only have Firefox installed so there is no switching and I don’t log onto the dev vm per say. I ssh into it and launch myeclipse remotely through X11 forwarding.

    Thanks again for your help

    #325183 Reply
    Profile photo of Brian Fernandes
    Brian Fernandes


    I’m sorry fo the delayed response – we were unable to reproduce the problem with our local Red Hant installs, but I believe we finally found the problem. It appears to be a conflict with SWT and an XULRunner update that is shipped with the Red Hat update. You would face this problem not only with MyEclipse, but with Classic eclipse too.

    The problem is described here:

    You need to follow the steps in the last comment – as far as starting with a switch pointing to an earlier version of XULRunner is concerned, you will need to edit the myeclipse.ini file and add the


    switch at the bottom of the file.

    I hope this helps.

    #325221 Reply

    Good news, this seems to have worked, it no longer crashes as I modify java files. Thanks for following up on this, much appreciated.

Viewing 11 posts - 1 through 11 (of 11 total)
Reply To: My Eclipse 10 JVM crash

This topic is marked as closed to new replies, however your posting capabilities still allow you to do so.