MyEclipse 2014 and Spring development

This topic contains 1 reply, has 2 voices, and was last updated by  support-swapna 4 years, 4 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #395218 Reply

    gwwilliams22
    Participant

    We have MyEclipse 2014 at work and we would like to start doing Spring Framework development. I am not sure the highest version of Spring 2014 supports. When I try to add Facet to project it only goes up to 3.1. Under plugins directory I see some Spring Framework stuff for 4.0 and 3.3. Can I upgrade 2014 to work with Spring 4.0 or at least 3.2? If so how would I do it, with Plugins? I am in a closed classified system so it is not as easy to get something off the internet, I have to use what is available in our repository.

    #395375 Reply

    support-swapna
    Moderator

    gwwilliams22,

    Spring 3.1 is the highest version of Spring supported by MyEclipse 2014. Our latest version, MyEclipse 2015 supports Spring 4.1.

    If it is possible for you, then I recommend you update to MyEclipse 2015.You can install MyEclipse 2015 alongside your existing MyEclipse 2014 installation and use your current license.

    If you cannot update to MyEclipse 2015 at this point of time, then you can go to project properties > Java Build Path and on the Libraries tab, select and remove the Spring 3.1 containers (or JARs if you had chosen to copy them into your project). You would need to download Spring 4.1 library,create User libraries for the Spring 4.1 JARs and add them to the project’s buildpath (Add Library > User Library) or simply dump them raw on the project’s classpath.

    Let us know if you see any issues.

    –Swapna
    MyEclipse Support

Viewing 2 posts - 1 through 2 (of 2 total)
Reply To: MyEclipse 2014 and Spring development

You must be logged in to post in the forum log in