MyEclipse 8.0 editing of JSP/HTML/JavaScript painfully slow

  1. MyEclipse IDE
  2.  > 
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #306707 Reply

    Scott Dunbar

    Hi all,
    I’ve been doing Java development on MyEclipse for years and it has saved me a great deal of time. Recently I’ve moved into doing significantly more front end work and have been incredibly frustrated with the speed of just editing. Typing or moving around takes at least 100% of one CPU. I’ll click sometimes and just sit and wait for a few seconds (or more) for it to move the cursor.

    I’ve got an i7 (4 core) machine running at 3Ghz with 8G of RAM. MyEclipse is allowed to take 2 G of that and I don’t have much else running on the machine (Ubuntu 9.10, x64). Top currently shows that I have over 2GB free on the machine.

    My only solution has been to use the built in text editor but that isn’t as useful.

    Is this an Eclipse issue or a MyEclipse issue? Again, JSP, HTML, JavaScript are all just dog slow. Java is great, no problems editing it.

    Anybody else?

    #306951 Reply

    Patrick Kates

    Our entire dev team has had this problem starting with 7.5. I was considering upgrading to 8.0 to see if the problem was fixed. I guess it hasn’t been, so I’ll save myself the effort.

    The intial load of the tooling is painfully slow and then switching between JSP editors also takes several seconds. Combine that with the editing bug where your cursor jumps to a new random place while you’re typing, and JSP editing can become a frustrating experience.

    I believe it be a MyEclipse problem – I’ve loaded up a eclipse galileo instance and the initial load is about 5 seconds and switching between JSP editors is instantaneous.

    #307356 Reply

    #311414 Reply


    This is an issue I have been struggling with since at least v 7.1 of MyEclipse. I posted about incredible lag problems when typing JSTL syntax in JSP’s HERE which Joy was able to reproduce given the test project I sent in. Despite Joy saying they were working on a fix for 7.5, I am still getting the same issue in 8.6 which I currently run.

    The first jsp/html/xml file you open at the start of the day takes an age to load up. The xsl editor as a whole is practically useless…it spends half it’s time locked up as it struggles to do something in the background as you work.

    My take on these editor problems is that it is something to do with the formatting and validation engine they use. It obviously runs lots of checks as you type/work to make sure formatting and code colouring is correct etc. In the issues I have linked to above, the nature the lockup was longer or shorter depending on how big the file was and where you made the change in that file. All points to the background validation going on in my view.

    #311500 Reply

    Leo Chavez

    Good to know I’m not the only one with the same issue. DaftMute, you’re absolutely right that it seems to be related to formatting and validation. Since this hasn’t been fixed, you’d figure they would at least give us a way of disabling the formatting and validation. But I’ve checked everywhere and it doesn’t exist.

    As it stands now, my only option is to use textpad on the jsp/html pages and myEclipse for everything else. The issue happens on all my PCs at work and at home so I’m certain this is not an isolated issue.

    How about it guys, can you please provide us with a disable jsp/html/jscript formatting and validation option.

    PCs at Work : i5 750, 4GB RAM, WinXP
    PC at Home : i7 920, 6GB RAM, Win7

    #311539 Reply

    Brian Fernandes

    The formatting is only run when you actually format the code and validation as you type is not too expensive unless you have a really huge file. What can be expensive though is the updating of the Design view – if you don’t have use for that, try editing the file in the source only editor which provides syntax highlighting, content assist.

    To use this, right click the file and use “Open With > MyEclipse JSP Editor” instead of “MyEclipse Visual JSP Designer”. camilos, does this improve your experience?

    Note: This only needs to be done once per file, as it will always reopen using the last known editor. You can also go to Window > Preferences > General > Editors > File Associations and select *.jsp. Then select the MyEclipse JSP Editor and hit the Default button to make this editor the default editor.

    DaftMule, I have flagged your bug for another look in 9.0M2, it was something we looked at earlier but no fix could be found, thanks for the reminder.

    On the first JSP open taking time, that is unfortunately expected as the plugins required are lazily loaded. Subsequent opens should be much faster.

    #311566 Reply

    Tim McLaughlin

    Support-Brian: Thank you! I have been trying to figure out if I could get away from using MyEclipse at all with my projects because of the horrible lag when working with JSP files. I am in and out of them all day and they are large but not THAT big. This has saved me from tearing out my IDE and most of my hair.

    #312087 Reply


    From reading posts throughout this forum, it seems that this problem has been ongoing for over 3 years and has not been resolved. I have been using MyEclipse for over 8 years and it seems that the performance on JSP editing gets worse with every release.

    I am running version 8.6 with the following command line:

    -vmargs -Xmx768M -XX:MaxPermSize=512M -XX:ReservedCodeCache=64M

    Editing even moderately sized files can become painfully slow.

    Support: If there is a plan for a solution out there please let everyone know.

    #312155 Reply



    Have you tried out ME 9.0 M1? This version has a lot of improvements in JSP editing and performance. Can you try out ME 9.0 M1 and give us your feedback.

Viewing 9 posts - 1 through 9 (of 9 total)
Reply To: MyEclipse 8.0 editing of JSP/HTML/JavaScript painfully slow

You must be logged in to post in the forum log in