MyEclipse 9.0 – cannot exclude a resource from validation

  1. MyEclipse Archived
  2.  > 
  3. Bugs
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #315424 Reply

    Scott Dunbar

    Hi all,
    I’m trying out MyEclipse 9.0 and am having a problem with validation. I’m using a JavaScript library that I guess truly does have some errors but I’m not going to fix them as it is a third party library. So I tried to exclude the library from validation. The menu shows that the directory where this library lives is excluded but there is still a red X on the directory and the parent directories. I’m unable to change this. As an aside, when you select “Manage Validation…” I almost always get MyEclipse to “gray out” as if it is hung for about 10 seconds.

    I’m running on Ubuntu 10.10, 1.6.0_24 64 bit JDK both internally (within MyEclipse) and externally (with a modified myeclipse.ini).

    #315480 Reply



    1) Can you please list out steps in detail right from project creation to excluding the java script library for me to replicate it at my end?

    2) Also please attach a screenshot of the issue.

    #315783 Reply

    Scott Dunbar

    Sorry it took a while to get back. My first attempt was a “converted” workspace from MyEclipse 8.6. After waiting nearly an hour for validation to finish (2.66Ghz quad core machine – a giant issue in it’s own right) I right clicked and went to MyEclipse -> Exclude From Validation – except that that was already checked.

    So I just now tried a brand new work space with brand new MyEclipse settings and it does the exact same thing.

    For example, take a look at screenshot 1:

    Here I’m showing that the extjs-3.3.1 directory has an issue. I don’t care about the issue but MyEclipse won’t let me not care:

    It is excluded from validation but it is still being validated:

    I thought, perhaps that it is because this is an error, not a warning. Nope, I have another directory that is excluded from validation but is still showing the warning:

    Sorry, but why is this so hard to reproduce?

    #315806 Reply



    This is a known issue and I have already filed a PR for the dev team.

    You can exclude the resource from the project property page. Right click on project > Properties > MyEclipse > Validation > Excluded Resources.
    Attached is a screen shot for your reference.

    Let me know how this works for you.

    You must be logged in to view attached files.
Viewing 4 posts - 1 through 4 (of 4 total)
Reply To: MyEclipse 9.0 – cannot exclude a resource from validation

You must be logged in to post in the forum log in