MyEclipse 9.0M2 online installer doesn’t work at all

  1. MyEclipse Archived
  2.  > 
  3. Bugs
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #314094 Reply

    Scott Dunbar

    I just downloaded myeclipse-9.0M2-online-installer-linux.run for an Ubuntu 10.10 development environment. On trying to run I get:

    scott@gator:~/Downloads$ ./myeclipse-9.0M2-online-installer-linux.run
    Starting installer – please wait…
    – Preparing install engine
    372+1 records in
    372+1 records out
    – Extracted install engine
    cd: 106: can’t cd to /tmp/oneinstall_13079/myeclipse-9.0M2-online-installer-linux/tools
    Exception in thread “main” java.lang.NoClassDefFoundError: ArchDetect
    Caused by: java.lang.ClassNotFoundException: ArchDetect
    at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
    Could not find the main class: ArchDetect. Program will exit.
    – Detected JVM architecture: bit
    [: 124: =: argument expected
    – Launching install engine; waiting for completion
    – Exited install engine

    My Java is

    scott@gator:~/Downloads$ java -version
    java version “1.6.0_22”
    Java(TM) SE Runtime Environment (build 1.6.0_22-b04)
    Java HotSpot(TM) 64-Bit Server VM (build 17.1-b03, mixed mode)

    #314097 Reply

    Brian Fernandes


    Thanks for the details, I’ll ask our Installer team to take a look at this asap. In the meanwhile, it would appear that there was some sort of permission problem – either the installer was unable to extract into the temp location or for some reason it could not read what was extracted. Does the user you are running the installer as have read / write permissions to the “/tmp” folder?

    If you wish to install MyEclipse 9.0M2 in the meanwhile, you can install it using Pulse Explorer, let me know if you need further instructions.

    Sorry for the inconvenience caused.

    #314115 Reply

    Scott Dunbar

    Not a problem Brian – that is why they are milestones, not GA. I’m very confident that my /tmp has the correct permissions – many other things would be broken if they were incorrect. I did try the “offline” installer and it worked just fine so this is an “online” problem only.

    Edit – and at a guess, the problem is that I’m using a 64 bit JVM. The line from the installer error:

    – Detected JVM architecture: bit
    [: 124: =: argument expected

    seem to indicate that the shell script for installation didn’t parse something correctly.

    #314139 Reply

    Brian Fernandes

    I’m glad the offline installer worked – that too was an important data point.

    We had another look at the online installers and did find a few places where things could potentially go wrong and a few places where error reporting could be improved too. Both improvements will be added to our GA installers, so your feedback has been very helpful.

    If you still have the online installer that you used with you, can you confirm that the MD5 sum of that file is: a0cf50fb9d942360a094c715b7ab0853

Viewing 4 posts - 1 through 4 (of 4 total)
Reply To: MyEclipse 9.0M2 online installer doesn’t work at all

You must be logged in to post in the forum log in