MyEclipse corrupting CVS files?

  1. MyEclipse Archived
  2.  > 
  3. Application Servers and Deployment
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #338392 Reply

    David Askov

    I have a file that I checked out of our CVS using MyEclipse. It is a .htm file that normally has no issues. I think it was generated by MS Word, so there’s some extra complexity in it that Word’s HTML engine spits out, but we have had this file in CVS for many years with no problems. It looks like only these Word-to-HTM files are affected.

    I checked 3 MyEclipse installations that checked this file out, and each contains all kinds of whacky characters in it (it should just be English). Chrome tells me it is in Chinese and offers to translate it! I checked 2 “regular” Eclipse installations, and the file is fine for them.

    I tried checking the file out of CVS again – same result. This file has not changed since July, 2012, and other coworkers can see it ok, so I don’t think there’s anything funny going on in CVS.

    Any ideas? It sure looks like MyEclipse is corrupting my files, but it is only a small subset of what I work with. Unfortunately, this file is on a password-protected part of our website, so I cannot post it here.

    #338406 Reply


    Sorry that you are seeing this issue. I have escalated it to a dev team member, they will get back to you.

    #338431 Reply

    Brian Fernandes

    This certainly is an odd problem. We do not change the CVS functionality, it’s the same as what is supplied in base Eclipse. So perhaps something is happening to the file post checkout.

    1) What version of MyEclipse are you using?

    2) Is the file showing up as “dirty” after checkout? (Make sure you refresh the folder containing the file)

    3) Immediately after checkout, right click the file and open it in the text editor (not the defualt html editors) do you already see the odd characters?

    4) Are all your word-to-html file affected? If you haven’t tried others, can you confirm?

    5) Bring up the file properties of the affected file in the package explorer and check the CVS Node. What is the “Keyword mode” set to?

    6) What sort of project contains the file?
    An option to see if the project type is affecting the file is to select just the folder containing the file in the CVS Repositories view and use the “check out as” option, where you can choose to check out into an existing project (create a dummy java project for this purpose and check out the file into that). Do you still see the problems for this file in this project too?

    #338448 Reply

    David Askov

    1) MyEclipse 10.7.1-20130201

    2) No

    3) Yes

    4) There are 42 of them, so I opened 7 as a good sample size and they were all the same.

    5) In the package explorer, the file properties only shows me the information in the “Resource” tab. I can click on the other entries in the left, but the info doesn’t change in the right page. If I do this from the Navigator, go to CVS, then the Keyword mode is “ASCII with keyword expansion (-kv)”

    6) It is in a “General” type project, with the CVS module checked out under that. I checked it out as a project itself (at the root of the workspace) and got the same result. Using a Java project is the same result.

    FYI: We use TortoiseCVS here. I think we all use it (except one guy on a Mac). I don’t know how to do a command-line checkout, but that might help isolate the Tortoise or MyEclipse software as the issue.

    #338582 Reply

    Brian Fernandes

    ASCII with keyword expansion should be -kkv, but I don’t think that would make a difference.
    If the file was being changed post checkout, it would have shown up dirty (if an external process was changing the file, it would show up dirty if you refresh the folder). So this certainly odd. I suppose comparing the file with the remote version will show you “no changes”? Everything else appears just fine here, cannot think of why this behavior would occur.

    Sanity check: Are you sure you are checking out exactly the same version of the file that your colleagues are checking out? You could be on a different branch, for instance.

    Something to try would be to check out the files/project only using Tortoise on your machine, without involving MyEclipse at all (shut down MyEclipse to remove variables). Now look at this file in an external text editor. Do you see the weird characters now?

    #338903 Reply

    David Askov

    So, we finally got to the bottom of it. Two regular Eclipse users told me their files were ok, so I focused on MyEclipse vs. Eclipse as the culprit.
    — One user, it appears, told me his files were fine without actually looking at them. When he built the WAR file, they were corrupted. When we checked his eclipse, the files were bad.
    — The other regular Eclipse user was on a Mac, and he could view the files just fine. That lad us to explore the differences between Mac and Windows.

    The issue ended up being that the files were in UTF-16 big (or was it little) endian character set. The guy on the Mac could view them fine. He converted them to UTF-8, and life is good.

Viewing 6 posts - 1 through 6 (of 6 total)
Reply To: MyEclipse corrupting CVS files?

You must be logged in to post in the forum log in