MyEclipse Professional stackoverflow building workspace

Tagged: 

This topic contains 9 replies, has 3 voices, and was last updated by  Brian Fernandes 8 months, 1 week ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #578694 Reply

    Scott Esker
    Participant

    I just purchased the professional license this morning, and once I upgraded, I can no longer run MyEclipse because it cannot build the workspace without getting a StackOverflow Exception.

    I have -cleaned, changed the VM ARGS, but I basically cannot use MyEclipse at this point.

    !ENTRY org.eclipse.e4.ui.workbench 2 0 2018-04-05 15:11:02.749
    !MESSAGE Removing part descriptor with the ‘com.genuitec.eclipse.modeling.ui.OverviewView’ id and the ‘JSF Flow Overview’ description. Points to the invalid ‘bundleclass://org.eclipse.ui.workbench/org.eclipse.ui.internal.e4.compatibility.CompatibilityView’ class.

    !ENTRY org.eclipse.m2e.logback.appender 2 0 2018-04-05 15:11:06.052
    !MESSAGE The artifact jstl:jstl:jar:1.1.2 has been relocated to javax.servlet:jstl:jar:1.1.2

    !ENTRY org.eclipse.core.jobs 4 2 2018-04-05 15:11:25.304
    !MESSAGE An internal error occurred during: “Building workspace”.
    !STACK 0
    java.lang.StackOverflowError
    at org.eclipse.jdt.internal.core.JavaModelCache.getInfo(JavaModelCache.java:123)
    at org.eclipse.jdt.internal.core.JavaModelManager.getInfo(JavaModelManager.java:2040)
    at org.eclipse.jdt.internal.core.JavaElement.getElementInfo(JavaElement.java:314)
    at org.eclipse.jdt.internal.core.JavaElement.getElementInfo(JavaElement.java:302)
    at org.eclipse.jdt.internal.core.JavaElement.getChildren(JavaElement.java:257)
    at org.eclipse.jdt.internal.core.JavaElement.getChildrenOfType(JavaElement.java:271)
    at org.eclipse.jdt.internal.core.JavaModel.getJavaProjects(JavaModel.java:195)
    at com.genuitec.eclipse.core.util.JavaMetaUtils.getJavaProject(JavaMetaUtils.java:133)
    at com.genuitec.eclipse.core.util.JavaMetaUtils.getJavaProject(JavaMetaUtils.java:118)
    at com.genuitec.eclipse.core.util.Util.getJavaProject(Util.java:108)
    at com.genuitec.eclipse.hibernate.util.HTUtils.getClassPaths(HTUtils.java:300)
    at com.genuitec.eclipse.hibernate.util.HTUtils.getClassPaths(HTUtils.java:325)
    at com.genuitec.eclipse.hibernate.util.HTUtils.getClassPaths(HTUtils.java:325)
    at com.genuitec.eclipse.hibernate.util.HTUtils.getClassPaths(HTUtils.java:325)
    at com.genuitec.eclipse.hibernate.util.HTUtils.getClassPaths(HTUtils.java:325)
    at com.genuitec.eclipse.hibernate.util.HTUtils.getClassPaths(HTUtils.java:325)
    at com.genuitec.eclipse.hibernate.util.HTUtils.getClassPaths(HTUtils.java:325)
    at com.genuitec.eclipse.hibernate.util.HTUtils.getClassPaths(HTUtils.java:325)

    Attachments:
    You must be logged in to view attached files.
    #579280 Reply

    Scott Esker
    Participant

    *** Date:
    Monday, April 9, 2018 7:15:05 AM CDT

    *** System properties:
    OS=MacOSX
    OS version=10.13.3
    OS arch=x86_64
    Profile arch=x86_64
    Window system=cocoa
    Java version=1.8.0_112
    Workspace=file:/Users/sesker/Development/Workspaces/MyEclipse/Enterprise/
    VM Args=-Xms256m
    -Xmx1024m
    -XX:+UseG1GC
    -XX:+UseStringDeduplication
    -Dosgi.requiredJavaVersion=1.8
    -Dosgi.nls.warnings=ignore
    -Dorg.eclipse.swt.internal.carbon.smallFonts
    -Xdock:icon=../Resources/myeclipse.icns
    -XstartOnFirstThread
    -Djava.class.path=/Applications/MyEclipse 2017 CI/MyEclipse 2017 CI.app/Contents/MacOS//../Profile/plugins/org.eclipse.equinox.launcher_1.3.200.v20160318-1642.jar

    *** Subscription information
    Product Id: E3MS (MyEclipse for Spring Subscription)
    License version: 3.0
    Full Maintenance Included
    Subscription expiration date (YYYYMMDD): 20190405
    Number of users: 1

    *** Eclipse details:
    MyEclipse Enterprise Workbench

    Version: 2017 CI 10
    Build id: 15.0.1-20171220

    com.genuitec.myeclipse.database – 14.0.0.me201712200858
    com.genuitec.myeclipse.db2 – 14.0.0.me201712200858
    com.genuitec.myeclipse.desktop – 14.0.0.me201712200858
    com.genuitec.myeclipse.enterprise.workbench – 14.0.0.me201712200858
    com.genuitec.myeclipse.icefaces.feature – 14.0.0.me201712200858
    com.genuitec.myeclipse.jsf – 14.0.0.me201712200858
    com.genuitec.myeclipse.maven – 14.0.0.me201712200858
    com.genuitec.myeclipse.persistence – 14.0.0.me201712200858
    com.genuitec.myeclipse.reports – 14.0.0.me201712200858
    com.genuitec.myeclipse.struts – 14.0.0.me201712200858
    com.genuitec.myeclipse.uml2 – 14.0.0.me201712200858
    com.genuitec.myeclipse.visualvm – 14.0.0.me201712200858
    com.genuitec.myeclipse.ws – 14.0.0.me201712200858
    com.skyway.myeclipseforspring.feature – 14.0.0.me201712200858
    org.eclipse.birt – 4.6.0.me201712200858
    org.eclipse.datatools.connectivity.feature – 1.13.0.me201712200858
    org.eclipse.datatools.enablement.feature – 1.13.0.me201712200858
    org.eclipse.datatools.modelbase.feature – 1.13.0.201603142002
    org.eclipse.datatools.sqldevtools.feature – 1.13.0.me201712200858
    org.eclipse.emf – 2.12.0.v20160526-0356
    org.eclipse.gef – 3.11.0.201606061308
    org.eclipse.graphiti.feature – 0.13.1.v20160830-1309
    org.eclipse.jpt.jpa.feature – 3.5.0.me201712200858
    org.eclipse.jpt.jpadiagrameditor.feature – 1.2.300.me201712200858
    org.eclipse.jst.common.fproj.enablement.jdt – 3.8.0.me201712200858
    org.eclipse.jst.enterprise_ui.feature – 3.8.0.me201712200858
    org.eclipse.jst.server_adapters.ext.feature – 3.3.501.me201712200858
    org.eclipse.jst.server_adapters.feature – 3.2.400.me201712200858
    org.eclipse.jst.server_ui.feature – 3.4.300.me201712200858
    org.eclipse.jst.ws.axis2tools.feature – 1.1.301.me201712200858
    org.eclipse.m2e.feature – 1.7.0.me201712200858
    org.eclipse.sapphire.platform – 9.1.0.201609301330
    org.eclipse.wst.common.fproj – 3.7.0.me201712200858
    org.eclipse.wst.server_adapters.feature – 3.2.500.me201712200858
    org.eclipse.xsd – 2.12.0.v20160526-0356
    org.springframework.ide.eclipse.feature – 3.8.2.me201712200858

    angularjs-eclipse-feature – 1.2.0.me201712200858
    angularjs-eclipse-jsp-feature – 1.2.0.me201712200858
    angularjs-eclipse-php-feature – 1.2.0.me201712200858
    com.eclipsesource.j2v8.feature – 4.0.0.201704121300
    com.github.eclipsecolortheme.feature – 1.0.0.me201712200858
    com.vmware.vfabric.ide.eclipse.tcserver – 3.8.2.me201712200858
    com.vmware.vfabric.ide.eclipse.tcserver.insight – 3.8.2.me201712200858
    fr.obeo.acceleo.bridge.feature – 2.6.0.me201712200858
    io.emmet.eclipse – 14.0.0.me201712200858
    net.jeeeyul.pdetools.feature – 1.2.6.me201712200858
    net.jeeeyul.swtend.feature – 2.2.5.me201712200858
    org.chromium.debug – 0.3.9.201712201137
    org.chromium.sdk – 0.3.9.201712201137
    org.chromium.sdk.wipbackends – 0.1.11.201712201137
    org.dadacoalition.yedit.feature – 1.0.18.201712201146
    org.eclipse.buildship – 2.1.2.v20170807-1324
    org.eclipse.cdt.native – 9.2.2.201709072038
    org.eclipse.cvs – 1.4.300.v20160907-1200
    org.eclipse.draw2d – 3.10.100.201606061308
    org.eclipse.e4.rcp – 1.5.1.v20160907-0248
    org.eclipse.ecf.core.feature – 1.3.0.v20160823-2221
    org.eclipse.ecf.core.ssl.feature – 1.1.0.v20160823-2221
    org.eclipse.ecf.filetransfer.feature – 3.13.2.v20160823-2221
    org.eclipse.ecf.filetransfer.httpclient4.feature – 3.13.2.v20160823-2221
    org.eclipse.ecf.filetransfer.httpclient4.ssl.feature – 1.1.0.v20160823-2221
    org.eclipse.ecf.filetransfer.ssl.feature – 1.1.0.v20160823-2221
    org.eclipse.egit – 4.5.0.201609210915-r
    org.eclipse.epp.mpc – 1.5.2.v20161005-1414
    org.eclipse.equinox.p2.core.feature – 1.3.200.v20160815-1406
    org.eclipse.equinox.p2.discovery.feature – 1.0.401.v20160901-1335
    org.eclipse.equinox.p2.extras.feature – 1.2.200.v20160815-1406
    org.eclipse.equinox.p2.rcp.feature – 1.2.200.v20160815-1406
    org.eclipse.equinox.p2.user.ui – 2.2.200.v20160815-1406
    org.eclipse.help – 2.2.0.v20160907-1200
    org.eclipse.jdt – 3.12.1.v20160907-1200
    org.eclipse.jet – 1.1.1.v201101271243-5319sC7HCAGERASDK3924
    org.eclipse.jet.uml2 – 1.1.0.v201006011447-2-07w311A1A152813
    org.eclipse.jgit – 4.5.0.201609210915-r
    org.eclipse.jsf.feature – 3.9.0.me201712200858
    org.eclipse.mylyn.bugzilla_feature – 3.21.0.v20160909-1813
    org.eclipse.mylyn.commons – 3.21.0.v20160707-1856
    org.eclipse.mylyn.commons.identity – 1.13.0.v20160630-1702
    org.eclipse.mylyn.commons.notifications – 1.13.0.v20160721-2347
    org.eclipse.mylyn.commons.repositories – 1.13.0.v20160630-1702
    org.eclipse.mylyn.context_feature – 3.21.0.v20160815-2336
    org.eclipse.mylyn.cvs – 1.13.0.v20160630-2022
    org.eclipse.mylyn.discovery – 3.21.0.v20160729-1739
    org.eclipse.mylyn.gerrit.feature – 2.12.0.v20160719-2354
    org.eclipse.mylyn.git – 1.13.0.v20160630-2022
    org.eclipse.mylyn.ide_feature – 3.21.0.v20160912-1820
    org.eclipse.mylyn.java_feature – 3.21.0.v20160701-1337
    org.eclipse.mylyn.monitor – 3.21.0.v20160630-1702
    org.eclipse.mylyn.reviews.feature – 2.12.0.v20160819-2206
    org.eclipse.mylyn.tasks.ide – 3.21.0.v20160929-1805
    org.eclipse.mylyn.team_feature – 3.21.0.v20160701-1337
    org.eclipse.mylyn.versions – 1.13.0.v20160630-2022
    org.eclipse.mylyn_feature – 3.21.0.v20160914-0252
    org.eclipse.ocl – 3.1.0.v20110606-1427
    org.eclipse.pde – 3.12.1.v20160907-1200
    org.eclipse.platform – 4.6.1.v20160907-1200
    org.eclipse.rcp – 4.6.1.v20160907-1200
    org.eclipse.tm.terminal.connector.local.feature – 4.1.0.201606052351
    org.eclipse.tm.terminal.control.feature – 4.1.0.201606052351
    org.eclipse.tm.terminal.view.feature – 4.1.0.me201712200858
    org.eclipse.wb.core.feature – 1.9.0
    org.eclipse.wb.core.java.feature – 1.9.0
    org.eclipse.wb.core.ui.feature – 1.9.0
    org.eclipse.wb.core.xml.feature – 1.9.0
    org.eclipse.wb.doc.user.feature – 1.9.0
    org.eclipse.wb.layout.group.feature – 1.9.0
    org.eclipse.wb.rcp.SWT_AWT_support – 1.9.0
    org.eclipse.wb.rcp.doc.user.feature – 1.9.0
    org.eclipse.wb.rcp.feature – 1.9.0
    org.eclipse.wb.swing.doc.user.feature – 1.9.0
    org.eclipse.wb.swing.feature – 1.9.0
    org.eclipse.wb.swt.feature – 1.9.0
    org.eclipse.wb.xwt.feature – 1.9.0
    org.sonatype.m2e.mavenarchiver.feature – 0.17.2.201606141937-signed-20160830073346
    org.springsource.ide.eclipse.commons – 3.8.2.me201712200858
    tern-feature – 1.2.0.201712201139
    tern-jsdt-feature – 1.2.0.201712201139
    tern-linters-feature – 1.2.0.201712201139
    tern-server-nodejs-feature – 1.2.0.201712201139
    tern.eclipse.ide.server.nodejs.embed – 1.2.0.201712201139

    Eclipse startup command=-os
    macosx
    -ws
    cocoa
    -arch
    x86_64
    -showsplash
    -launcher
    /Applications/MyEclipse 2017 CI/MyEclipse 2017 CI.app/Contents/MacOS/myeclipse
    -name
    Myeclipse
    –launcher.library
    /Applications/MyEclipse 2017 CI/MyEclipse 2017 CI.app/Contents/MacOS//../Profile/plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.400.v20160518-1444/eclipse_1615.so
    -startup
    /Applications/MyEclipse 2017 CI/MyEclipse 2017 CI.app/Contents/MacOS//../Profile/plugins/org.eclipse.equinox.launcher_1.3.200.v20160318-1642.jar
    –launcher.overrideVmargs
    -clean
    -configuration
    /Applications/MyEclipse 2017 CI/MyEclipse 2017 CI.app/Contents/Profile/configuration
    -install
    /Applications/MyEclipse 2017 CI/MyEclipse 2017 CI.app/Contents/Profile
    -keyring
    /Users/sesker/.eclipse_keyring
    -vm
    /Applications/MyEclipse 2017 CI/MyEclipse 2017 CI.app/Contents/Profile/binary/com.sun.java.jdk8.macosx.x86_64_1.8.0.v112/jre/lib/jli/libjli.dylib

    #579282 Reply

    Scott Esker
    Participant

    …and the stack trace just continues throw the same error over and over..

    #579288 Reply

    support-swapna
    Moderator

    Scott,

    Firstly, apologies for missing out your previous post. Sorry that you are seeing this problem.

    Can you please give us some more details for further investigation ?

    1. Do you work with hibernate tools in any of the projects in the workspace?
    2. Can you please recheck if Hibernate support is installed in the IDE from the Help > Choose Components dialog? If the ‘Hibernate/JPA Support for MyEclipse’ under Persistence category is not in the Selected list, then add it to the Selected box, ‘Apply changes’ and restart the IDE when it prompts.
    3. If you are still seeing the issue, then please send us the complete log file by clicking on the ‘Export Log’ icon in the Error Log view. Also share with us more details about the projects that are in the workspace.
    4. Can you please also let us know which license you worked with before and what has changed in the IDE apart from the new license activation which resulted in this problem?

    Apologies for inconvenience caused.

    –Swapna
    MyEclipse Support

    #579300 Reply

    Scott Esker
    Participant

    Yes — it is still happening..

    We do in fact have hibernate in our projects, but I have not worked with the tools yet. Hibernate JPA Support is installed.

    I started with the demo license, then bought a professional license and installed it.

    My Projects are all multi-maven projects (with children) that use Spring/Hibernate and various other tools running in spring boot.

    The error occurs when I have several projects in the workspace.

    Error log attached..

    Attachments:
    You must be logged in to view attached files.
    #579371 Reply

    Brian Fernandes
    Moderator

    Scott,

    I suspect there is a problem with how your Maven settings (in pom.xml) are being converted into Eclipse/JDT classpath settings. Some Maven configuration is resulting in a circular reference, which is causing Eclipse to trip.

    Now we’re unsure if this is one project which has this sort of issue or several, but it would be good to isolate at least one project which we know is problematic, so we can figure this out.

    Would it be possible for you to close projects in your workspace until the problem stops appearing, then reopen a few to find at least one that is causing the problem?

    If you are able to isolate the project, can you send us the
    .project, pom.xml, .classpath files and all files in the .settings folder?

    #579378 Reply

    Scott Esker
    Participant

    Yes — I will get you that info, and yes I noticed the circular dependencies when I first imported in the projects. I am beginning to think it is from the circular dependencies, if I open all the projects that don’t have them it seems to be functioning.

    #579380 Reply

    Brian Fernandes
    Moderator

    Scott,

    Do you mean you are aware of circular dependencies between projects? If so, yes – that’s definitely going to cause issues within the tooling.

    #579383 Reply

    Scott Esker
    Participant

    No, I am new to the project, so this is the first time I imported, the problem is the stackoverflow issue shuts it down before I can start trying to solve anything. Let me keep testing, and I will update you shortly.

    Thanks,
    Scott

    #579384 Reply

    Brian Fernandes
    Moderator

    Ah, clear. If you haven’t done so already, you can try turning off the “Build Automatically” setting at Project > Build Automatically. That might alleviate some of the issues while you research further.

Viewing 10 posts - 1 through 10 (of 10 total)
Reply To: MyEclipse Professional stackoverflow building workspace

This topic is marked as closed to new replies, however your posting capabilities still allow you to do so.