facebook

MyEclipse won’t stop flashing a progress message

  1. MyEclipse IDE
  2.  > 
  3. Installation, Configuration & Updates
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #680271 Reply

    asmh
    Participant

    See attached image. It just flashes that non-stop, and it’s VERY VERY annoying!!

    Version: 2022.1.0
    Build id: 169.0.0-20220324

    It started when I upgraded to this version.

    Attachments:
    You must be logged in to view attached files.
    #680278 Reply

    Brian Fernandes
    Moderator

    Sorry about that – I can understand how annoying that flash can be! Could you let us know what additional plugins you have installed? The message says, “Refreshing Results View” – we tried installing SonarLint (which we could see in your GIF), but couldn’t find a Results view in it.

    Additionally, does the message start to appear as soon you start MyEclipse, every session? Or does it only start after some activity – like running a set of tests for instance?

    As a test, can you try switching to an empty workspace to see if that fixes the issue? This will tell us if the problem is specific to projects in your workspace.

    Again, sorry about this, we hope your details help us figure it out. Thanks!

    #680292 Reply

    asmh
    Participant
    
      Ansi Console	1.4.6.202112080311	net.mihai-nita.ansicon.feature.group	Mihai Nita
      Desktop Utilities for MyEclipse	16.0.0.c0000065t202203231757	component.2915-Enr-0574.myeclipse_desktop_module.macosx.cocoa.x86_64	null
      Hibernate / JPA Support for MyEclipse	16.0.0.c0000065t202203231757	component.2915-Enr-0574.myeclipse_persistence_module.macosx.cocoa.x86_64	null
      Maven Support for MyEclipse (Enhanced m2e)	16.0.0.c0000065t202203231757	component.2915-Enr-0574.myeclipse_maven_module.macosx.cocoa.x86_64	null
      MyEclipse	16.0.0.c0000065t202203231757	package.2915-Enr-0574.macosx.cocoa.x86_64	null
      MyEclipse Database Tools	16.0.0.c0000065t202203231757	component.2915-Enr-0574.myeclipse_database_module.macosx.cocoa.x86_64	null
      MyEclipse DB2 Database Support	16.0.0.c0000065t202203231757	component.2915-Enr-0574.myeclipse_db2_module.macosx.cocoa.x86_64	null
      MyEclipse for Spring	16.0.0.c0000065t202203231757	component.2915-Enr-0574.myeclipse_me4s_module.macosx.cocoa.x86_64	null
      MyEclipse Legacy Features	16.0.0.c0000065t202203231757	component.2915-Enr-0574.myeclipse_icefaces_feature_module.macosx.cocoa.x86_64	null
      MyEclipse Reports	16.0.0.c0000065t202203231757	component.2915-Enr-0574.myeclipse_reports_module.macosx.cocoa.x86_64	null
      MyEclipse UML 1 / 2 Visual Design Tools	16.0.0.c0000065t202203231757	component.2915-Enr-0574.myeclipse_uml_module.macosx.cocoa.x86_64	null
      MyEclipse VisualVM Profiler	16.0.0.c0000065t202203231757	component.2915-Enr-0574.myeclipse_visualvm_module.macosx.cocoa.x86_64	null
      SonarLint for Eclipse	7.3.1.45470	org.sonarlint.eclipse.feature.feature.group	SonarSource
      Spring Boot Language Server Feature	4.6.0.202003180840	org.springframework.tooling.boot.ls.feature.feature.group	Pivotal, Inc.
      Spring Support for MyEclipse	16.0.0.c0000065t202203231757	component.2915-Enr-0574.myeclipse_spring_module.macosx.cocoa.x86_64	null
      Swing Designer for MyEclipse	16.0.0.c0000065t202203231757	component.2915-Enr-0574.myeclipse_swing_designer_module.macosx.cocoa.x86_64	null
      SWT Designer for MyEclipse	16.0.0.c0000065t202203231757	component.2915-Enr-0574.myeclipse_swt_designer_module.macosx.cocoa.x86_64	null
      Terminal Support for MyEclipse	16.0.0.c0000065t202203231757	component.2915-Enr-0574.myeclipse_terminal_module.macosx.cocoa.x86_64	null
      Veracode Greenlight	2.9.4.202201131747	com.veracode.morpheus.feature.feature.group	Veracode
      Web Services Support for MyEclipse	16.0.0.c0000065t202203231757	component.2915-Enr-0574.myeclipse_ws_module.macosx.cocoa.x86_64	null
    

    It starts flashing as soon as I launch MyEclipse. I tried a blank workspace and it did not happen right away, but after it sat for a short time it started blinking.

    • This reply was modified 1 month, 3 weeks ago by asmh. Reason: uninstalled stuff - but it's still flashing
    • This reply was modified 1 month, 3 weeks ago by asmh.
    #680353 Reply

    Brian Fernandes
    Moderator

    Thank you for sharing those details – we were able to track this problem down to the Veracode Greenlight plugin. When we installed Greenlight and tried to activate its Results view, we were able to see the refresh issue ourselves.

    The problem appears to be an incompatibility between Greenlight and Eclipse 2021-12 (and later versions, possibly) on which this version of MyEclipse is based. If you look at their marketplace entry ( https://marketplace.eclipse.org/content/veracode-greenlight ) you will notice a similar report from a user who is using this plugin with STS. I’m afraid there’s not much we can do to fix this, and the fix will have to be made by the Greenlight plugin developers. Perhaps you could open a bug / issue on their side so they release an update to the plugin?

    One option would be to keep the Progress view closed (it will not pop up again) – the user comments that the jobs keep queuing up, but if they don’t in your case, hopefully it won’t result in a performance impact. Another option is to close the Results view and then restart MyEclipse – the problem should not occur until you activate the view. I hope these tips help, sorry we cannot provide further assistance on this issue.

    #680382 Reply

    asmh
    Participant

    Thank you!

    Closing the view would not help since it also flashes on the progress bar at the bottom. And it did pile up for me and cause a slowdown – I chose to uninstall it instead.

    However it left a menu behind – how do I get rid of it?

    • This reply was modified 1 month, 2 weeks ago by asmh.
    Attachments:
    You must be logged in to view attached files.
    #680391 Reply

    Brian Fernandes
    Moderator

    Does the menu still work / can it be activated? If so, it would mean the plugin isn’t completely uninstalled.

    If the plugin did get completely uninstalled, you can try either of the following:

    Window > Perspective > Reset Perspective (or switch to another perspective).
    If that doesn’t work, try Window > New Window – you’ll get another Eclipse window, hopefully without the menu, and you can close the first one.

    Hope this fixes it!

    #680394 Reply

    support-swapna
    Moderator

    Hi,

    On further testing, we found that only switching to a fresh new workspace helps get rid of that menu.
    Please switch to a new workspace and import your existing projects to continue working.

    –Swapna
    Genuitec Support

    #680415 Reply

    asmh
    Participant

    Thanks for trying. I’ll just ignore the menu – switching to a workspace and importing everything is too much trouble.

    #680418 Reply

    support-swapna
    Moderator

    Hi,

    You can chose to hide the menu in the current workspace. Go to Window > Perspective > Customize Perspective > Menu Visibility tab and uncheck the VeraCode Greenlight entry. Apply the changes and the menu should no longer be visible. Attached is the screenshot for your reference.

    Hope this helps.

    –Swapna
    Genuitec Support

    Attachments:
    You must be logged in to view attached files.
Viewing 9 posts - 1 through 9 (of 9 total)
Reply To: MyEclipse won’t stop flashing a progress message

You must be logged in to post in the forum log in