No SASS Support

  1. CodeMix & Angular IDE
  2.  > 
  3. Getting Help
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #610573 Reply


    Codemix is unable to render SASS. It handles SCSS totally fine though. The difference between the two is SCSS has all the syntax and SASS has none of the syntax and uses indentation.

    I have a VueJS project with each .vue file containing SASS, CoffeeScript, and Pug. Then my project is all indent style and looks quite nice.

    The coffee and pug syntax highlighting works awesome, then the SASS is just grey all the time. VSCode surprisingly does not support SASS out of the box and therefore my SASS is all grey there too. So I simply installed the SASS plugin from the market (https://marketplace.visualstudio.com/items?itemName=robinbentley.sass-indented) which made it all work in VSCode but not Codemix. Then I try to install it in codemix with install from vsix file and I get an error it is not compatible with the version of vscode codemix ships with.

    Please add the SASS plugin to the list of installable plugins in Codemix


    Alternatively fix the issue with the install from vsix file which has never worked on any plugin for me ever.

    #610635 Reply



    Sorry that you are seeing problems with SASS support in CodeMix. I see the compatibility issue with the extension in CodeMix at my end as well and I have asked the dev team to look into it. They will get back to you soon.

    Can you please elaborate what issues you are seeing when using the ‘Install from vsix file’ for other plugins? I ran few quick tests and it works fine for other extensions at my end. If you are trying to install any specific extensions, then please list them to help us investigate further.

    Apologies for inconvenience caused.

    Genuitec Support

    #610900 Reply


    The other plugin I really wanted to install was the rest clinet plugin coming from here: https://marketplace.visualstudio.com/items?itemName=humao.rest-client Thing is I requested that codemix support *.http files through the rest-client plugin and Codemix devs responded and gave what I wanted. Then a few weeks later there was a major update to codemix and now the support for *.http files is no longer supported. So it tried to install the plugin with vsix file and got an error saying the codmeix vscode is not supported for the plugin. Here is my original issue: https://www.genuitec.com/forums/topic/rest-client-plugin-support/

    Lastly the PlantUML plugin gets the same error the codmeix vscode is out of date. Here it is: https://marketplace.visualstudio.com/items?itemName=jebbs.plantuml

    #610902 Reply


    So my plantuml started working in Codemix all of a sudden, no probelms there anymore. May be an issue between my home vs work computer . . . ? All plantuml files light up like christmas now 😀

Viewing 4 posts - 1 through 4 (of 4 total)
Reply To: No SASS Support

You must be logged in to post in the forum log in