onclick="return false;" is marked as an error.

Home Forums MyEclipse IDE Installation, Configuration & Updates onclick="return false;" is marked as an error.

This topic contains 7 replies, has 3 voices, and was last updated by Profile photo of support-swapna support-swapna 3 years, 1 month ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #321314

    Hello.
    I did recently upgrade to MyEclipse 10.0, but now the IDE report me a problem with the parameter onclick=”return false;” in some icefaces components, the menu bar by example. the IDE say me “Cannot return from outside a function or method”.

    My application work well, but why mark the parameter as an error MyEclipse?

    I am working on Fedora 15.

    Thanks in advance.

    #321326
    Profile photo of support-swapna
    support-swapna
    Moderator

    afplmex ,

    I am afraid this is an Eclipse issue that you are seeing.
    There is a bug already filed for it .Take a look at this link :
    https://bugs.eclipse.org/bugs/show_bug.cgi?id=353209

    #326156
    Profile photo of EricLam
    EricLam
    Member

    Hi Swapna,

    We are currently upgrading our projects from MyEclipse Blue v8.6 to v10. We are also encountered such problem.

    Do you have any plan for solving this problem?

    Any workaround solution could be provided?

    Thanks in advance.

    Eric Lam

    #326158
    Profile photo of support-swapna
    support-swapna
    Moderator

    EricLam ,

    As mentioned in my previous reply, its an Eclipse bug.I have raised a PR for the dev team to check if it can be fixed in MyEclipse. I am afraid I cannot suggest any workaround for it.

    Sorry for inconvenience caused.

    #326161
    Profile photo of EricLam
    EricLam
    Member

    Hi Swapan,

    Thank you for your reply and we are appreciated you have raised a PR to dev team. We understand it is an Eclipse bug and your dev team will work hard to fix this issue.

    We love your product and it is a best alterative of RAD. Honestly, this issue gives us a bad impression on MyEcipse Blue V10. Our developer is suffering and put extra work to distinguish whether the error message is valid or not.

    We are appreciated if this issue could be put higher priority and it could be solved by coming release or even an interim fix.

    Thank you very much!
    Eric Lam

    #326174

    Hi.
    The issue is already solved, I updated my workbench and the warnings are gone.
    Greetings.

    #326212
    Profile photo of EricLam
    EricLam
    Member

    The problem has been solved after we upgraded the MyEclipse Blue from V10 to V10.1.
    Thank you for your help!

    Cheers!
    Eric Lam

    #326215
    Profile photo of support-swapna
    support-swapna
    Moderator

    EricLam,

    Glad that it is working.
    Do let us know if you see any issues.

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘onclick="return false;" is marked as an error.’ is closed to new replies.