org.hibernate.PropertyNotFoundException:

Home Forums Archived Forums MyEclipse Archived Database Tools (DB Explorer, Hibernate, etc.) org.hibernate.PropertyNotFoundException:

This topic contains 2 replies, has 3 voices, and was last updated by Profile photo of bartolomeo.romano bartolomeo.romano 7 years, 8 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #270595

    We are mapping a table to Hibernate POJO class and MyEclipse generated us ???.hbm.xml mapping fileas well as Java bean with setters and getters. While trying it load POJO class Hibernate throws the following exception :

    Exception in LoginDAO.getDetails : org.hibernate.PropertyNotFoundException: Could not find a getter
    for ordersSeqid in class xxx.hibernate.POJO.UsersOrders
    org.hibernate.PropertyNotFoundException: Could not find a getter for ordersSeqid in class xxx.UsersOrders

    I searched this site before and tried to change setter and getter methods with lower case “getordersSeqid” instead of “getOrdersSeqid”, however it didn’t help.

    We are using Hibernate 3.0 and WebLogic9.0 as an app server.

    #270630
    Profile photo of Riyad Kalla
    Riyad Kalla
    Member

    The correct case would be “getOrdersSeqid” as you had it, that will generate:
    1) Pull off the “get”
    2) Lowercase the first letter
    3) You get “ordersSeqid”

    Can you re-gen the table, to make sure none of your customizations are in there, and then post the getter and setter from the POJO here, also the HBM.xml file contents?

    #278784

    I’ve got a very strange problem as the same code on two different computers work sdifferently.
    On one it works properly on the other I get this error……

Viewing 3 posts - 1 through 3 (of 3 total)

The forum ‘Database Tools (DB Explorer, Hibernate, etc.)’ is closed to new topics and replies.