Problem with JPA Editor – Myeclipse for Spring 10.5.0 – OSX

  1. MyEclipse Archived
  2.  > 
  3. Database Tools (DB Explorer, Hibernate, etc.)
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #327796 Reply

    Marko Baricevic


    I am getting this stack trace after I tried to “Open JPA diagram” in WebProject (with enabled JPA cap)

    !ENTRY org.eclipse.core.filesystem 4 272 2012-07-02 20:06:45.206
    !MESSAGE Could not write file: /ACore/diagrams/ACore.xml.

    !ENTRY org.eclipse.ui 4 0 2012-07-02 20:06:45.206
    !MESSAGE Unhandled event loop exception
    !STACK 0
    org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NullPointerException)
    at org.eclipse.swt.SWT.error(SWT.java:4282)
    at org.eclipse.swt.SWT.error(SWT.java:4197)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:138)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3938)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3615)
    at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
    at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
    at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
    at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
    at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
    Caused by: java.lang.NullPointerException
    at org.eclipse.jpt.jpadiagrameditor.ui.internal.modelintegration.ui.OpenJpaDiagramActionDelegate.openDiagramEditor(OpenJpaDiagramActionDelegate.java:106)
    at org.eclipse.jpt.jpadiagrameditor.ui.internal.modelintegration.ui.OpenJpaDiagramActionDelegate$OpenEditorRunnable.run(OpenJpaDiagramActionDelegate.java:87)
    at org.eclipse.ui.internal.UILockListener.doPendingWork(UILockListener.java:164)
    at org.eclipse.ui.internal.UISynchronizer$3.run(UISynchronizer.java:158)
    at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
    … 22 more

    Please help.

    #327822 Reply



    Sorry you’re seeing this problem. I’ve managed to reproduce it and have filed a bug for it.

    The incorrect behavior may give you a way to work around the bug. In Windows, this problem probably isn’t seen, because the feature is trying to create a folder at the location seen in the error (in your case, “/ACore/diagrams/ACore.xml”), as well as an xml file in the project, and in Windows, users can create folders/files in the root of the file system. In order to avoid seeing the issue on Mac OS X (or Linux), you could create a folder, ACore, at the root of the file system and ensure it is owned by you, the user. You will need to do this as root (or equivalent). After that, you should be able to open the JPA diagram.

    Obviously, the folder “/ACore/diagrams/ACore.xml” should not be being created, so this will be looked at in the fix, but this may be a workaround for you.

    Please let us know if this works for you.

    #327824 Reply

    Marko Baricevic

    Hi Tony,

    yes, its working now, thanks.

    I hope this will be solved soon.

    Regards, analyticom

    #327829 Reply



    Thanks for getting back to us and I’m glad you have a workaround. I’ll try to remember to post here when we have a proper fix.

    #330037 Reply

    Brian Fernandes


    This issue was tracked and fixed in the 10.6 release which is available now. 10.6 can be installed via a small update from the MyEclipse Configuration Center or you could download a new installer instead. If you still experience the same problem with 10.6, please let us know.

    Thank you for your support and reporting the problem.

Viewing 5 posts - 1 through 5 (of 5 total)
Reply To: Problem with JPA Editor – Myeclipse for Spring 10.5.0 – OSX

You must be logged in to post in the forum log in