Problem with '[‘ Key on macOs in JavaScript Editor – Waring about unsend snippet

  1. MyEclipse IDE > Off Topic

This topic contains 5 replies, has 3 voices, and was last updated by  support-tony 2 years, 11 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #543857 Reply

    hluebeck
    Participant

    Hello, if i press ‘[‘ in the Javascript Editor there is a Warning about an “unsend snippet” (see attached screenshot).

    happens with:
    MyEclipse Enterprise Workbench
    Version: 2017 CI 8
    Build id: 15.0.1-20170912

    on macOS

    Attachments:
    You must be logged in to view attached files.
    #543863 Reply

    support-swapna
    Moderator

    hluebeck,

    Thank you for the screenshot. The warning is related to sharing text via Slack. If you are invoking the ‘Share to Slack’ from the editor without selecting any text, then you will be warned about the empty snippets.

    Can you please clarify if you have changed the key combination for ‘Share to Slack’ knowingly or unknowingly? Right click in the JavaScript Editor and in the context menu check the command for ‘Share to Slack’. You can edit the key combination from Window > Preferences > General > Keys. The default key combination is Option key +5 on Mac.

    Please recheck and let us know how it works for you.

    –Swapna
    MyEclipse Support

    #543866 Reply

    hluebeck
    Participant

    Yes that was the Problem. On a Mac Option(Alt) key + 5 = ‘[‘. I have changed the Slack Sharing to Shift + Option + 5 and the ‘[‘ work very well.

    Thanks a lot

    #543989 Reply

    support-tony
    Keymaster

    hluebeck,

    I’ve checked on a Mac with OS X High Sierra and find that the Option-5 key combination produces the infinity symbol (“∞”). There seems to be no way to change this, so I’m confused about your last reply. Do you have a special keyboard, where the Option key mappings are different?

    You can look at the various keyboard mappings by checking the “Show Input menu on menu bar” option in the Input Sources tab of the Keyboard preferences (in System Preferences), then click the Input Menu icon on the right hand side of the Mac’s menu bar. In the keyboard that’s shown, you can click an Option key and see what characters each key produces with the Option key held down. What do you see for the “5” key, when the Option key is held down?

    The only other possibility I can think of is that Language and Region settings are affecting this in some way. Could you let us know what settings you have there and what version of OS X you are using? I’m glad you’ve found a way round this but we’d like to understand what was causing the original problem, as we might be able to address it in the product.

    Thanks for any assistance you can provide in helping us track this down.

    #544233 Reply

    hluebeck
    Participant

    On my Mac (also with macOs High Sierra) the Option-5 key (ALT-5 Key) maps to the [ Char.

    I use a German keyboard.

    Please see my Attached Screenshot of key Bindings and Keyboard Mapping.

    Attachments:
    You must be logged in to view attached files.
    #544291 Reply

    support-tony
    Keymaster

    hluebeck,

    Thanks for that information. It makes the situation very clear. I’ve raised a bug to try to ensure this issue won’t happen in future.

    Sorry for the inconvenience and thanks again for raising the issue.

Viewing 6 posts - 1 through 6 (of 6 total)
Reply To: Problem with '[‘ Key on macOs in JavaScript Editor – Waring about unsend snippet

You must be logged in to post in the forum log in