Project is missing a required library

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of support-joy support-joy 4 years, 9 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #314342 Reply
    Profile photo of bongo666

    I am getting the following error:

    Project 'myProjectEJB' is missing required library: '/myProjectEAR/lib/ibmjsse-5.0.jar'

    my structure is:

    myProjectEJB (depends on myProjectEAR)
    myProjectWAR (depends on myProjectEAR)

    The thing is that I can see no reference to that library in either the EJB or WAR project build paths.

    I was using MyEclipse Blue 8.5 with ibmjsse-5.0.jar in the build path for the WAR & EJB projects, and the actual library in the EAR project. All was OK.
    I then decided to remove the ibmjsse-5.0.jar library – I did this by refactoring as can be seen in the Refactoring History of the EAR project. Again everything worked OK.

    Since then I upgraded to MyEclipse Blue 8.6 and now am getting build errors. I’m not sure if the upgrade has caused the problem or what.

    I’ve done a search for an occurence of ibmjsse-5.0.jar in the code by using a File Search (containg text…) in the IDE and a file system search for anything containing the text outside the IDE. Nothing shows up. The library in not listed in either the EJB or WAR build path libraries.
    I’m now at a loss to resolve the build path error.
    Can anyone help?


    #314370 Reply
    Profile photo of support-joy


    Can you quickly answer the following –
    1. Can you copy and paste your installation details? Open MyEclipse IDE, from menu options click on MyEclipse > Installation Summary > Installation Details.
    2. Can you copy and paste your .log file located at [your workspace dir]/.metadata/.log?

    Thank you.

Viewing 2 posts - 1 through 2 (of 2 total)
Reply To: Project is missing a required library