Project loses EAR Facet after close and reopen

  1. MyEclipse IDE > Installation, Configuration & Updates

This topic contains 8 replies, has 3 voices, and was last updated by  ibanezje 4 weeks, 1 day ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #664027 Reply

    Patrice
    Participant

    Well the title says it all.
    I hava projects configured with EAR facet.
    When I close the project and reopen, the facet is gone. Pretty annoying.
    This has worked ok before. current ME version: 2020.9.16

    cheers Patrice

    #664122 Reply

    Brian Fernandes
    Moderator

    Patrice,

    I’m sorry we missed this post last week – that behavior sounds very odd.

    1) What if you restart the Eclipse session without closing the project – is the facet retained then?
    2) Can you tell me what version of MyEclipse you were using before – did it start happening only after the 2020.9.16 update?
    3) Please send us your workspace log file – you can find it at [workspace_location]/.metadata/.log

    #664160 Reply

    ibanezje
    Participant

    1 with project open and restart, the facet is retained
    2 not 100% sure but it seems it worked before the 2020.9.16 update. Cant remember what version that was but I always upgrade to the latest version when ME promps me to.
    3 see attach

    Attachments:
    You must be logged in to view attached files.
    #664166 Reply

    Brian Fernandes
    Moderator

    The log doesn’t indicate any facet removal, however, it does show several facet related errors in your project. It may be that the facet is present, but when you open the property page to check, an error prevents the page from being correctly initialized, resulting in that facet being unchecked. If you close / apply changes now, the facet may actually be removed by this page if you don’t check it again.

    1) When you close and reopen your project, instead of opening the property page, can you check the contents of the .settings/org.eclipse.wst.common.project.facet.core.xml file? See if it has an <installed facet="jst.ear" ...> element?

    2) I see this error in the file java.lang.IllegalArgumentException: Path must include project and resource name: /WPLscan_PROD as being the root of many problems. Have you renamed or moved the project? Is WPLscan_PROD the name of an existing project in your workspace – is this the project losing facets?

    3) Could you try creating a new dummy EAR project and see if the issue can be replicated with this project?

    #664168 Reply

    ibanezje
    Participant

    1 . <faceted-project>
    <runtime name=”was.base.v85″/>
    <installed facet=”jst.ear” version=”6.0″/> </faceted-project>

    So facet is still configured but properties panel doesn’t show it. More important, when I want to deploy to Websphere, the project is not selectable as an available resource (because is is not recognized as an Ear I suppose)

    2. I have multiple EAR projects in the same workspace, WPLscan_PROD is one of them. Every EAR project has this same behaviour. Nothing has moved.
    3. When I try to create a new EAR project nothing happens, but error messages appears in error log. Also , new WebProject doesn’t work. See log attachment

    Attachments:
    You must be logged in to view attached files.
    #664221 Reply

    Brian Fernandes
    Moderator

    Patrice,

    This is beginning to look more like a corrupt install with key bits missing according to your log file – perhaps something went awry with the update. The fact that you cannot even create a new WebProject is indicative of how corrupt your install probably is.

    Can you start MyEclipse just once with the -clean argument, and if that doesn’t resolve the issue, can you download a fresh offline installer and use the repair option to repair the current installation?

    #664225 Reply

    ibanezje
    Participant

    I did a complete clean install, -clean and repair did not work.
    Even the clean instal did not resolve the issue in this specific workspace.
    When I create a new workspace, all problems are gone and I can create a fresh EAP project.
    So the trouble is in the workspace.
    Is there a way to copy or duplicate a workspace to a fresh initialized new workspace?

    #664227 Reply

    Brian Fernandes
    Moderator

    Hmm, I was going to suggest a new workspace, but didn’t think it would resolve this sort of problem, so didn’t bother. Glad you tried it out.

    To import projects, if they’re all in the same directory, you can just use the Import project wizard, specify that directory and it will pick them all up. Any version control systems they’re connected to should get automatically initialized as well. If it’s more complicated than that, you could look at exporting a Team Project set from the export wizard.

    For preferences, you can export and import some of the preferences from the preference export / import wizard.

    Hope this helps!

    #664244 Reply

    ibanezje
    Participant

    Ok so importing in new workspace worked, but needed some tweaking here and there, but I got it to work .
    Thanks for the support!

Viewing 9 posts - 1 through 9 (of 9 total)
Reply To: Project loses EAR Facet after close and reopen

You must be logged in to post in the forum log in