Project test-a is not an Angular CLI project

This topic contains 1 reply, has 2 voices, and was last updated by  Brian Fernandes 4 days, 21 hours ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #586418 Reply

    mpwillia401
    Participant

    Recently I upgraded to angular CLI 6.0.1. After upgrading the Angular IDE for Webclipse would no longer run my project called “test-a”. It would give me the error “Project test-a is not an Angular CLI project”. I believe the problem roots with the change Angular made to .angular-cli.json. In Angular CLI 6.0.+ .angular-cli.json was renamed to angular.json. To get the Angular IDE for Webclipse to work again I had to create a soft link in the file system.

    #586444 Reply

    Brian Fernandes
    Moderator

    You’re right – we do have a compatibility issue with Angular 6, one of the reasons being the change from .angular-cli.json to angular.json. You’ve applied a fine workaround for now.

    The good news is that we have these issues fixed and will be releasing an update to Angular IDE tomorrow which will be more compatible with this release.

    Apologies for the inconvenience caused.

Viewing 2 posts - 1 through 2 (of 2 total)
Reply To: Project test-a is not an Angular CLI project